Xampp on Server 2008 not accessible from outside

I have installed xampp (orangeHRM) to run the OrangeHRm software. I currently have it running fine and accessible from my test machine (windows 7 pro) I can access from externally www.orangehrm.mywebsite.com not issues. So I exported the db and set it up on the server internally I can reach it  192.168.2.19/login.php no problem and the imported DB all the data is showing up perfectly, now I want to access it from www.IPAddress/orangeHRM but I cannot, I am getting no errors it just won't resolve from the server. Once I get it to resolve with the IP address then I will change the DNS to point to the new IP address. Below is the vhost file :

#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
#NameVirtualHost *:80


#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ServerName or ServerAlias in any <VirtualHost> block.
#
<VirtualHost *:80>
    ##ServerAdmin postmaster@dummy-host2.localhost
    DocumentRoot "C:\Program Files (x86)\OrangeHRM\2.6.5\htdocs\orangehrm-2.6.5"
    ##ServerName dummy-host.localhost
    ##ServerAlias www.dummy-host2.localhost
    ##ErrorLog "logs/dummy-host2.localhost-error.log"
    ##CustomLog "logs/dummy-host2.localhost-access.log" combined
</VirtualHost>
##<VirtualHost *:80>
    ##ServerAdmin postmaster@dummy-host.localhost
    ##DocumentRoot "/xampp/htdocs/dummy-host.localhost"
    ##ServerName dummy-host.localhost
    ##ServerAlias www.dummy-host.localhost
    ##ErrorLog "logs/dummy-host.localhost-error.log"
    ##CustomLog "logs/dummy-host.localhost-access.log" combined
##</VirtualHost>

##<VirtualHost *:80>
    ##ServerAdmin postmaster@dummy-host2.localhost
    ##DocumentRoot "/xampp/htdocs/dummy-host2.localhost"
    ##ServerName dummy-host2.localhost
    ##ServerAlias www.dummy-host2.localhost
    ##ErrorLog "logs/dummy-host2.localhost-error.log"
    ##CustomLog "logs/dummy-host2.localhost-access.log" combined
##</VirtualHost>
padillrrProject CoordinatorAsked:
Who is Participating?
 
Frosty555Commented:
Maybe I misread your question - this sounds more like a firewall issue, especially since you've already successfully set it up on Windows 7. You clearly know what you're doing as far as typing the correct address into the browser bar goes ;)

Server 2008 has a very strict firewall for incoming connections. Open "Windows Firewall with Advanced Security", and create a new Inbound rule that allows TCP traffic on port 80 and 443.

Check this guide:

http://www.windowsnetworking.com/articles_tutorials/configure-Windows-Server-2008-advanced-firewall-MMC-snap-in.html
0
 
achaldaveCommented:
try ipaddress/orangeHRM instead of www.ipaddress
0
 
Frosty555Commented:
Resolving like "www.IPAddress", e.g. "www.192.168.2.19", is not valid - you either use a fully qualified domain name (which will be resolved into an IP Address by your DNS server), or you use an IP address directly, you can't mix the two.

If you must have a name and you don't have a DNS server you can easily configure, you can temporarily edit your hosts file so that "www.somehostname" resolves to your IP address, and proceed from there.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
padillrrProject CoordinatorAuthor Commented:
I would of course use the external IP address not the internal which is how I tested my setup on the dev server which is actually working. I first tested it with the external IP it worked then i pointed my DNS to that I P and it resolved no problem. I just can't make it work from the server 2008. The changes I made on the dev were very simple, I've tried all of that on the server and none of the changes work. Not sure if it's the Vhost file. I did have IIS running and it would resolve to the IIS default page if I just put the external IP of the server on the browser but once i changed it to Apache it is not resolving to port 80 or any port for that matter.
0
 
padillrrProject CoordinatorAuthor Commented:
Funny thing is that I can access port 80 via IIS and connect to the default IIS page. I turn IIS off and turn apache on but I get no access. I can access locally i.e. Localhost or the internal IP but just can't get to connect. I've double checked my forwarding on the router and the firewall settings. Kinda stuck.
0
 
padillrrProject CoordinatorAuthor Commented:
Had to create a rule for the Apache HTTPD and it allowed me in. Great Job Thanks! Seems the WWW rule that is generically made is not enough.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.