Shutting down Windows 2008 server - stuck - Notifying services that windows is shutting down

HELP - after possible problems wit ESET AV on a server we had went to remove it and had issues. The remove did seem to halt and some processes had to be killed.

In the end we needed to restart, however the Server screen has got stuck saying

"Notifying services that windows is shutting down"

For about 20 minutes. I'm scarred to force a restart at this point. Any advice VERY much appreciated?
afflik1923Asked:
Who is Participating?
 
Darius GhassemCommented:
Force reboot that is the only way or you can wait
0
 
afflik1923Author Commented:
how long would I have to wait? Is there a big risk in a force reboot?
0
 
estuardohCommented:
I think you must to unplug the server o power off from the PDU
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Darius GhassemCommented:
However long it would take to shutdown, it might not even shutdown properly.

Sometimes there is a small risk with data lost if the system didn't write all the data to the drives that were existing in memory but usually you have no problems
0
 
AquatoneCommented:
Could try just unplugging the UTP cable from the NIC if you are nervous about forcefully powering-off the server.
0
 
afflik1923Author Commented:
I'll try the network unplug, but then looks like I'll force it. Reckon I should try just pressng the power button first, and then if no esponse holding it down?
0
 
Darius GhassemCommented:
Press Power button see if windows will force it down. Then hold
0
 
afflik1923Author Commented:
Many thanks. It worked.
0
 
FlatheadITCommented:
Hmm, while I realize this post is ancient - we have the same issue April 2015 3.5 years later - however this is now happening on an ESXi 5.5 platform.  This is also an issue with ESET Nod32 antivirus.

A forced shutdown does NOT work, there is no way to Power off/unplug the VM and all options are greyed out in Vsphere.  I am awaiting a resolution from VMWare for this issue - none of the above posts are an exact fit here.

"Notifying services that windows is shutting down..."  - same error - different host platform.

We have waited over the entire weekend.  So, I do not believe this issue will resolve itself.  

I have been reading posts - all of which are great in theory but none of them appear to work in this situation.  

shutdown - (multiple switches - multiple attempts - none work)

run process explorer and kill the svhost process associated with xxxx (multiple suggestions here)
- our issue - we cannot run any PSEXEC or remote commands on this beast.

physically unplug/power off.  Seriously?  On a VM?  (obviously irrelevant here!)

ESX issue where running some shell commands after starting an SSH session  would allow you to kill this server/vm process on the host itself - we tried this but these commands do not work in ESXi.

So, this issue will be bumped to VMware support.

Does anyone else have any ESET issues on VMs?  I am wondering if I should post the solution here to avoid the angst for others or if anyone else has even experienced this or not.
0
 
FlatheadITCommented:
Okay - here is the deal - ESXi would use the following commands:

(SSH into the host first)

esxcli vm process list
          (use this command to list the running vms and to show the world-id of each one in order to kill the correct VM)

esxcli vm process kill --type <str> --world-id <str>

           (options are soft, hard, or force)  vmware states that force should be used as a last resort because it will shutdown this without a chance to shutdown cleanly.

example:
esxcli vm process list

VSERVERXYZ
   World ID:  55555
   Process ID: 0
   VMX Cartel ID: 55552
   UID 55 55 55 55 55 55 555 55 55 55 55 55 55 55 55 55 (some hex numbers here)
   Display Name:  VSERVERXYZ
   Config file: /vmfs/volumes/(long wwwn name here/VSERVERXYZ.vmx


esxcli vm process kill --type soft --world-id 55555


So, you can use soft here, hard, or force.

Happy VM'ing!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.