[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 619
  • Last Modified:

RDP Connections

Hi all,

My server- ACT-SVR keeps disconnecting people.  Then stops them from connecting again.  The user is presented with the error that the host cannot be found, however it is pingable by name and I can browse the file structure on the C: drive during this time.  It seems to only be RDP.  There are no firewalls involved in any of this traffic, including on the server and client machines.

My maximum allowed connection for some reason is only 2.  We've had at least 20 logon at the same time in the past, however today it will not allow more than 2.

Any ideas?
0
jsctechy
Asked:
jsctechy
1 Solution
 
jambraunCommented:
Silly question, did you lose your Terminal Services licensing or connection to the server?  Sounds like a terminal services issue from first glance.
0
 
jboozCommented:
I would try to look at your terminal services manger.  Check to see if people are not actually logging off.  If they are still logged in, log them off and restart your server.  
0
 
jsctechyAuthor Commented:
When I check the terminal services licensing on this server, it points to another server- which is a DC.  Seems to have connectivity to it.  I'm not too familiar w/ licensing
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 
jambraunCommented:
Try jbooz's suggestion.  If you right-click on the taskbar and select properties, you can view all those signed on.  Maybe you have 18 people disconnected?
0
 
jambraunCommented:
And I have to ask because...it's IT....did you reboot the server?
0
 
jsctechyAuthor Commented:
The server was rebooted 3-4 times.  There are no users in the 'disconnected' state.  I have a message in the "Terminal Services Configuration" - under RDP Properties, and then under the Network Adapter tab
"This server is configured in the default Remote Desktop mode for remote administration, which allows a maximum of two simultaneous remote connections".

I'm not sure why that is, but I've tried changing it to 20, but it will not take.  Do these RDP/TS licenses expire?
0
 
jsctechyAuthor Commented:
Also looking at the licensing server for TS, the ACT-SVR isn't even listed in there.  Strange....
0
 
jambraunCommented:
They may but I assume that's centrally stored.  Obviously you can't enable services you don't have rights to at the moment.  It's worth an inquiry at least.

Otherwise, are there any system messages in the logs? Errors? I'm not going to recommend hacking the registry but it's an option.
0
 
jambraunCommented:
Ah....add the TS server!
0
 
Sushant GulatiConsultantCommented:
The remote desktop mode will only 2 connections which of course only be the Admins connections no such user without having the administrators group membership shall be allowed to create the RDP connection with their user id.

Yes, check your TS Licensing and if you are sure that this TS server were used to accept more than 20 concurrent connections then check this key in the registry and check the "MSLicensing" key.. Follow the link given below..

http://technet.microsoft.com/en-us/library/cc756826(v=ws.10).aspx#BKMK_8

Good Luck..!!
~SG~
0
 
jsctechyAuthor Commented:
How do I add the TS to the license server?

Susquperf,
I'm tried those solutions... still only allowed 2 connections.
0
 
jambraunCommented:
I think this is it:

http://technet.microsoft.com/en-us/library/cc725748(WS.10).aspx

Connecting to a Terminal Services License Server

Updated: January 10, 2008



After installing TS Licensing, you can use the TS Licensing Manager tool to connect to and manage Terminal Services license servers.

If you want to use TS Licensing Manager from another Windows Server 2008 computer, see Installing TS Licensing Manager.

Membership in the local Administrators group, or equivalent, is the minimum required to complete this procedure.
 To connect to a Terminal Services license server 1.
Click Start, point to Administrative Tools, point to Terminal Services, and then click TS Licensing Manager.

2.
On the Action menu, click Connect.

3.
In the Server box, type the name of the license server to which you want to connect, and then click Connect.


When TS Licensing Manager opens, it tries to find all the license servers in the workgroup or domain that are automatically discoverable and to which the user has the appropriate administrative permissions.
0
 
jsctechyAuthor Commented:
I'm using Server 2003, and I don't see the option in step 1,

"Click Start, point to Administrative Tools, point to Terminal Services, and then click TS Licensing Manager."

There is no "LIcensing Manager".  I have Terminal Services Licensing, but nothing else.

I found this message in my TSL server event log:
The product Windows Server is out of licenses.  Use Licensing from the Administrative Tools folder for more information on which users are out of compliance and how many licenses should be purchased.

I'm not sure if this is related to TS or to just Windows Server 2000/20003 users.
0
 
jambraunCommented:
Try this:

http://technet.microsoft.com/en-us/library/cc737644(WS.10).aspx

Set preferred Terminal Server license servers

Updated: January 21, 2005

Applies To: Windows Server 2003, Windows Server 2003 R2, Windows Server 2003 with SP1, Windows Server 2003 with SP2





To set preferred Terminal Server license servers


At a stand-alone server:
Using Group Policies (best practice)


Using Terminal Services Configuration


Using the registry




Using Group Policies (best practice)

1. Open Group Policy.


2. In Computer Configuration, Administrative Templates, Windows Components, Terminal Services, double-click Use the specified Terminal Server license servers.


3. Click Enabled.


4. Enter the names of the Terminal Server license servers you want this Terminal Server to contact first when attempting to obtain client access licenses (CALs), and then click OK.



Important
 You should thoroughly test any changes you make to Group Policy settings before applying them to users or computers. For more information on testing policy settings, see Related Topics.



Notes
 To perform this procedure, you must be a member of the Administrators group on the local computer, or you must have been delegated the appropriate authority. If the computer is joined to a domain, members of the Domain Admins group might be able to perform this procedure. As a security best practice, consider using Run as to perform this procedure.


 This Group Policy setting is only available on Windows Server 2003 with Service Pack 1, or with the Service Pack 1 versions of System.adm Group Policy template files installed in your Terminal Server environment.


 Use this procedure to configure the local Group Policy object. To change a policy for a domain or an organizational unit, you must log on to the primary domain controller as an administrator. Then, you must open Group Policy through the Active Directory Users and Computers snap-in.


 You can also set preferred license servers by using a Windows Management Instrumentation (WMI) script. For three scripts that you can use to set preferred license servers, delete preferred license servers, or query preferred license servers, see "Preferred License Server WMI Scripts" in Windows Server 2003 Terminal Server Licensing (http://go.microsoft.com/fwlink/?LinkID=26220). .



Using Terminal Services Configuration

1. Open Terminal Services Configuration.


2. In the console tree, click Server Settings.


3. In the details pane, right-click License server discovery mode, and then click Properties.


4. Click Use these license servers, and enter the names or IP addresses of the license servers in the text box, separating them with commas.


5. Click Check names, make any necessary corrections, and click OK.



Notes
 To open Terminal Services Configuration, click Start, click Control Panel, double-click Administrative Tools, and then double-click Terminal Services Configuration.


 This feature is only available on Windows Server 2003 with Service Pack 1.


 You can also set preferred license servers by using a Windows Management Instrumentation (WMI) script. For three scripts that you can use to set preferred license servers, delete preferred license servers, or query preferred license servers, see "Preferred License Server WMI Scripts" in Windows Server 2003 Terminal Server Licensing (http://go.microsoft.com/fwlink/?LinkID=26220).



Using the registry

1. Click Start, click Run, type regedit, and then click OK.


2. Locate, and then click, the following key in the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters


3. On the Edit menu, point to New, click Key, and then type LicenseServers to name the new key.


4. Locate, and then click, the following key in the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers


5. On the Edit menu, point to New, click Key, and then type ServerName where ServerName is the NetBIOS name of the license server that you want to use, and then press ENTER.

The new key name can be any of the following designations that represent the license server:

The NetBIOS name of the server


The fully-qualified domain name (FQDN) of the server


The IP address of the server



6. Restart your computer



Notes
 You can also set preferred license servers by using a Windows Management Instrumentation (WMI) script. For three scripts that you can use to set preferred license servers, delete preferred license servers, or query preferred license servers, see "Preferred License Server WMI Scripts" in Windows Server 2003 Terminal Server Licensing (http://go.microsoft.com/fwlink/?LinkID=26220).


 For more information about Terminal Server, see Guidelines for Deploying Terminal Server (http://go.microsoft.com/fwlink/?LinkID=34627)



Information about functional differences

 Your server might function differently based on the version and edition of the operating system that is installed, your account permissions, and your menu settings. For more information, see Viewing Help on the Web.

0
 
jsctechyAuthor Commented:
I tried this too...


Using Terminal Services Configuration

1. Open Terminal Services Configuration.


2. In the console tree, click Server Settings.


3. In the details pane, right-click License server discovery mode, and then click Properties. (I don't have LICENSE SERVER DISCOVERY MODE).

I did the reg key though- rebooted, but still nothing.  Rebooting the TSL server now.
0
 
jambraunCommented:
I guess make sure the TS license server isn't expired either, or blocking by firewall
0
 
jsctechyAuthor Commented:
I was able to figure this out.  For some strange reason my Terminal Server, no longer had the Terminal Service installed.  I went into Add/Remove Programs- Windows Programs, and selected Terminal Services from the list.

Once I did that, I was then able to point it to the licensing server.  Very very strange.  I should enable auditing now....

Thanks to all of you for your help.
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now