Print spooler disabled

We are using group policy to deploy printers from Server 2008 R2 to Windows 7 workstations. Oneworkstation which we have re-imaged is starting up with Print Spooler service disabled, even after changing the start up to automatic.
The event viewer suggests it is because RPC is not running, but it is, and is listed as a dependency for print spooler.
Any ideas?
jackd1Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sid_FCommented:
Is the print spooler bombing out or just not starting? I have had numerous problems with print spooler service stopping on windows servers but its always been down to having an incorrect or corrupt print driver
0
BCipolloneCommented:
Sure I have a few.  Does the computer have Adobe Installed? If so repair it.

Clean out the C:\Windows\system32\Spool\Printers folder

Disable Point to Print restrictions in The group Policy (gpedit.msc > Administrative > Printers)

Remove all installed printers and remove the drivers from the print server - then re-install the printers

Restart your spooler service and verify it is working
0
jackd1Author Commented:
The print spooler works OK while the machine is running if started manually, but is disabled when rebooted.
BCipollone - by Adobe, do you mean adobe reader, flash player, acrobat, or all of them?
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

jackd1Author Commented:
Just for clarification, the actual event message says the RPC server is unavailable, error code 0x800706ba
0
Sid_FCommented:
Are the three services set to auto
1) Remote Procedure Call
2) Remote Procedure Call Locator
3) Print Spooler

0
jackd1Author Commented:
yes all set to automatic
0
johnb6767Commented:
So you have it set to Automatic, but on reboot it is set to Manual?
0
jackd1Author Commented:
Does the RPC Locator have to start before the Print Spooler?
0
jackd1Author Commented:
I have it on automatic. Looking at the event viewer, the service starts on bootup, then stops and is changed to disabled.
0
upalakshithaCommented:
no it is set to manual by default
look at services.msc whether RPC is started. if rpc started
run this first in cmd   SC CONFIG SPOOLER DEPEND= RPCSS
then try to start spooler. if not success,

go to this key in reg edit HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Spooler
look at right side this "DependOnService"  & duble click it.
you will see RPCSS, HTTP are there. remove RPCSS & try to start spooler.
 spooler can start without RPC. but i have not test printing
0
johnb6767Commented:
Might have a driver shot corrupting the spooler....

My standard procedure for removing printers AND thier drivers....

Remove all physical printers.

Once the printer(s) is deleted, go to start>, and type CMD (Right Click, and "Run As Administrator"

net stop spooler
net start spooler

Click Start, and type "Print Management">Print Servers>Local>Drivers>Rt Click a driver and select "Remove Driver Package", and remove them all.....

Note: If this is Anything lower than Windows 7 Professional, use the below command instead of Print Management, as it is not included in lower versions.....

Hit Winkey+R, and paste the following.....

printui /s /t2

It will bring up the classic Drivers tab, familiar with XP. You can remove Drivers from there, after the printers are gone....

Then try and reinstall the network/local printers....

0
jackd1Author Commented:
Sorry. Problem solved. A program called net control 2 was killing RPC.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jackd1Author Commented:
All the other suggestions were tried and didn't succeed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.