Service Pack 1 crashing fresh reload of Vista 32bit

Posted on 2011-10-03
Last Modified: 2012-05-12
I have a Dell XP 420 desktop with a fresh reload of Vista 32-bit.  Upon successful install of the OS and drivers, it crashes when a pre-downloaded copy of Service Pack 1 is installed.  The same predownloaded file has been used several times on other systems, and has been successful.  The bios has been updated to the latest version from Dell's site.

I believe Windows 7 SP1 experienced the same issue, and we have already tried a different hard drive, as it was also determind the hard drive (although it was new) was failing.
Question by:JJMarquart
    LVL 19

    Expert Comment

    Does it crash during the install process of SP1, or after SP1 has finished installing?
    LVL 89

    Expert Comment

    by:John Hurst
    I am not entirely clear. Are you saying you already tried a new hard drive for this Vista machine?

    Try the System Readiness tool for Vista before trying to install SP1.

    See if that allows you to install SP1 (make sure your have the correct SP1: 32-bit, for intel CPU's). See if you can run the MD5 hash verification on the download. ... Thinkpads_User

    Author Comment

    It crashes during the install, but at the final stage, it crashes when the system reboots and performs the 3-step process.  At which it then crashes with an ntoskrn error, and will not boot in any mode; last known-good configuration doesn't work either.  I'll post the exact error tomorrow.

    I'll also try the system rediness tool also to see if that fixes it.
    LVL 77

    Expert Comment

    by:David Johnson, CD, MVP
    you could go right to sp2

    Author Comment

    @ ve3ofa: SP2 requires SP1 to be installed first.

    @ everyone: set sata to non-raid and installing sp1 at the moment.  Will update this post with the results.

    Accepted Solution

    Problem fixed.

    It was the SATA mode; was originally on RAID.  Upon switching it to AHCI non-raid, I was able to install both service packs.

    Author Closing Comment

    SATA controller set to non-compatible setting.

    Author Comment

    SATA controller was set to non-compatible setting.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Hi All Just a quick one for everybody. I was recently looking into setting the default User Account Picture for all my vista clients within the network but on closer inspection the group policy setting only allows you to set the default pictur…
    The Service applet starts in Extended Mode by Default, with a taskpad on the left of the services pane. This view mode was introduced in XP. As I find it not very usefull, I like to use the Standard view as default, and without the Console tree. …
    The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

    761 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    7 Experts available now in Live!

    Get 1:1 Help Now