[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Insert a hyperlink to a file (not a URL)

Posted on 2011-10-03
42
Medium Priority
?
1,002 Views
Last Modified: 2013-12-18
Hi, i am having a difficult time in figuring out how to insert a link to a word document that resides on the network.  It needs to be a clickable link on recipient side.  It seems as though LN allows a URL link but not a link to a file.

I have searched on the website too but did not find anything that seemed o directly deal with this issue.
0
Comment
Question by:pdvsa
  • 17
  • 9
  • 6
  • +3
41 Comments
 
LVL 26

Expert Comment

by:Fred Marshall
ID: 36907422
Open a Word document.
Save it as an .htm/.html file.
type some words for the link
highlight those words
Insert / Hyperlink ... and it will open a file selection / explorer dialog.
Select the file.
Test by pressing Control and clicking on the link words.
0
 

Author Comment

by:pdvsa
ID: 36907535
hi, i dont believe A file saved as an html cant be edited?  LN does not have an easy way to insert a link to a file in its native file extention?  This would be the best way i believe.
0
 

Author Comment

by:pdvsa
ID: 36907548
Or maybe just the directory?
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 24

Expert Comment

by:yo_bee
ID: 36907578
Let me see if I understand what you are looking to accomplish.

Doc1.doc  has a link within it to open another doc or pdf on your network.

Copy the folder path from the address bar
i.e.  \\Server1\Share1\doc1.doc

Then goto Insert > Hyperlink > and paste the address in the address field in the Insert Hyperlink Window/wizard. > Press OK

That is pretty much it.
 
0
 

Author Comment

by:pdvsa
ID: 36907625
Yobee:
thanks for esponse
<Then goto Insert > Hyperlink > and paste the address in the address field in the Insert Hyperlink Window/wizard. > Press OK

i dont believe that is for files but only for a URL.  At least in my version it is.  

Are you certain it is a link to a file or a directory?
0
 
LVL 24

Expert Comment

by:yo_bee
ID: 36907634
What version are you running?
0
 
LVL 24

Expert Comment

by:yo_bee
ID: 36907649
I have been doing it since Office 2000 - 2010

This is from 2007


Screen-Shot-2011-10-03-at-10.58..png
Screen-Shot-2011-10-03-at-10.59..png
0
 
LVL 24

Expert Comment

by:yo_bee
ID: 36907664
If you want to browse you can click on the folder that is annotated with a red rectangle.

Screen-Shot-2011-10-03-at-10.58..png
0
 
LVL 26

Expert Comment

by:Fred Marshall
ID: 36907783
You could also save it as a .doc file.
The hyperlink insert tool works there as well.
0
 
LVL 24

Expert Comment

by:yo_bee
ID: 36908964
@Fmarshall

How would a link be inserted by saving the file?
0
 

Author Comment

by:pdvsa
ID: 36909445
Yobe:  
I believe you have given instruction to inserting a link Within WORD.  It is Lotus Notes what i am interested in.

Do you know how to di the same within LN?
0
 
LVL 24

Expert Comment

by:yo_bee
ID: 36909456
sorry.  I misunderstood your question.  I am not a Lotus Notes guy so LN did not jump out at me.

Sorry for the confusion.
0
 

Author Comment

by:pdvsa
ID: 36909758
I looked again and I dont know how I posted this to the wrong area.  Anyways, I think I will ask for attention.   Sorry about that.
0
 
LVL 10

Expert Comment

by:doninja
ID: 36910301
Similar process for lotus notes. You can either just paste in the path to the file and add to the beginning file:

so as example it would become file:\\server\share\directory\filename.ext

Try to not use spaces or from within the notes client start your new mail etc and in the body area select create hyperlink and replace http:// with file: and past in path as above.
0
 
LVL 26

Expert Comment

by:Fred Marshall
ID: 36911032
yo bee:  A link is NOT inserted by saving the file.  But getting an html file with Word is had by saving a blank file.  Not a big deal.    ...... and, this isn't a chat room.
0
 

Author Comment

by:pdvsa
ID: 36913603
doninja:
You mean like this:
file:\\C:\Documents and Settings\fin001\My Documents\Work\Technip\Customer Docs\Worley Parsons\KQ comments.doc

It did not open the file although it did appear as a hyperlink
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 36913675
Can you insert a link hotspot?
0
 

Author Comment

by:pdvsa
ID: 36913918
I dont think so.  I just tried it and you have to select some text in the email then Create / Hot Spot and the choices after that are only URL, Link and Named Element.  the Link choice does not have a field to paste a link such as a path to a file or at least it is not intuitive.

I do not like LN.  
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 36915318
In the link hotspot, add the URL in the form of file://c:/path/file.doc
By the way, the earlier file-url was incorrect, a url must contain slashes instead of backslashes.
0
 
LVL 22

Expert Comment

by:Bill-Hanson
ID: 36916377
Sjef is right.  This is as easy to accomplish in LN as in Word.

1) Select some text.
2) Select Create > Hyperlink from the menu.
3) Enter the URL to the file.  URLs to files are allays in the form "file://PATH", just like Word and every other client I've seen.  So if the file is C:\Temp\some.doc, then the URL would be "file://C:\Temp\some.doc" (without the quotes).
0
 

Author Comment

by:pdvsa
ID: 36916381
sjef:  
<In the link hotspot, add the URL in the form of file://c:/path/file.doc
==>Ithe only place where I see a field might be able to accept a file path is under the field called "VALUE" but not sure why it would be called that name if it accepts a URL.  Anyways, I tried it and it opens up the internet within LN but it does not open the word doc.  I thinik it is only for a URL and not a file or at least it seems so.

file://C:/Documents and Settings/fin001/My Documents/Work/Technip/Customer Docs/Worley Parsons/KQ comments.doc

When I do put the path there in the Value field, LN puts another slash mark in the front making it 3 instead of 2 ...file:/// instead of file://   dont know if that makes  a diff.

It seems as though LN can not link to a file?
any other ideas?  
   Hotspot Link
0
 
LVL 22

Accepted Solution

by:
Bill-Hanson earned 800 total points
ID: 36916438
I just did the same thing - link to a word document in My Documents, but it worked as expected (ie: MS Word launched and opened the document for editing).

One difference, my URL Value did not change after I entered it.  Are you sure you typed it in correctly?  I don't see 3 slashes in the screenshot above.

Also, I see forward slashes in the file path.  They are supposed to be backslashes.  IE: "C:\Documents...", not "C:/Documents...".  This is probably why it's not working.

Another difference, I have my client setup to use the OS default for links, not Notes.  I don't like using Notes as a web browser, so the first thing I do after setting up a Notes client is to change the web browser setting (File > Preferences > Web Browser > Use the browser I have set as the default...
0
 

Author Comment

by:pdvsa
ID: 36917005
Bill...thank you,
is there suppose to be  "file: \\"  in front fo the C:  
like this:
file:\\C:\Documents and Settings\fin001\My Documents\Work\Technip\Customer Docs\Worley Parsons\KQ comments.doc
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 36917131
It is file:// always, with the slashes, otherwise it isn't a proper URL (which it should be). The path may contain backslashes.
0
 
LVL 22

Assisted Solution

by:Bill-Hanson
Bill-Hanson earned 800 total points
ID: 36919615
OK, it's URL 101 time!  :)

A basic URL has 2 parts: a protocol and an address.  For web links, the protocol is normally "http" or "https".  For a file link it is always "file".

Next, comes the colon (:) and two forward slashes (//).  Not backslashes.  So web links start like this...

      http://
      https://

and all file links start like this...

      file://

Next is the address.  For web addresses, the path is delimited with forward slashes (/).  For file addresses, it depends on the operating system.  Windows uses a backslash (\), Linux uses a forward slash (/), and Apple uses a colon (:).

So in your example above, for a Windows file system, you would use:

file://C:\Documents and Settings\fin001\My Documents\Work\Technip\Customer Docs\Worley Parsons\KQ comments.doc

Notice that the protocol part uses forward slashes and the file path uses backward slashes.
0
 

Author Comment

by:pdvsa
ID: 36920303
Bill

does anything look wrong here?

file://C:\Documents and Settings\fin001\Desktop\Hello2.doc

Please see screen print as well.
untitled.JPG
0
 

Author Comment

by:pdvsa
ID: 36920310
nevermind the UserName part...
0
 
LVL 22

Expert Comment

by:Bill-Hanson
ID: 36920667
That looks good to me.

My only concern is that you seem to be linking to a non-shared location.  Are you sure the file is there?
0
 

Author Comment

by:pdvsa
ID: 36921292
Yes, the file is definitely there.  I right click the file and see the path and this is what I am using.

Anything else?

LN sure does make it difficult to do somethign that should be so simple.  
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 36921422
I can only confirm that it work exactly as Bill says. If you replace all backslashes by slashes (don't!) the file opens in the browser. Even the spaces in Documents and Settings don't seem to be an issue.

Do you send the mail? Try first to save the mail only, using Ctrl-E and Save only, and then click the link. Does the file open? Here it does. I hope you understand that, when you send the mail, the file won't be sent along, for you send only the link to a file, not the file itself. Consequently, the receiving user cannot open the mail when it is on your (local) disk. Hence Bill's question about the non-shared location.
0
 
LVL 10

Expert Comment

by:doninja
ID: 36922689
yep was typing wrong on first post as people have stated it is forward slash not backward on the initial part of the link.

This all uses your current browser functionality to open a file.

To see if it works in your operating system ok, you can try to put the link in the run or search box under start button. Or use IE and put in the address bar replacing the http://blah.blah

this should initiate a browser open/run on the selected file and test that it works as a link.

Final is that some browsers do not like spaces in a url and don't convert but most should be ok in this situation.


Lotus does make file sharing easy if using the right tools. With QuickR or similar file storage the file is placed in a shared location where a simple link to the file can be sent or made. You can also drag and drop file into a mail to have it attached automatically.
Just because a user can see a file it cannot be assumed others can see a file, such as on a local hard disk and not on a server so some file management/sharing should really be setup.
Looking forward to 8.5.3 the new File Connections addons will allow simple file sharing using drag and drop on the client.
0
 

Author Comment

by:pdvsa
ID: 36926197
sjef:
<Do you send the mail? Try first
I tried to send to myself but the link does not work.  It says it cant find the file.  The path I gave is from right click of the file so that must be teh path.  

WAIT!
I did get the file to open in the web browser.

this is teh exact path I used:
file://C:\Documents and Settings\anjohnson\My Documents\Work\Technip\Customer Docs\Worley Parsons\KQ comments.doc

(but the browser removed the file:// part)

I tried again in LN but to no avail.

What do you think?
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 36927763
Can you try from a real browser, e.g. Firefox? ;-)

In IE, the spaces might be the issue. Either replace the spaces by %20 or use the internal MS-DOS name of the folders in the path (e.g. docume~1 instead of Documents and Settings)
0
 

Author Comment

by:pdvsa
ID: 36930354
Sjef:  it opened up in Firefox too.
I used teh same exact path as I did in IE:
file://C:\Documents and Settings\anjohnson\My Documents\Work\Technip\Customer Docs\Worley Parsons\KQ comments.doc

I guess I need to make sure that how I am doing this correctly in LN
Please see pic below.

Anything wrong you see?  Or maybe there is some setting in LN that is not correct?


untitled.JPG
0
 
LVL 46

Assisted Solution

by:Sjef Bosman
Sjef Bosman earned 1200 total points
ID: 36938663
Looks good to me, except for the fact that the file is local and nobody but you has access to it.

What if you try this:
- create a mail
- add the hotspot like above
- save the mail but do not send it
- put the mail in read mode (use Ctrl-E)
- click the hotspot

The file should be opened correctly. Proof of concept. Works. QED.
0
 

Author Comment

by:pdvsa
ID: 36938775
OK it actually worked in the READ MODE.   The file did open.

HOWEVER, when I sent it, the link did not work.  It gave me the same error as "cant find file"

What do you think now?  
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 36938851
Try like this:
file://C:\Documents%20and%20Settings\All%20Users.LOG

Instead of the spaces, use %20.

As I suggested before, you could use the MS-DOS names for the directories and files with spaces. Use the Command Prompt window to find out those names., use the command DIR /X to display the short names.
0
 

Author Comment

by:pdvsa
ID: 36941964
sjef:  
It seems like it is something to do with the C: drive because I tried a link to the network and it worked and even with spaces.  

The %20 added was not the solution for linking to the C: though.  

Although it does work when I tried in read mode (cntrol E).

this is what I pasted in the HotSpot Link:
file://C:\Documents%20and%20Settings\anjohnson\My%20Documents\Work\CoName\Customer%20Docs\Worley%20Parsons\KQ%20comments.doc

What do you think?
0
 
LVL 46

Assisted Solution

by:Sjef Bosman
Sjef Bosman earned 1200 total points
ID: 36942008
It worked here, no problem...

Maybe if you replace the colon by %3A, like in
file://C%3A\Documents%20and%20Settings\anjohnson\My%20Documents\Work\CoName\Customer%20Docs\Worley%20Parsons\KQ%20comments.doc

Just guessing...
0
 

Author Comment

by:pdvsa
ID: 36945387
still not working.  

It does work in the READ MODE (control e) but if I send it it is a different story.

I am about to say that there is something wrong with our version of LN?
It works on your end you said, correct?

WAIT!
I CALLED IT.  
This needs to be in the beginning:
\\FS10-HOU\Vol2\

it works now.

I think that Doninja mentioned this in the beginning.  But I thought that the server name was already in the path name but apparently it was not.

thank yoiu

0
 
LVL 46

Assisted Solution

by:Sjef Bosman
Sjef Bosman earned 1200 total points
ID: 36945445
Indeed, you need to include a full network path, starting with the \\ ...

So it works? Great!
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes how to use the Send to Mail Recipient command. The instructions apply generally to Office 2007 and later versions, but Microsoft® Word 2013 was used for the specific steps and figures.  What is Send to Mail Recipient? Send…
Sometimes clients can lose connectivity with the Lotus Notes Domino Server, but there's not always an obvious answer as to why it happens.   Read this article to follow one of the first experiences I had with Lotus Notes on a client's machine, my…
In this video, we show how to convert an image-only PDF file into a PDF Searchable Image file, that is, a file with both the image (typically from scanning) and text, which is created in an automated fashion with Optical Character Recognition (OCR) …
Learn how to make your own table of contents in Microsoft Word using paragraph styles and the automatic table of contents tool. We'll be using the paragraph styles in Word’s Home toolbar to help you create a table of contents. Type out your initial …
Suggested Courses
Course of the Month19 days, 11 hours left to enroll

872 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question