Microtek Scanner Software (Scanwizard) Says I Don't have Admin Privileges - but I do

I am trying to install Scanmaker software (basically the drivers for a Microtek Scanwizard 4700 scanner) on Windows XP.  I have tried installing several different versions of the software, and each time am told "you don't have admin privileges."  This message is generated by the Scanmaker install program, not by Windows.  In fact, I do have admin privileges...I get the same error when I'm logged in as "Administrator!"  I have verified that I have admin privileges by, for example, right-clicking on the Start button, and seeing "Explore all users" and "Open all users," which you don't see if you don't have admin privileges.

I have tried to install in safe mode; no difference.  Anyone know what might be wrong?
LVL 26
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

you can test the software on another xp pc - to see if it is not corrupt
the only other option i see is creating another admin account to test from
akahanAuthor Commented:
Sadly, creating another admin account didn't work.
I'm fairly sure the software itself isn't corrupt, as I have tried numerous versions, all with the same result.  And, it is software that I have successfully installed in the past.

Oddly, I am able to do all sorts of other things that require admin access (like, for example, create an account with administrator privileges!)  It's just this particular software, in all its variants, that won't recognize this.
My first guess is that the Scanmaker installer is getting an error trying to copy a file to a destination folder and is spitting out that "admin" message just because it is the most common reason, but not the only reason.  

Are you doing anything non-default during installation, like  trying to override the destination folder?  Do you have enough freespace on the hard drive?  Are there any network shares involved in the install path?   Anything unusual about protected folders on the hard drive?

If you're not taking the default destination - try it.  If you are, then try giving an explicit destination folder instead.

The latest version of the scanmaker software is available on cnet.   You may want to confirm it is the same version as the one you are using.  Click "Download the latest version" and see if the file you get is the same as the one you are using:

Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

akahanAuthor Commented:
Good thoughts, thanks.  I don't think I'm trying to do anything non-default, no.   I'm downloading the file, and running it, from the c: drive; it expands itself into several directories, and then runs the setup.exe, all from the C: drive, which has plenty of room.

I don't think I've got anything unusual going on with the protected folders on the hard drive, and I ran sfc a few minutes ago to confirm that all my system files are intact.

The  version you've pointed to is for MacOS but, in any event, I've tried several versions of the Scanwizard software, including the latest available from MIcrotek's site.

Some notes that may apply - some relating to XP in spite of the article title.  See especially #19:

akahanAuthor Commented:
I've read through that, which I should have mentioned in the original posting, and unfortunately none of it helped.  #19, in particular, is about permissions required to RUN the software, rather than to install it.

I think I may have to just give up and get a new scanner.  

You don't have any anti-virus running, do you.

Tough one.
it could also be a corrupt OS - did you run sfc, or even a repair install yet ?
http://www.updatexp.com/scannow-sfc.html                        SFC use in XP
http://www.michaelstevenstech.com/XPrepairinstall.htm            Repair install  XP
akahanAuthor Commented:
nobus - as mentioned in an earlier post (but easy to miss), I did run SFC, with no change in the result.

I am using Microsoft security essentials, but even when I turn off real time protection, I have no difference in the result.

try a repair then?
akahanAuthor Commented:
Wouldn't a repair mangle a lot of my current registry settings, necessary for function of my various applications, such that I'd have to re-do their installation and/or configuration?  I've always thought of that as kind of a "last resort".
i never had any problems with it  - but read the article completely first, before starting; always a good procedure to do so
akahanAuthor Commented:
Victory!  Apparently my registry's permissions had gotten mangled somehow.  I was able to solve the problem by running this command:

secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose

After doing this, the software installed without a hitch.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
akahanAuthor Commented:
I found this on my own , eventually.
tx for feedback
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.