OWA, OOF, RWW not working internally or externally

Hi Experts,

I have a issue with OWA, OOF and RWW not working due to some mistakes I may have made during migration. during the migration "set up your internet address" I changed the default remote.thisismysite.com to webmail.thisismysite.com (because I thought I was being smart) and I had also made the mistake of pointing my server dns to some Public DNS servers

I resolved the DNS server issue but setting up my DNS forwarders and that is working but since then all users have lost the ability to use OWA, OOF, RWW (which all worked before I made the DNS changes)

I have A records for both webmail & remote pointing to my server under the forward look up zone
When I type http://127.0.0.1/owa i get to the site ok
but when I type http://localhost/owa I get the page cannot be displayed.
When I try and browse the site via IIS7 I also get page cannot be displayed.

I know this is a DNS issue hoping someone could advise of the best ways forward, could I do more damage if I rerun the setup my internet connection wizard? any help in troubleshooting this would be great.

thanks
LVL 1
lakeofafricaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PapertripCommented:
If you have A records setup for your internal DNS, then why are you using http://localhost ?

Try to access those sites the same way any other user would, using the FQDN.
0
lakeofafricaAuthor Commented:
Hi papertrip,

afraid ignorance is the reason why I tried localhost, my understanding is localhost & 127.0.0.1 are the same but its a good test if DNS is at fault.

when trying to access owa internally with FQDN I get a page cannot be displayed message.
0
PapertripCommented:
All good.

Let's see if you can resolve that hostname first off.  Open up a command prompt and type
nslookup owa.mydomain.com

Open in new window

Paste the output please.
0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

lakeofafricaAuthor Commented:
Ok here you go

C:\>nslookup owa.mydomain.com.au
Server:  servername.mydomain.local
Address:  192.168.0.2

*** servername.mydomain.local can't find owa.mydomain.com.au: Non-exi
stent domain
0
PapertripCommented:
Well that is your first problem :)  You said you enabled DNS forwarding, please provide details on that.  Also you said you have A records setup in your DNS server -- are you able to nslookup any other hosts from different domains that you host on your local DNS server?  Are you 100% certain you have an internal forward lookup zone for mydomain.com.au ?

Let's check external visibility too -- put your FQDN in at http://network-tools.com/ and make sure the output on the next page matches what you expect it to be (mainly the "IP address" output).
0
lakeofafricaAuthor Commented:
Ok here so here goes, just to clarify this is a client site running SBS2011 with about 20computers

DNS fowarding enabled by pointing my server primary DNS to itself then via dns manager right click server name -properties - forwarders - added a number of public dns servers (139.130.4.4, 8.8.8.8, 203.21.20.20)

The host A records created are actually forward lookup zones which have a Host A record pointing to the internal IP of the server, 1 x for remote.mydomain.com.au & 1 x for webmail.mydomain.com.au - this second was created I think because of the initial setup I did when I migrated from sbs2003 and did the setup my internet connection wizard, I changed the default :(

I am not 100% sure of the foward lookup zone question - under forward lookup zones I have the following zones
_msdcs.mydomain.local
remote.mydomain.local
mydomain.local
webmail.mydomain.com.au

I can nslookup to domains outside the network without a problem and emails are all working just not the IIS functionality stuff.

Did the network tools stuff and found that the IP reported is not the same as there static public IP address, I think I know who to call to fix that but still does not explain the internal OWA not working.

thanks for your help you have been helping me move this foward a lot and finding problems I did not know about in the first place...what is weird is that it was all working before I made the DNS fowarding change..
0
lakeofafricaAuthor Commented:
found out a bit more about the different IP address, its for the website hosting, so mail.mydomain.com.au points correctly to the server mydomain.com.au points to where the website is hosted.

also remote.mydomain.com.au also points correctly to the server.
0
lakeofafricaAuthor Commented:
also wanted to check give you all the info, but have disabled IPv6 both via the network card and also via DNS manager as per the attached screenshot
DNSManager.JPG
0
PapertripCommented:
So earlier I had you test nslookup on owa.mydomain.com.au -- but I see now that it's actually webmail.mydomain.com.au.  I just used owa as an example and wanted you to use the actual hostname you have in DNS, so do an nslookup on webmail.mydomain.com.au and paste the results please.
0
lakeofafricaAuthor Commented:
Hi paper trip, so here are the results for webmail and also felt one testing the one that was working was also appropriate to check remote.mydomain.com.au

C:\>nslookup webmail.mydomain.com.au
Server:  myserver.waterfront.local
Address:  192.168.0.2

Name:    webmail.mydomain.com.au
Address:  192.168.0.2


C:\>nslookup remote.mydomain.com.au
Server:  myserver.waterfront.local
Address:  192.168.0.2

*** myserver.waterfront.local can't find remote.mindariremarina.com.au: Non
-existent domain
0
PapertripCommented:
Is 192.168.0.2 the correct IP for the server that is hosting webmail.mydomain.com.au? What happens when you put https://webmail.mydomain.com.au into your browser?  Try from more than 1 machine on the internal network.

You need to add an A record in your forward lookup zone for remote.mydomain.com.au.
0
lakeofafricaAuthor Commented:
yes it is the correct IP

When putting in https://webmail.mydomain.com.au 
I get a page cannot be displayed message on the server and on another machine in the network I get the same thing as well.

0
lakeofafricaAuthor Commented:
These are the forward look up zones that I have plus have created a A record under mydomain.local


FowardLookupzones.JPG
0
lakeofafricaAuthor Commented:
Its something very simple but I have over complicated it because of either the webmail zone or the remote zone.
0
lakeofafricaAuthor Commented:
just wanted to add this to the mix, I have a site thats working fine and comparing settings on my problem site I see this when I highlight the default web site in IIS 7

Unknown.JPG
0
PapertripCommented:
These are the forward look up zones that I have plus have created a A record under mydomain.local
I see the new zones, but did you add the A record for each zone?  I don't mean creating an A record in mydomain.local.
0
lakeofafricaAuthor Commented:
yes each zone has the local IP address of the server.
0
lakeofafricaAuthor Commented:
I should specify that its an A record of the local IP address of the server under each zone
0
lakeofafricaAuthor Commented:
Hi Papertrip,

I stuffed up the certificates, issue was resolved by completing these commands in a exchange powershell window. thanks for all your help, I am awarding the points for sheer effort :) much appreciated.

Set-ClientAccessServer -Identity Myserver -AutodiscoverServiceInternalUri https://remote.mydomain.com.au/autodiscover/autodiscover.xml 

Set-WebServicesVirtualDirectory -Identity "MYSERVER\EWS (Default Web Site)" -InternalUrl https://remote.mydomain.com.au/ews/exchange.asmx

Set-OABVirtualDirectory -Identity "MYSERVER\oab (Default Web Site)" -InternalUrl https://remote.mydomain.com.au/oab
0
PapertripCommented:
Hah awesome!  I won't lie, I wouldn't have even thought of that... (not an Exchange guy)...

Glad you got it fixed!!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lakeofafricaAuthor Commented:
error suggested a problem with IIS and DNS but turned out to be a certificate problem all along.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.