Email Permanently Deleting from Outlook

Hi..

I am using Outlook 2010 with  Exchange 2010 server.

We got mailbox which is shared among few of us.
We noticed emails kept disappearing from mailbox in last few weeks.
I checked in deleted item folder but email were not there. But when is checked in Folder>Recover deleted items, I found all there.

To get make sure no one is permanently deleting email. I took everyone’s permission off from “Exchange management console” apart from me.
But this is still happening.

I have confirmed no email rules setup on outlook.

Now, I have no idea why email is deleting permanently from inbox. (it doesn’t go to deleted item folder)
And this now happening to all email.

Is there any setting on exchange I can change to make it stop deleting? (or set no one can delete anytime from inbox)

Help pls!!



Replaced the "Printers" and "HP Printers" with the "Outlook" and "Email Clients" Zones.

rindi,
EE ZA Storage

Open in new window

propertyozadminAsked:
Who is Participating?
 
apache09Connect With a Mentor Commented:
You may have removed everyones permission via Exchange
However, have you checked the Delegate Permissions on the Shared Outlook Profile itself

Although no one has permissions in Exchange or AD
If somone is listed as a delegate with Editor Permissions on the Inbox they can still delete

You will also need to check outlook option Empty Deleted Items on Exit
As it would appear that one of the users has this option enabled in their outlook profile

0
 
pravinkbCommented:
Users who are accessing the mailbox may have done hard delete (Shift+Delete)

If you have removed everyone permission off on the Shared mailbox then you may have to force the AD replication to make sure the changes are updated on all domain Controllers...
0
 
lucid8Commented:
Agree with Pravin that this is more then likely a hard delete (Shift+Delete) or if a user has an iPhone or smart phone that is causing a delete it may be invoking a hard delete instead of a soft delete
0
 
propertyozadminAuthor Commented:
Thanks,
I am still testing out.
0
 
propertyozadminAuthor Commented:
Problem disappeared by itself
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.