Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1079
  • Last Modified:

How to solve Certificate issue on vSphere Client?

We have on Windows Server 2008 R2 installed vSphere Client. When we start the client it is always showing the error on the picture. Can you please help resolving this?

Other issue is that we have 2 DC's. And they should look the same. But when we open vSphere Client in Datacenter Y, we don't see in the client both, X and Y DC's. But when we open vSphere Client on Datacenter X, we can see X and Y in it. Any tips here as well?

Thanks.

01.jpg
0
ZUNO
Asked:
ZUNO
  • 4
  • 4
2 Solutions
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
You can tick the "Install this cettificate...." and Ignore, or you can install your own certificate.

This is normal, most just Tick "Install" and Ignore. It's because the server is using a self-signed certificate.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
You do not mention which version of vSphere, this is the manual for 4.1.

Replacing certificates
http://www.vmware.com/files/pdf/techpaper/vsp_41_vcserver_certificates.pdf

I would need more information, on the DC question, number of ESX hosts, are you using vCenter, shared storage, datastores, LUNs etc
0
 
ZUNOAuthor Commented:
It is 4.1, so thanks for that link. Will look into it.

Each DC has 2 ESX hosts. We are using vCenter and LUNs.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
ZUNOAuthor Commented:
But I am led to believe that this is because of the certificate issue. Will try to solve that first.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
No, it is notthing to do with the certificate issue. The reason for the warning is because the certificate is self-signed. That's it. If you do not want to use the VMware self-signed certificate

1. either ignore the warning, and install the self-signed certificate.
2. or produce you obtain a new certificate for the server and replace as detail in the document.

Are you connecting to the ESX host or vCenter? If you have vCenter you should connect to vCenter all the time.
0
 
ZUNOAuthor Commented:
All the time to vCenter. It's just when I logon to the SKD1SVC01 I can see in client:

SKD1SVCS01
SKD2SVCS02

but when I logon to the SKD2SVCS01 I can see only this and not D1.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
If you log in directly to an ESX server, you will only be able to see the VMs, that that server is hosting, although you will be able to see all the datastores presented to that server.

If you have vCenter, always log in and manage via vCenter.

0
 
Justin CAWS Solutions ArchitectCommented:
If you're using vSphere 4, here's a quick walkthrough on replacing the default certificate.

http://www.experts-exchange.com/Software/VMWare/A_6949-Replace-vCenter-4-1-default-SSL-certificate-with-a-trusted-certificate.html
0
 
ZUNOAuthor Commented:
Thanks, will test it.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now