How do I disable the Command Bar in IE8

Hi, I am trying to customize Internet Explorer 8 so the user cannot access the Command Bar.  I can hide the Command Bar using the CommandBarEnabled registry key under HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\CommandBar.

The problem I have is that the user can simply re-enable it using the context (right-click) menu.  In IE7 I used the NoBandCustomize key under HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer but this seems to have no effect in IE8.

Does anyone know how I can disable this context menu.

Thanks
LVL 2
nicksbellAsked:
Who is Participating?
 
CanusRufusCommented:
How about network group policy?

Can be set via local group policy as well.
gpedit.msc (in run statement)
 Computerconfigeration --> Administrative Templates --> windows Components --> Internet Explorer --> Toolbars    (lock all toolbars)

Pulled from this link, approx 1500 different ways to set IE
http://technet.microsoft.com/en-us/library/cc985351.aspx
0
 
mrroonieCommented:
hi there, this may work

HKEY_Current_USER\software\policies\microsoft\internet explorer\toolbars\restrictions
Value name: NoCommandBar
Type: DWORD
Value: 1 (on)
0
 
mrroonieCommented:
or if that doesn't work, maybe try the suggestions here - http://eduboris.blogspot.com/2009/08/how-to-lock-down-internet-explorer-8.html
0
 
nicksbellAuthor Commented:
Unfortunately the NoCommandBar key, which is your suggestion as well as the suggestion in the link you provided, removes the entire command bar, including the Tabs.  This doesn't help me as I need to keep the tabs.  CommandBarEnabled is the key used to remove just the command button elements of the command bar but it can be simply reinstated by the user using the context menu.  What I need is to disable the context menu.
0
 
nicksbellAuthor Commented:
Thanks CanusRufus,

That is a very useful link.  In fact the Lock All Toolbars doesn't do what I need but I noticed that there is a Hide the Command Bar setting which, unlike the registry key I used, also disables the context menu item.

Thanks again.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.