Videos don't stream when I click on the list item that holds all my videos in SharePoint 2010

I have created an asset list that holds my videos. When I click on an item (a video), instead of playing it it shows me a window to save the file. All I want is that when user clicks on the list item, the video starts playing.
LVL 1
shieldguyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

celazkonCommented:
I think it depends on IIS MIME settings, how is the particular video filetype served.
So, try to look in the inetmgr application (start, run, "inetmgr" without quotes), click your local webserver name and choose mime types icon on the right pane. Then in the list, find the extension of your videofiles and check the settings. If it is application/octet-stream, then the file is sent and not played. Check some other video filetype settings and compare it.
0
shieldguyAuthor Commented:
My video type is .wmv. I have checked the setting for this in IIS and under column 'MIME Type' the value mentioned is 'video/x-ms-wmv'. Same setting is for all the other video files. This still doesn't work.

0
celazkonCommented:
Seems then it is a browser issue, rather than server. What browser do you use?
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

shieldguyAuthor Commented:
IE 8

Just to let you know that clicking on the thumbnails in the default view (/Forms/Thumbnails.aspx) plays the video. However while clicking on thumbnail in the view (/Forms/VideosListView.aspx) that I created, starts downloading the file.



0
celazkonCommented:
Okay, so that seems like it the code in your view is the cause. Right click on the link in default view and choose properties. Where does the link point to? Compare it to your view.
0
shieldguyAuthor Commented:
Yeah you are right. The one that is playing video is pointing to:
http://ukosp2010wfe01/_layouts/images/VideoPreview.png

and the other one is:
http://ukosp2010wfe01/_layouts/images/icwmv.gif

Can you please tell me how this can be changed. I went into the library settings and tried to find out something there but no luck.
0
celazkonCommented:
I would like, but unfortunately, I don't use sharepoint server. All what I wrote comes from the general fact, that sharepoint runs on IIS webserver, and I work with IIS daily. But, I would recommend to try to change the view itself.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Applications

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.