Group Policy settings not working on XP machines

Ill try to throw out as much info as I can with the time that I have at the moment.

Basic rundown is this...
I came into a clients site having to reverse engineer a lot of things that were done here to try and understand what the previous group had done.  Ive had only a little group policy experience before at another site but what I did worked just fine, but it was for Vista Business machines.

Here on this site we have tried to roll out several group policies and unless its a Win7 machine, they never work.  We use them for printer deployment per pc rather than per user since users move from machine to machine throughout the day.  As I said, if its 7, its fine.  We have no problems with it, but XP refuses to accept any changes.  I can create the policy in the workstation OU and do a gpupdate on the workstation and have it show that its applied if I run gpresult, but the settings never follow through.  Weve done testing with several other types of settings in a GPO but nothing actually happens.
Ive also done testing where I move my Win7 pc over into that out and test the GPO and it works perfectly, but the rest of the XP machines in that OU just wont respond.

Am I missing something for the XP machines here?

And sorry if the post is a bit jumbled, quite a rush this morning.

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pete LongTechnical ConsultantCommented:
How are you deploying them? have you tries with GPP

Deploying Printers with Group Policy Preferences

Remember for XP clients they need the client side extensions installing for that to work, though if you are looking for location based printing why not try:

Windows - Location Based Printing with con2prt


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
columbusdataAuthor Commented:
Im deploying them through the GPO in GP Management.  Going under Computer Configuration and Deployed Printers and adding them in through there.
Ill try and read through those links today, thanks!
That functionality doesn't work by default with Windows XP. Microsoft has a small executable that must be added to the logon script to make this work.

Check this link for more info and detailed information about how to make it work.

Hope this helps.
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

columbusdataAuthor Commented:
Does that still apply if its Server 2003?

And aside from the current printer issue, does anyone have any ideas on why any of the other settings wouldnt be applying?  I dont know that its really a problem with the printer more than just a problem with something stopping the GPO settings.  It looks like the previous group had several GPOs in place, but it doesnt look like they are actually working either.

Wish I could just overhaul the entire lot of servers...
The ability to deploy printers via GPO was introduced in 2003 R2. XP doesn't support it by default, so you would need the executable mentioned in that link to make it work.

As for the other settings, have you used the Resultant Set of Policy to see what settings are being applied from which GPOs and if there are any errors while processing the GPOs? You can run rsop.msc from the Run box and it will show you all the settings that have been applied for the computer and user sections. If you right-click on the computer section and hit properties, you can check to see which policies are being applied. There is also a section in there that shows errors if it couldn't apply certain policies. If there are no errors and it looks like the policies are being applied properly, you can drill down to a specific setting that doesn't appear to be taking effect and it will show you if the setting is being applied and by which policy it is being applied. It's possible another policy is overriding the one you are editing.

RSOP should at least give you some more information about what's going on with your policies. Another thing to look at is the event log on the XP machine to see if there are any errors in there about accessing the GPO or applying it.

Hope this helps.
columbusdataAuthor Commented:
Sorry guys, Ive been swamped with a multitude of other issues here at this site and havent had a chance to follow up with these new suggestions yet.  Ill try to get to them ASAP and let you know the results.

columbusdataAuthor Commented:
Ok, we got the push exe and deployed it to the server with the printer connections we wanted.  I had to do a little cleanup and make a fresh GPO to get the settings to take effect.  I guess an important lesson here is: When in doubt, nuke it and start over.
So thanks for all the information guys, I appreciate it.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.