Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

install jdk

Posted on 2011-10-04
45
Medium Priority
?
426 Views
Last Modified: 2012-08-13
hello I wanna install jdk and eclipse but I dont know.
I have downloaded   ( eclipse-java-indigo-SR1-linux-gtk-x86_64.tar.gz ) and put inside user/share/java  file but them I dont know how to tar this file or which should be the next step?

Thanks
0
Comment
Question by:GiorgioCarlos
  • 23
  • 21
45 Comments
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36910669
Sure it's not /usr/share/java ?

Anyway, from that folder, if you are root/su

# tar xzf eclipse-java-indigo-SR1-linux-gtk-x86_64.tar.gz
or if you can't become su (if using Ubuntu, et al)
$ sudo tar xzf eclipse-java-indigo-SR1-linux-gtk-x86_64.tar.gz

Go into the new folder.  It will likely start with eclipse.  In the new folder, look for  a readme.txt or install.txt file.
0
 

Author Comment

by:GiorgioCarlos
ID: 36910692
i get this: I am in Fedora 14
tar (child): eclipse-java-indigo-SR1-linux-gtk-x86_64.tar.gz: it can't open: it doesn exist the file.
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36910925
Make sure you are in the right folder.  If you can't find the file...

Try this

# find / -name eclipse-java-indigo-SR1-linux-gtk-x86_64.tar.gz

If it's on your system, it should find it.  You'll get some warning messages, which you should just ignore.  
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:GiorgioCarlos
ID: 36913318
Ok this the path:

/usr/share/java/eclipse-java-indigo-SR1-linux-gtk-x86_64.tar.gz
find: `/home/masr/.gvfs': Denied permit
/home/masr/Downloads/eclipse-java-indigo-SR1-linux-gtk-x86_64.tar.gz

0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36913798
Which command produced this?  If it was tar, be sure you are at a # before you use tar to unzip to that folder.

0
 

Author Comment

by:GiorgioCarlos
ID: 36913984
with this:

# find / -name eclipse-java-indigo-SR1-linux-gtk-x86_64.tar.gz, because when you told me that.
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36914589
It is normal for find using the whole filesystem to return a warning.  The point was to find the location of the tarball -- eclipse-java-indigo-SR1-linux-gtk-x86_64.tar.gz

Once you find it, you and use the tar xzf command to unzip it.
0
 

Author Comment

by:GiorgioCarlos
ID: 36914603
this is the file where it is:

/usr/share/java/eclipse-java-indigo-SR1-linux-gtk-x86_64.tar.gz
0
 

Author Comment

by:GiorgioCarlos
ID: 36914605
what should i do next?
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36914697
Try this

$ su
# cd /usr/share/java
# tar xzf eclipse-java-indigo-SR1-linux-gtk-x86_64.tar.gz

and probably

# cd eclipse-java-indigo-SR1-linux-gtk-x86_64
# ls
look for a file like README or readme
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36914701
Have you installed the Java Development Kit yet?  You'll need that too.

Try this as a test

$ javac -version
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36914712
In my copy of eclipse, I ended up with a directory called readme.  My folder is called eclipse.  I might or might not have renamed it.  Not sure.  Anyway, in the ecplipse/readme directory there is an HTML file with more instructions.
0
 
LVL 6

Expert Comment

by:mohansahu
ID: 36914878
Hi,

Plz follow below link for detail in step by step instruction for installing eclipse on Fedora.

http://www.if-not-true-then-false.com/2010/linux-install-eclipse-on-fedora-centos-red-hat-rhel/

MS
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36914969
Sounds like there are special Fedora instructions?  I used Slackware.

0
 

Author Comment

by:GiorgioCarlos
ID: 36917199
Ok hmccurdy
I succed until this:

# cd /usr/share/java
# tar xzf eclipse-java-indigo-SR1-linux-gtk-x86_64.tar.gz

Then what should I do?
0
 

Author Comment

by:GiorgioCarlos
ID: 36917381

I think the problem is cause since I tried to change the permission of usr/share/java...  is impossible to autenticate  in my disk
it ask for autenticate and them I click and them it doesnt work.
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36917570
Is there a message?  Did you read the Fedora instructions suggested by mohansahu

If there are special Fedora instructions, normal Linux instructions will likely not work.  I got Eclipse to work with Slackware.

If the Fedora instructions don't work, perhaps a new post mentioning you are using Fedora.
0
 

Author Comment

by:GiorgioCarlos
ID: 36936361
The problem is that I can not enter to my disk c:, maybe i have done something that I change some permission to system folders,
So what should i do to return to my default permission of the whole thing.
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36937422
OK, what do you mean by authenticate your disk.  What program is trying to authenticate your disk?
0
 

Author Comment

by:GiorgioCarlos
ID: 36945076
When you are trying to install a new package or a new program, the system ask you for authenticate or said in other words, (In windows)
 trying to enter disk c:, but I cannot enter I dont know why?
0
 

Author Comment

by:GiorgioCarlos
ID: 36945663
maybe I need to change the permission of my entire disk?
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36945837
I think you need to enter the password for root on the system.

Another option is open a terminal window and then

$ su
#

From the # you shouldn't need to authenticate further.  Type exit or press CTRL/D to exit from #.   You should not stay at a # longer than necessary.
0
 

Author Comment

by:GiorgioCarlos
ID: 36949798
yeah i tried with $su, I wrote the password, but defeinitely if I want to enter my disk c: It appers me a window I need special permission to enter, so should I change the permissions of the folders or the system folders?
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36949903
I don't know.  It appears you may have extra security that I haven't used.

Which system folders?  (For instance, don't change the perms on /bin, /etc and so forth.)  By contrast, I created a "system" folder called /opt and I made myself the owner.
0
 

Author Comment

by:GiorgioCarlos
ID: 36956468
I think the perms of my entire folder  home/usr/bin   are changed
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36956537
All the files or just the folder?
0
 

Author Comment

by:GiorgioCarlos
ID: 36956740
all the files
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36956792
It is hard to know what they were.  Most of them were likely 755 and owned by root:root.
0
 

Author Comment

by:GiorgioCarlos
ID: 36963425
the fact the disk c: is blocked I can not access
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36963491
The disk C: is a Windows partition?  Is it an NTFS Windows partition?  If so, I think you are "out of luck."  Last I checked, Linux can't write to an NTFS partition.  Only read it.  (Last I checked).  Linux can read and write to a FAT32 partition.

If this is the case, perhaps we can come up with an alternate plan.  I would need to know more about what you are trying to accomplish to help with an alternate plan.
0
 

Author Comment

by:GiorgioCarlos
ID: 36963650
I am not meaning that disk c: is a windows partition I just used this words to explain you that I cannot acces what in (windows we call c:) where is all my data.

There is a windows that appears me that I cannot authenticate
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36963683
It would be easier for me if we used Linux/Unix terminology.

Is the entire partition blocked?  How is it mounted?  (Copy and paste of the associated /etc/fstab line would help.)
0
 

Author Comment

by:GiorgioCarlos
ID: 36963718
#
# /etc/fstab
# Created by anaconda on Wed Sep  7 21:12:00 2011
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/vg_mastermusic-lv_root /                       ext4    defaults        1 1
UUID=54759db8-3c65-417e-a844-6ac62cf6ce0a /boot                   ext4    defaults        1 2
/dev/mapper/vg_mastermusic-lv_swap swap                    swap    defaults        0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
0
 

Author Comment

by:GiorgioCarlos
ID: 36963729
yes the problem I cannot mount the disk
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36963756
Please issue the command

$ df -h
and copy/paste here
0
 

Author Comment

by:GiorgioCarlos
ID: 36963767
S.ficheros            Size  Used Avail Use% Montado en
/dev/mapper/vg_mastermusic-lv_root
                       44G  9.9G   34G  23% /
tmpfs                1002M  1.1M 1001M   1% /dev/shm
/dev/sda2             485M   65M  395M  15% /boot
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36963907
OK, both / and /boot are mounted.  Is there some other partition you want to mount?
0
 

Author Comment

by:GiorgioCarlos
ID: 36964085
yes my disk where I have my data
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36964104
OK, what is the partition called (/dev/what?) and where do you want to mount it?
0
 

Author Comment

by:GiorgioCarlos
ID: 36964121
how can I know how is the partition called?
0
 
LVL 13

Expert Comment

by:Hugh McCurdy
ID: 36964244
Hopefully this will work

$ cat  /proc/partitions
0
 

Author Comment

by:GiorgioCarlos
ID: 36964299
so I must put this     chmod 775 /dev/sda5?

I put It didn't work
0
 

Author Comment

by:GiorgioCarlos
ID: 36964400
major minor  #blocks  name

   8        0  244198584 sda
   8        1   38069216 sda1
   8        2     512000 sda2
   8        3  154928128 sda3
   8        4          1 sda4
   8        5   50686976 sda5
 253        0   46530560 dm-0
 253        1    4128768 dm-1
0
 
LVL 13

Accepted Solution

by:
Hugh McCurdy earned 1500 total points
ID: 36964405
No.  Next you need a mount point.

$ su
# mkdir /mnt/hd                     (this is a mount point, at least for now)
# mount  /dev/sda5  /mnt/hd     (stop after this if you get any error messages and report them to me)
# df   -h

Should show the new partition as mounted and give you space.

0
 

Author Closing Comment

by:GiorgioCarlos
ID: 37032188
thank you
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month12 days, 2 hours left to enroll

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question