Outlooks in Windows XP wont connect to Exchange 2010

Hi there!

I am having a lot of trouble to understand what the problem is. I´ve migrated a domain from Windows 2003 to Windows 2008 R2, witihn the migration we also migrated from Exchange 2007 to Exchange 2010.

All computers using Windows 7 dont have any problem using Outlook 2007 or 2010, but users using Windows XP Pro have problems to connect, and I always get a password prompt.

The only way I´ve been able to connect this Windows XP Pro´s Outlooks is by disabling MSSTD line on the Exchange > Connections tab.

The thing is that disabling this parameter works for one session or so and for some reason it gets activated again and fails to connect.

Any ideas why is this happening and how to solve it?

Thanks a lot!
LVL 1
SurferrideAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
madhatter5501Commented:
are you using basic or ntlm under the outlook proxy settings?  and, is it the same on the xp and 7 machines?
SurferrideAuthor Commented:
Thanks amitkulshrestha but that link suggestions I already followed, actually there is no stated solution on that link.

madhatter5501: Thanks for your comments, I am doing some testing regarding to this.

I´ll keep you posted.
SurferrideAuthor Commented:
OK, found the solution to the problem.

This was suggested by someone on a MS forum:
Check on Your certificate under Details Subject Alternative Name. Whatever is the first name after DNS Name= should be used in MSSTD. For example in my case it was that the 1st line reads DNS Name=mydomain.ee so I changed MSSTD:mail.mydomain.ee to MSSTD:mydomain.ee.

So what I did is to check how the MSSTD was pointing and re-configure it to the first line on the certificate. Windows XP doesnt manages well other lines rather than the first.

This solved the issue.

Thanks a lot for your comments.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SurferrideAuthor Commented:
I found the answer on an MS forum.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.