SBS 2011 DHCP stopped handing out IP addresses

I'm running  SBS 2011 with 15 XP Pro workstations. Everything has been running fine for about 6 months but a few days ago one computer had the yellow ! and would not connect to the network. I configured a static IP and worked fine. The next day three more PCs had the same problem and the next day all of the PCs were not being assigned IP addresses. I rebooted the server, DHCP services are running, firewall is disabled, etc. I've set all of the PCs up with a static until I find a solution to the problem.
JustAnotherGeekAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
First thing is first. I'd run wireshark on both the client and the server to see that:

1) The client requests a DHCP address when using "ipconfig /renew"

and

2) The server is at least receiving that request.

I make this suggestion under the assumption that you have indeed checked the firewall and service already as you stated above, so I am skipping those basic steps.

-Cliff
0
Fred MarshallPrincipalCommented:
What is the lease time?  Maybe all the addresses are leased out?

I recommend 4 hour leases in just about all situations.  The overhead is low enough and the problem of running out of addresses due to long leases is eliminated.   Or, if keeping the "same" dynamic(?) address is important then maybe a bit longer lease time OR assign reserved IP addresses on the DHCP server according to MAC address.  Most DHCP servers can do this.
0
Fred MarshallPrincipalCommented:
And, how many addresses are in the DHCP pool?
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

JustAnotherGeekAuthor Commented:
pool: 192.168.1.10 - 254 are all open. DHCP is not handing out addressed to any device. There are no leases right now.

I haven't tried wireshark yet.
0
Rob WilliamsCommented:
There are some things that will "kill" DHCP on SBS including enabling hyper-V (not supported), or enabling a second NIC can do it sometimes. SBS only supports 1 NIC, all others must be disabled, not just disconnected. Also is there any third party security software installed; Symantec, AVG, etc.?
0
JustAnotherGeekAuthor Commented:
Thany youfor the quick reply. I'm going back onsite tonight to continue troubleshooting and will check out your suggestions.
0
JustAnotherGeekAuthor Commented:
I ran the "fix my network tool" and it reconfigured DHCP but it's still not handing out addresses to any PCs on the network.
The firewall is off, I've checked for any software that could be causing a problem, only one NIC is enabled on the server.
0
Rob WilliamsCommented:
A couple of troubleshooting tests you can do:
-Try running on a workstation the DHCP Locater tool DHCPLoc. It is part of the resource kit or you can download from:
http://www.petri.co.il/download_free_reskit_tools.htm
At a command line enter  
   DHCPLOC  <the work station's IP>
and hit enter (may have to hit enter twice). You will be prompted to enter d, q, or h. Enter d for discover (again may have to hit d twice). It should return the IP of the DHCP server and an offered DHCP address. DO NOT run this on the DHCP server itself, it can damage or disable the DHCP service.
DHCPloc syntax:
http://technet.microsoft.com/en-us/library/cc778483.aspx
http://technet.microsoft.com/en-us/library/cc759117(WS.10).aspx


-Another good test is to run Ethereal, if you are familiar with it, on the server, and filter out all but broadcast traffic, and then run the DHCPLoc tool on the workstation. See if WireShark picks up the DHCP request, and possibly tries to make an "offer".
http://www.wireshark.org/
0
JustAnotherGeekAuthor Commented:
Reinstalling and configuring DHCP solved the problem
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jaredr80Commented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.