• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2906
  • Last Modified:

Slow Latitude D620 absolutely stumping me

I'm working on this Dell Latitude D620 that runs like doo-doo. At first I thought it was malware or a rootkit or a ton of apps. I uninstalled everything. Ran full antimalware utils on it. Ran full antirootkit in Windows and from Linux live cds. Uninstalled free avast. Manually uninstalled remnants of Symantec endpoint protection. Thought memory was bad, removed each 1GB stick and tested. Same probs. (has 2GB total).  Got sick of it so I put in another hard drive and loaded XP SP3 fresh and it STILL runs like doo-doo.

I am sitting here on a fresh installed laptop with all the windows updates installed and all of Dells updated drivers for this model and it is sitting here at 60-70% CPU Usage in the graph in the performance tab..

What doesn't add up is this:
under the "processes" tab, "System Idle Process" stays right around 65-75%. taskmgr around 15, explorer around 15-20 and 3-4 misc others each at 2-4%. If "System Idle" is running at 70% constantly wouldn't you expect the CPU usage on the performance tab to show a graph where CPU usage is around 30%? It's not! CPU usage is pegged at 60-70%!!

What is going on here?
0
RickNCN
Asked:
RickNCN
  • 17
  • 4
  • 2
  • +3
7 Solutions
 
Software_onbekendCommented:
Did you download and installed the latest drivers from Dell..
Be aware that there is a special order to install the software and drivers correctly.
http://support.dell.com/support/topics/global.aspx/support/kcs/document?c=us&cs=555&docid=268873&l=en&s=biz
0
 
Jim-RCommented:
In addition to drivers in the right order, you can use Microsoft's Process Monitor by Mark Rto see what's going on in real time.  This program generates a butt load of information, so you'll want to use the filter function when you spot something of interest chowing down on the resources.
0
 
Dr. KlahnPrincipal Software EngineerCommented:
There may be some illumination in ... "under the "processes" tab, System Idle Process stays right around 65-75%. taskmgr around 15, explorer around 15-20 and 3-4 misc others each at 2-4%."

On a normally operating system, the System Idle Process shows 99% usage and all others show 0% because the CPU usage by other processes is a fixed, but tiny amount.  On a system with a slow CPU, that tiny amount becomes a much larger slice of the pie; and then those other processes, instead of showing 0% usage, now show that they are using a significant amount of the CPU bandwidth.

If that hypothesis is correct, then the CPU is operating correctly, but at much lower than normal speed.  That is possible if it is a laptop CPU in reduced power or reduced speed mode.  It might prove useful to investigate the CPU and memory operation modes using CPU-Z or other system bandwidth software.

If it should develop that the CPU is operating in reduced power / reduced speed mode, then the Control Panel options that allow the system to go to reduced power mode should be investigated, and likewise the BIOS options that control CPU speed and system power consumption.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
RickNCNAuthor Commented:
DrKlahn: Those comments go directly to my hunches on this thing. What you say about a reduced speed CPU making the tiny sliver of CPU usages balloon up makes sense because when I switch tabs in task manager or click the column headers to order things, I see the "task manager" process bump way up in CPU % and I NEVER see that type of thing. MAYBE I'll see task manager process bump a 1% for a split second on a regular system, but to bump up to 15- 25% for a few seconds, that sounds like the slow CPU theory.

Doesn't that inverse "system Idle Process" and "CPU Usage History" graph thing seem strange: If Idle process is at 99% then the CPU usage should be at almost 0%. If Idle is at 70% then it reasons that 30% CPU time is being used, but it's not, I'll see 70% CPU time used, constantly.

I'll check those utilities
0
 
Dr. KlahnPrincipal Software EngineerCommented:
Reduced speed operation would be consistent with severe thermal throttling.  It might be useful to download ThrottleWatch and see if thermal throttling is the problem.

If thermal throttling is the problem, then the usual solution is to open the laptop and remove a wad of cat hair and clothes lint from the undersized heatsink's cooling fins.  Blowing the clog off the heat sink from the outside does not work; it just reattaches itself the next time the fan turns on.
0
 
nobusCommented:
check if the disk is running in DMA - not PIO mode : http://winhlp.com/node/10      
0
 
RickNCNAuthor Commented:
Software: what are the issues associated with not installing drivers in the right order? And if they weren't installed in the right order what can be done to fix that?
0
 
RickNCNAuthor Commented:
ok, so I installed CPU-Z. CPU is an Intel Mobile Core2 Duo T5600 @ 1.83Ghz.

One thing I did yesterday was go into the BIOS and turn OFF the dual core and made it one logical core. (To see what would happen - I'm going to turn that off and re-run CPU-z)  It runs worse now. So, in that mode, CPU-z reports:

core speed: ~998.7 Mhz (sometimes jumps up to 1005.7)
Multiplier: x 6.0
Bus Speed: 167.6 MHz
Rated FSB: 665.8 MHz

The memory is:

DDR2 dual channel total 2048MB
DRAM freq: ~ 335.2 MHz
FSB:DRAM ration 1:2
CL: 5
tRCD: 5
tRP: 5
tRAS: 15
tRC: 20
0
 
RickNCNAuthor Commented:
I changed the settings in the BIOS and set it for two cores again. I also changed the hard drive acoustic mode from "bypass" (I think it's called - slower, compatible with older drives) to "Performance" (louder but faster, etc). Speedstep is enabled. So it should be throttling the CPU. (I'm going to throttle this fing CPU if I can't fix this)

I re-ran CPU-z and the CPU speed is nearly identical: 998.7 mostly but occasionally 1005.7 or thereabouts. Definitely NOT the 1.83 it should be.
0
 
RickNCNAuthor Commented:
I read that Windows has native speedstep drivers installed and that by going into the power button in the screen saver tab (what a dumb place to put it) under "Power Schemes" if you select "always on", speedstep is disabled, running the CPU at full speed. (ref: http://forums.techguy.org/hardware/758557-c2d-not-running-full-speed.html). So I set it to Always On and saved it but I see no change in Core Speed. I'm still at x6. I guess the multiplier should be x11 for full 1.83 speed. I've also installed Orthos Stress Prime 2004 to see if the multiplier kicks up. I'm running two instances of it (per the dev) and stressing each core, 0 and 1 with a CPU stress test. So far no multiplier change.
0
 
RickNCNAuthor Commented:
Oh, I updated the BIOS to A10 from A08 btw.
0
 
RickNCNAuthor Commented:
in the BIOS there's a >Performance> SpeedStep Enable menu. THe options are OFF = place system in lowest performance state... or Enabled = allow CPU to operate in multiple performance states.

Wouldn't you think "Off" would mean allow the CPU to run at it's full speed all the time? OR - give a third option for full speed CPU operation. None of the clocking settings are changeable on this mobo.
0
 
nobusCommented:
any chance to comment on my suggestion?  is it running in DMA ?
0
 
RickNCNAuthor Commented:
nobus: yes, sorry. I double checked and the IDE channels are running DMA if available, not Pio. Good suggestion.
0
 
RickNCNAuthor Commented:
strange, while watching cpu-z I actually saw the  core speed drop to around 600 something MHz. It happened so quick I didn't see the exact Mhz. it was probably x4

Oh, also, I took off the keyboard in order to remove memory and the fan is clean and working.
0
 
RickNCNAuthor Commented:
ok, another wacky piece of info: I downloaded the latest Intel Processor Identification Utility. Its reported speeds are off from CPUz by a factor of 10:

                      Expected           Reported Core1             Reported Core2
Speed                1.83 GHz           0.09 GHz                        0.09GHz              (yes, that's 90 Hz, right?)
System Bus        667 Mhz              65 Mhz                           65 MHz
L2 Cache                                        2 MB                              2 MB

also:

Enhanced speedstep supported
Intel SSE, SSE2 and SSE3 supported. SSE4 not supported
0
 
RickNCNAuthor Commented:
another weird thing to note: I've watched BIOSes load probably tens of thousands of times. I can't recall ever seeing one like this. The Dell bios screen comoes up. Most of the time the loadinig progress bar zips across from left to right in a couple few seconds. Every 5 or ten boots though, it hesitates and halts midway through. Sometimes at the beginning sometimes nearer the end. Am I dealing with a dying CPU? static shocked maybe?
0
 
nobusCommented:
maybe a bad cpu  then ?
0
 
RickNCNAuthor Commented:
I've also dnloaded Notebook HArdware Control. It's supposed to let you control clock speeds and multipliers. It is reporting the CPU is running at 1831 MHz. It seems to be reporting that that is a measured speed, not just a report of the capability of the CPU. On the CPU Speed Control tab, under current CPU settings,  multiplier and voltage are "---" not reporting anything. No matter what speed settings I choose, nothing changes: CPUz reports no changes.

I tried downloading a Speedstep utility from Dell made for this model but when I ran the setup, it started to unpack the setup program but nothing happened after that. It just failed to continue installing.  Weird. I'm thinking dead CPU unless anyone else has any tricks.
0
 
RickNCNAuthor Commented:
GAH!!! I solved it. User had the wrong  power adapter. It was a Dell adapter, but 19.5V and 3.3 A (PA-12 adapter). I looked at that and wondered a couple times because it looked sorta small. I happened to have a larger PA-10 4.6 A adapter so I tried it and VOILA. Feels like normal speed. Attached is the screenshot of the cpu usage chart. The system is idle the whole time. the first low point on the graph is the 4.6A adapter, the spike in CPU is when the 3.3 adapter is plugged in and the third section, the low point is the 4.6A adapter plugged in again.

Still, though, CPUz is telling me the cores are running at 998 MHz. I downloaded Auslogics system information and it confirms 998 MHz. What the heck? "Notebook Hardware Control" reported 1830 MHz the whole time. It "feels" like it's running more normal but do I still have a problem?
0
 
RickNCNAuthor Commented:
Ok, maybe I solved that question as well. When I booted up with the 4.6A adapter the BIOS came up with a message saying the adapter isn't recognized and the system will run slower than normal...etc.  I think this Dell adapter I have has a problem and whatever internal chip identifies it to the laptop isn't working properly. So maybe that's still causing a cpu speed problem
0
 
RickNCNAuthor Commented:
0
 
flubbsterCommented:
Nice work. I'd be curious to know what the results are using a charged battery. Are the voltages of the two adapters the same, and just the current is different?

If the voltages are different, could you post the voltage and current rating of each pls?
0
 
RickNCNAuthor Commented:
to answer your question the PA-12 is a 19.5v, 3.34A (65W) power adapter.

the PA-10 is a 19.5v 4.62A adapter (90W)

With it running on a battery, the CPU usage history graph is just as normal as with the 90W adapter.

Ok, another interesting thing - finally, today, I'm seeing CPU-Z  report 1831 MHz!! It fluctuates between 998 and 1831 when there's a load on the CPU, it bumps up like it should.

Seems to have been a power problem all along.
0
 
nobusCommented:
now - that is a strange problem.. tx for the feedback on it
0
 
RickNCNAuthor Commented:
well, since I solved my own problem, I accepted my answer as the solution, but I did it with y'alls help so I split up the points.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 17
  • 4
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now