USB Com Port doesn't work until device is physically dosconnected and reconnected after each reboot - Win7

I have a Motorola LS2208 scanner with a USB interface.  I have the scanner installed and have version 1.8.5 of the Symbol COM Port Emulation Driver installed and the device does what its supposed to do. I scan barcodes direct into hyper terminal.  The problem I have is that when I reboot the PC the device doesn't work until I unplug the scanner and reconnect it again.  Before I reboot and when the scanner is working in device manager under HID I have Symbol USB Com Port Emulation and Communication Virtual Port Com4.  When I reboot I stll see the Com POrt Emulation device but loose the Communication Virtual Port and have instead an unknown device.  The properties for the unknown device say the device is working correctly but hyperterminal doesn't see the port.  When I unplug and reconnect it works straight away.

After doing some googling I have found release notes for a version 1.8.6 of the emulation driver which states that 1.8.6 includes Windows 7 support but I can't find a download link for 1.8.6 anywhere.  I therefore am assuming 1.8.5 isn't 100% happy running on Win7.

I know the 1.8.5 driver does work on Windows 7 because I have a second PC with it working.  I have tried everything including swapping scanners and even doing a clean Windows install but am having no luck with it.

Any ideas?
bridgegaelAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David-HowardCommented:
Have you updated the chipset, BIOS and or USB drivers for this system? If not, you might want to visit the manufacturers site and see if there are any applicable updates for the pc.
I would also verify service packs, etc. against the system that is working with the system that is not. (Service Pack 1)
0
bridgegaelAuthor Commented:
I have the latest BIOS and chipset drivers.

I have found a nasty hack which works:

c:\devcon\devcon.exe disable "@USB\ROOT_HUB20\4&1D371D5B&0"
c:\devcon\devcon.exe "@USB\ROOT_HUB20\4&1D371D5B&0"

I now need to get this to run at logon.  I tried Task Scheduler but nothing happens, I put it into the registry and nothing happens.

Any ideas

0
David-HowardCommented:
I'm not sure which keys you entered the hack into. Did you try the following?
HKLM\Software\Microsoft\Windows\CurrentVersion\RunOnce
HKLM\Software\Microsoft\Windows\CurrentVersion\RunOnceEx
HKCU\Software\Microsoft\Windows\CurrentVersion\RunOnce
HKCU\Software\Microsoft\Windows\CurrentVersion\RunOnceEx

0
bridgegaelAuthor Commented:
I had to turn User Access Control off to get this to work.  Not good but it got me out of a hole.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bridgegaelAuthor Commented:
Disabling User Access control was the solution.  I suggested it
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.