Resetting Password in Virtualized Xubuntu Under VMWare Fusion

I use VMWare Fusion 3.1.2 on my MacBook (running OS X 10.6.8). Many months ago I created a virtual machine running Xubuntu 10.10. I have not used it in a long time and now I cannot remember the password. The VM was suspended, so I was able to restart it w/o being prompted to log in and I can get to a command prompt. But I cannot do anything that requires sudo b/c I don't remember the PW.

Is there some way I can reset the PW on this VM?
anuneznycAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

alienvoiceCommented:
Can you access Single User Mode?
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
How to reset your password in Ubuntu
http://www.psychocats.net/ubuntu/resetpassword
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Kerem ERSOYPresidentCommented:
Hi,

You can boot your ubuntu from the install image or the live CD you can download from ubuntu site.

Then follow this procedure:
- Indicate the .iso image file as the CD and boot your VM from the CD.
- Boot from the Live CD
- Find your boot partition using fdisk -l command and mount it to a directory
- Use chroot to the new path and now your / is set to the mounded partition.
- Now you can use the passwd command to change your passwd.

Here are detailed steps and screenshots from this operation:

http://www.howtogeek.com/howto/linux/reset-your-ubuntu-password-easily-from-the-live-cd/


Cheers,
K.

 
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
anuneznycAuthor Commented:
Was not able to access single-user mode or the GRUB menu from within this virtual machine.

KeremE, your instructions booting from Xubuntu CD worked. Thanks also for the link with the nice clear screenshots. That made the process completely painless.
0
PapertripCommented:
Was not able to access single-user mode or the GRUB menu from within this virtual machine.

Then you didn't read the instructions properly.

While the Live CD is a valid option, the overhead required to do it that way doesn't really make it worth it vs. the other options that were suggested.

hanccocka and I should have at least got Assisted Solution for this.
0
anuneznycAuthor Commented:
I read the instructions just fine. Maybe you didn't read my original post? This is Xubuntu virtualized under VMWare Fusion. I appreciate you pointing me in the right direction, but you and hanccocka's links are for regular installs, NOT for virtualized installls. I tried at least 10 different times to access the GRUB menu from within VMWare and was not able to do so. Maybe I was doing something wrong, but your links didn't help my particular situation. Hence why I used KeremE's suggestion which worked perfectly to successfully resolve my problem and that's why he got all the points.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.