Map a drive Win 7 --> 2000 Server with no password

User has an old Windows 2000 server and several XP desktops.  All of those XP boxes map a drive F: to the server, and when it asks for credentials, they login as admin, but with no password.  This has apparently worked fine for them for years.

Now I've added a Win 7 Pro desktop, and I'm unable to make that same connection.  When I'm asked for login name and password, I use 'admin, "blank"' and it says it's invalid.  I'm wondering if this is a Win 7 issue, where maybe it requires that a non-blank password be used??  I'm hoping to solve it without having to change their users on the server if possible, i.e. ideally be able to log in just like the XP boxes do.  Any suggestions?  TIA
LVL 3
sasllcAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Set it up to work with passwords as Windows 7 works best that way. Then log in using the userid and password. Look in Control Panel -> Network and Sharing Center. Make sure options are set appropriately and make sure passwords are enforced. Make sure Homegroup is OFF. In Windows Explorer -> Folder Options, I do not use the sharing wizard (equivalent of simple file sharing).

Open a command prompt now, and type NET USE Z: \\windows2000\folder, authenticate and what answer do you get.

I have no clients anymore with Windows 2000 Server, but I connect to my Windows 2000 virtual machine with no issue. .... Thinkpads_User
n2fcCommented:
In the Windows 7 box, change the NTLM authentication level to “Send LM & NTLM - use NTLMv2 session security if negotiated” in Windows 7.

See: http://technet.microsoft.com/en-us/library/cc738867(WS.10).aspx

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
n2fcCommented:
Here is where you should find it in the WIN7 PC:

Control Panel - Administrative Tools - Security Settings
   Local Policies - Security Options

Set the following:

Network security: LAN Manager authentication level  (set to)
      Send LM & NTLM responses

Minimum session security for NTLM SSP
     (Disable) Require 128-bit encryption

JohnBusiness Consultant (Owner)Commented:
>>> change the NTLM authentication level to “Send LM & NTLM - use NTLMv2 session security if negotiated.

I have to do that to map to Windows 98 and earlier, but the default setting should work for Windows NT4 forward.

... Thinkpad_User
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.