Error 1603 installing Microsoft .NET 1.1

I have an install package for my application that checks for the presence of .NET 1.1 and installs it if necessary.  I have done over 600 installs with this package with no problem.  On my last install, I got 1603: Error installing Microsoft .NET 1.1 which I've never had before.

I uninstalled everything to do with .NET, through the Control Panel.  I've done this before and it has solved the problem, but not this time.  I've researched this on the web and read about shared files, security issues, and the dotnetfx cleanup tool, but before I do anything I would like any advice or tips from anyone who has actually had this problem and solved it.

I'm trying to install on a 1 year old laptop, 1 GB memory, Windows 7 32bit.  I'm doing it by remote assistance which has never been a problem but I thought I should include this for completeness.

Thanks in advance.
Clive BeatonAccess DeveloperAsked:
Who is Participating?
 
Jacques Bourgeois (James Burger)PresidentCommented:
Windows 7 is not a supported OS for framework 1.1 (http://www.microsoft.com/download/en/details.aspx?id=33)

Windows 7 come with a newer version of the framework already installed. Most 1.1 applications will run under a newer version. I would thus try the application before installing 1.1.

If it fails, Microsoft has a fix for error 1603: http://support.microsoft.com/kb/923100
0
 
pravin_abhale11Commented:
Supported Operating Systems for .net 1.1: Windows 2000, Windows Server 2003 Service Pack 1 for Itanium-based Systems, Windows Server 2003 x64 editions, Windows Server 2008 Datacenter, Windows Server 2008 Enterprise, Windows Server 2008 for Itanium-based Systems, Windows Server 2008 Standard, Windows Vista Business, Windows Vista Enterprise, Windows Vista Home Basic, Windows Vista Home Premium, Windows Vista Starter, Windows Vista Ultimate, Windows XP, Windows XP Professional x64 Edition

0
 
marek1712Commented:
As already said - it's not suported.
If the installer is a .MSI package - you can edit the conditions to omit it.
If the setup file of the .Net 1.1 is a separate file - replace it with a dummy one.
0
 
Clive BeatonAccess DeveloperAuthor Commented:
It may not be supported, bit it has worked over 100 times on Win7 with no problem.  I guess what I am trying to find out is what could be different on this computer to cause this problem.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.