Trixbox CW 2.8.x when I dial DID number to dial direct to the phone, the line doesn't answer

I have two client phones that are not accepting calls unless I come in the IVR and press thier option numbers.


When I dial the DID #s for each of them the system rings their phones but it shows "unknown@ipaddress" and if I pick up the handset all I get is a dial tone.

Any ideas?
PatrickDomanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

feptiasChief DudeCommented:
Based on the fact that you mention Cisco 7960 phones in your tags plus the quite unusual behaviour you described - i.e. picking up a ringing phone does not answer it - I would guess that the problem is linked to the ports used for transmitting and receiving SIP messages.

This means ignoring the additional information that it works via an IVR menu, but I'm guessing that there is a good reason for that situation being different.

If the 7960 is like the 7940 that I have been working with recently, then they have somewhat unusual default behaviour regarding ports. They transmit SIP messages to Asterisk on a different port to the one that is listening for, and receiving, SIP messages from Asterisk. This can confuse Asterisk, but there is a solution. You must set "nat=no" in the TrixBox extension settings (assuming of course that the phones are on the same LAN as the TrixBox).

If that doesn't fix it, please post back what are the NAT settings on the phones. ...and what is the network topology between the phones and the TrixBox. If possible, please capture the SIP packets going between the phone and the TrixBox during a problem call. You can use Wireshark or the Asterisk CLI command "sip set debug" to capture the SIP (in the latter case you probably need to connect using Putty and SSH rather than using the Web GUI).

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PatrickDomanAuthor Commented:
The issue was actually with Qwest. They had forwarding turned on "on their end" which sent all calls to an AZ office. I had to have them turn off the call forwarding. Once they did that the phone worked fine.

Good info though... Thanks for your assistance.

The unknown@192.168.1.20 on the phone indicated that something else on the line was causing issues with the phone receiving calls. I worked with Fonality support they had said that the system was all setup correctly. That this had to be a extenuating function causing this. It turned out it was.
PatrickDomanAuthor Commented:
I worked through the evening and then again in the morning with Fonality support when they reopened the next day. We deleted the line and the extension and re-added everything back again.

Once we did that the line still exhibited the same problems. I went through and called Qwest. They found that a special call forward was sending all calls coming into the local number to another office.

If the calls came in the IVR the issue didn't exist. All worked well.


The primary resolution was to call qwest and have them disable call forwarding.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Voice Over IP

From novice to tech pro — start learning today.