• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 349
  • Last Modified:

Trixbox CW 2.8.x when I dial DID number to dial direct to the phone, the line doesn't answer

I have two client phones that are not accepting calls unless I come in the IVR and press thier option numbers.


When I dial the DID #s for each of them the system rings their phones but it shows "unknown@ipaddress" and if I pick up the handset all I get is a dial tone.

Any ideas?
0
PatrickDoman
Asked:
PatrickDoman
  • 2
2 Solutions
 
feptiasCommented:
Based on the fact that you mention Cisco 7960 phones in your tags plus the quite unusual behaviour you described - i.e. picking up a ringing phone does not answer it - I would guess that the problem is linked to the ports used for transmitting and receiving SIP messages.

This means ignoring the additional information that it works via an IVR menu, but I'm guessing that there is a good reason for that situation being different.

If the 7960 is like the 7940 that I have been working with recently, then they have somewhat unusual default behaviour regarding ports. They transmit SIP messages to Asterisk on a different port to the one that is listening for, and receiving, SIP messages from Asterisk. This can confuse Asterisk, but there is a solution. You must set "nat=no" in the TrixBox extension settings (assuming of course that the phones are on the same LAN as the TrixBox).

If that doesn't fix it, please post back what are the NAT settings on the phones. ...and what is the network topology between the phones and the TrixBox. If possible, please capture the SIP packets going between the phone and the TrixBox during a problem call. You can use Wireshark or the Asterisk CLI command "sip set debug" to capture the SIP (in the latter case you probably need to connect using Putty and SSH rather than using the Web GUI).
0
 
PatrickDomanAuthor Commented:
The issue was actually with Qwest. They had forwarding turned on "on their end" which sent all calls to an AZ office. I had to have them turn off the call forwarding. Once they did that the phone worked fine.

Good info though... Thanks for your assistance.

The unknown@192.168.1.20 on the phone indicated that something else on the line was causing issues with the phone receiving calls. I worked with Fonality support they had said that the system was all setup correctly. That this had to be a extenuating function causing this. It turned out it was.
0
 
PatrickDomanAuthor Commented:
I worked through the evening and then again in the morning with Fonality support when they reopened the next day. We deleted the line and the extension and re-added everything back again.

Once we did that the line still exhibited the same problems. I went through and called Qwest. They found that a special call forward was sending all calls coming into the local number to another office.

If the calls came in the IVR the issue didn't exist. All worked well.


The primary resolution was to call qwest and have them disable call forwarding.
0

Featured Post

Reclaim your office - Try the MB 660 headset now!

High level of background noise often makes it difficult for employees to concentrate fully on their jobs – or to communicate clearly on calls. The MB 660 headset helps you create a disruption free workspace.  

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now