Wrong Username

Posted on 2011-10-05
Last Modified: 2012-05-12
Good morning,
Im getting several users complaining that when they open Outlook they are being prompted for a username and password, but the username is wrong. When they click the down arrow next to username they can select there proper username. I cannot find anywhere where I change the default usename, any ideas where it is?

Thank you
Question by:tonelm54
    LVL 8

    Expert Comment

    Can you confirm your actual setup please.
    Are ou are using exchange 2003,2007 or 2010 with Outlook 20xx on a local network where al the PC's are in the domain.
    Outlook should normaly use integrated authentication so shouldnt need any additional credentials. It may be a problem with the domain controller not processing the authentication requests from exchange.

    Is this affecting every user or just a small group ?
    LVL 3

    Accepted Solution

    There was an issue with repeated password prompts that was resolved by installing Rollup 9 for Exchange 2007 SP1, however I would recommend that you should now be using Exchange 2007 SP2 since it has been around since August 2009:

    If you are in an Small Business Server 2008 environment and not yet using Exchange 2007 Rollup 9 you can also install SP2 for Exchange 2007 with the aid of the Installation Tool, available here:;EN-US;974271

    If that doesn’t fix the repeated prompt for password then it could be down to the autodiscover if your using Outlook 2007 then you must configure autodiscover correctly. There are many articles out there that cover the correct way to configure autodiscover, one of the better ones I have found is this one:

    However the part that most people are missing is the (where is the part after the @ in your e-mail address. Newer versions of outlook will look for this for OAB download, free/busy information, Out of Office etc etc. If it’s not there then outlook will continually give user prompts. To accompany this you must have an SSL Certificate that contains the URL (whilst you can configure ways around this, it really isn’t worth all the hastle). So purchasing an SAN/UCC Certificate with the following names in is a must for Exchange 2007 and Exchange 2010:

    • (the URL used for Outlook Web Access)
    •servername.domainname.local (the internal FQDN of your Exchange Server)
    •SERVERNAME (NETBIOS Name of your Server)
    If you have not yet purchased an SSL Certificate I can recommend as a cost effective product that is fully supported.

    You must also have the coresponding and A records configured in your external DNS

    If you have all the above configured and you are still experiencing problems then the following procedure will more than likely fix it for you.

    In Internet Information Services (IIS) Manager locate the Exchange virtual directories, if you are using Small Business Server 2008 these will be under the SBS Web Applications website, if your not using SBS then they will be under the Default Website.

    The virtual Directories you are looking for are:

    In turn highlight each of these virtual directories and double click the Authentication icon on the right hand side. Right click on Windows Authentication and select Advanced Settings. Place a check box in the box for Enable kernel-mode authentication. Do this for each virtual directory listed above.

    You may have the setting in outlook selected to always promot for crendentials.  

    In reality, what this option does is prompting you for your username and password to set up a connection with Exchange even when you are already logged in otherwise.

    For instance, if you are using a computer that is joined to a domain and you’ve logged in with your domain username and password, you normally would not be prompted for your credentials for any of the resources that are part of that domain. As the Exchange server is usually part of that domain, your connection to the Exchange server would be automatically authenticated by the credentials that you have used to log on to your workstation.

    To set the option “Always prompt for logon credentials”;

    1.Open Account Settings
    ¦Outlook 2003 and Outlook 2007
    Tools-> Account Settings…
    ¦Outlook 2010
    File-> Account Settings-> Account Settings…
    2.Double click on your Exchange account.
    3.Click on More Settings…
    4.Select the tab Security.
    5.Enable the option: “Always prompt for logon credentials”.

    Featured Post

    Free Trending Threat Insights Every Day

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Join & Write a Comment

    Check out this infographic on what you need to make a good email signature that will work perfectly for your organization.
    Find out how to use Active Directory data for email signature management in Microsoft Exchange and Office 365.
    This Micro Tutorial will give you a basic overview of Windows Live Photo Gallery and show you various editing filters and touches to photos you can apply. This will be demonstrated using Windows Live Photo Gallery on Windows 7 operating system.
    The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

    729 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now