Exchange 2007 Certificate issue with different default gateway

We have a strange issue internally using outlook where we get a certificate error with a name on security cert is mismatched, the cert is issued to sites and by the server itself, we are actually running a go daddy san cert and it works fine on all clients unless they are using a different default gateway to the server itself, when using the same gateway outlook is ok if using an alternative gateway we get the error.

The server is an sbs 2008 server.

Thanks,
Craig
NSSUKAsked:
Who is Participating?
 
RadweldCommented:
Post up a screen grab of the error, Does this occur internally or externally or both?
0
 
Sid_FCommented:
Can you give some further detail,concerning your gateways and network setup. If the name is mismatched for internal users what name is configured on the internal users outlook and what name is configured on the cert (you can post a dummy name but just something to give an example)
Have you trried resolving it by using a dns entry if the domain names are different
0
 
Hendrik WieseInformation Security ManagerCommented:
The only way I can see this happening is if you have an extra exchange server on the other default gateway that has a certificate that does not match. Other than that this seems weird.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
NSSUKAuthor Commented:
The Outlook client is auto detecting owa.domain.co.uk which is correct and is also the name of our certificate from Go Daddy, the issue is external as far as i know but we do use Outlook anywhere although not that often but I would need to try this externally later to confirm if it is an external issue as well.

If it is dns related which was my initial thought what record would i need to add to my internal dns ??
0
 
kkareemCommented:
its purely an DNS issue ,check the appropiate setting.
0
 
Hendrik WieseInformation Security ManagerCommented:
Just create an A record owa.domain.co.uk if it does not already exist. Although I am pretty sure that it does. Also ensure that the correct services is assigned to the certificate in question.
0
 
NSSUKAuthor Commented:
owa for the internal .local domain exists and points to the correct location ?
0
 
Hendrik WieseInformation Security ManagerCommented:
You could always create a DNS zone for domain.co.uk and just add  the owa A record, which you can then point to the owa.domain.local.
0
 
kkareemCommented:
I have already told please check throughly your DNS setting orther wise briefly descrieb the whole infrastructure that leads me towards the right Analysis of your Problem
Regards
Kashif
0
 
Hendrik WieseInformation Security ManagerCommented:
@kkareem - simply telling a user "check the appropriate setting." is a kind of broad suggestion. Please be more specific with your requests.
0
 
kkareemCommented:
@HendrikWiese -user unable to undestand ,that why i have told like above............
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.