Exchange 2010 not able to uninstall exchange server rules

hi
i have couple of exchange servers i want to remove one at all for format purpose ... when i try to uninstall the server the following errors comes

----------------------------------------------------------------------------------------------------------------------------------
Summary: 4 item(s). 2 succeeded, 2 failed.
Elapsed time: 00:00:42


Configuring Prerequisites
Completed

Elapsed Time: 00:00:00


Mailbox Role Prerequisites
Failed

Error:
Uninstall cannot continue. Database 'Public Folders': The public folder database "Public Folders" contains the following offline address books:
\Offline Address List Final
. Before you can delete the public folder database, you must change the OAB distribution method to Web-based distribution.
Click here for help... http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.14&id=b6e3b32a-8848-46cb-9567-72288ac15f60

Elapsed Time: 00:00:23


Client Access Role Prerequisites
Completed

Elapsed Time: 00:00:07


Hub Transport Role Prerequisites
Failed

Error:
This computer is configured as a source transport server for 2 connector(s) in the organization. These must be moved or deleted before Setup can continue.
Click here for help... http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.14&id=67c28d7f-cf6f-4f9c-b8a0-7e28ed318e2f

Elapsed Time: 00:00:09
-----------------------------------------------------------------------------------------------------------------------------------

how i can continue the uninstall ????
LVL 3
F_A_H_DAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dan ArseneauCommented:
First error:
Inside EMC, navigate to Microsoft Exchange - Microsoft Exchange On-Premises (server) - Organization Configuration - Mailbox
Click on the Offline Address Book tab
Double-click Default Offline Address Book
Click the Distribution tab
Uncheck "Enable public folder distribution"

Second Error:
Inside EMC, navigate to Microsoft Exchange - Microsoft Exchange On-Premises (server) - Organization Configuration - Hub Transport
Click on the Send Connectors tab
If this is the last Exchange server, delete all the connectors listed here.
If this is not the last, double-click each connector and click on the Source Server tab.
Remove the server in question from the list.
0
F_A_H_DAuthor Commented:
i have two databases and two public folders any idea how to move public folder to another ??
0
Dan ArseneauCommented:
If you're replicating with another server, open the Public Folders Tool, right-click and choose Move Replicas.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.