[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

FrontPage Form submission - "You are not authorized to view this page".

Posted on 2011-10-05
11
Medium Priority
?
427 Views
Last Modified: 2013-12-24
I have an intranet site that was running fine, with Forms, on IIS 5, Windows 2000 Server.  I recently moved it to a different server running Windows Server 2003, IIS 6.  Everything works fine, except for the forms.  There must be some sort of permissions issue.

If myself or another admin level user completes and submits a Form, it completes successfully - no problems.  Any other domain user that tries to submit a form is prompted for user authentication and after entering it three times, it fails with the following message:

You are not authorized to view this page.
You do not have pemissions to view this page using your current user account.
Please try the following:
- If you have another user account with a higher level of permission, click your browser's back button to try again using that account.
- If you believe you should be able to view this page, contact the Web site administrator.

I've spent hours messing around with NFTS permission and IIS permisisons.  Everything looks the same between my old IIS 5 box and the new IIS 6 box.  Does anyone have any idea what could be causing the permission error?

Thanks!
0
Comment
Question by:GStoner
  • 7
  • 4
11 Comments
 
LVL 31

Expert Comment

by:James Murrell
ID: 36919914
Have you installed fp extension?
0
 

Author Comment

by:GStoner
ID: 36919955
Yes. I forgot to mention that fp server extensions 2002 is installed.  Again, the forms work fine for any user who is included in the Domain Admin Group.  Anyone who is not in that group gets the "You are not authorized to view this page" error.
0
 
LVL 31

Expert Comment

by:James Murrell
ID: 36920003
what version on IE are you using?

also have you unchecked "Allow IIS to control password" checkbox
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:GStoner
ID: 36920089
I've tested it on IE7 and IE 8.  

Where is the checkbox for "Allow IIS to control password" ?
0
 
LVL 31

Expert Comment

by:James Murrell
ID: 36920104
this should help...http://support.microsoft.com/kb/332167 (only have iis7 at home)
0
 

Author Comment

by:GStoner
ID: 36925145
I don't think this applies because I'm using Windows Authentication.  This article discusses controlling the password for the Anoymous account when anonymous authentication is enabled for a web site.

Anyone with Domain Admin access can submit forms without error.
Anyone with Domian User access receives the permissions error.

That leads me to believe that this problem has nothing to do with the Anonymous user account.  
0
 

Author Comment

by:GStoner
ID: 36925169
Okay, I just realized that IIS 6 does not install SMTP Virtual Servers, so how is it supposed to route forms submissions by email?  I just added SMTP service and I'm looking at the configuration compared to my old server.  So far, it is still not working.  

Any insight on how to configure IIS 6 to route form submissions to my Exchange Server?
0
 

Assisted Solution

by:GStoner
GStoner earned 0 total points
ID: 36925365
This still doesn't makes sense.  Why would the forms submit email confirmations successfully from Domain Admin members before the SMTP Virtual Server was added?  That must not have anything to do with this issue either.  If the SMTP Virtual Server was the problem, I would not have been able to submit forms at all.
0
 
LVL 31

Expert Comment

by:James Murrell
ID: 36926198
Can you post form code
0
 

Accepted Solution

by:
GStoner earned 0 total points
ID: 36926709
I found the problem.  Frontpage Server Extensions 2002 has an additional security level to specify group or user access.  After I added Domain Users with Browse Access to FP Extensions, the domain users are now able to submit the forms without an error.  

Why would the domain user be able to browse the entire site and do everything, EXCEPT submit a form without the Frontpage Server Extension setting?  That makes no sense to me.

Thanks anyway.
0
 

Author Closing Comment

by:GStoner
ID: 36947401
An Expert did not provide a solution.  I found it by trial and error.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Does your audience prefer people in photos or no people? How can you best highlight what you’re selling? What are your competitors doing, and what can you do that is different and unique from them?  Continue reading to learn how to make your images …
Originally, this post was published on Monitis Blog, you can check it here . It goes without saying that technology has transformed society and the very nature of how we live, work, and communicate in ways that would’ve been incomprehensible 5 ye…
The purpose of this video is to demonstrate how to set up an RSS Feed on a WordPress Website. This will be demonstrated using a Windows 8 PC. Feedburner will be used for this demonstration. Go to your WordPress login page. This will look like the…
The viewer will learn how to dynamically set the form action using jQuery.
Suggested Courses
Course of the Month18 days, 21 hours left to enroll

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question