Unable to use Out of the Office Assistant - office 2007/ exchange 2010

Hello Experts!!

I think I have missed a step on Exchange configuration because Outlook 2007 Out of the office assistant doesn't work, while in Outlook  I select out of the office assistant takes a while to give the following message:
 " Your Our of Office settings cannot be displayed, because the server is currently unavailable. Try again later".

Although I'm able to send/receive/ view my emails...

Any ideas what could be the reason why is not working?

Thanks a lot!!!

ARPIAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

knwarrior74Commented:
Have you tried setting the OOF via OWA?
0
knwarrior74Commented:
Also do you have the latest SP for your exchange server?

SP1.
http://www.microsoft.com/download/en/details.aspx?id=21570
0
madhatter5501Commented:
sounds like you are having the common error that I have seen regarding the newer versions of exchange.  exchange 2007 and 2010 now use something called autodiscover, supposed to make the configurations easier but only if all the components are set correctly on the server.  First thing you want to check is your public certificate and check the names on there.  The cert needed is called a UCC SAN certificate and can be purchased through godaddy for $89 dollars last time I checked.

The certificate will need all the names that you are using on your exchange network, for example -

domain.local
domain.com
mail.domain.com
owa.domain.com
autodiscover.domain.com

and any other names that exchange is using.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

madhatter5501Commented:
0
E_T_BCommented:
I had this problem because there was a problem with the File Distribution Service.  I restarted and it worked.

If that doesn't do it, go down the autodiscover route.

http://www.proexchange.be/blogs/exchange2007/archive/2009/07/14/your-out-of-office-settings-cannot-be-displayed-because-the-server-is-currently-unavailable-try-again-later.aspx
0
ARPIAuthor Commented:
knwarrior74,

yes, it works only on OWA.
0
setasoujiroCommented:
madhatter5501 is correct. You are having an issue with Autodiscover... But you don't need a certificate for the OOOF assistant to work, you are missing a DNS record i think.

on both your internal and external DNS server (depending on your setup) you need an A record for "autodiscover.yourdomain.com" OR ".local" , depends on what your outlook uses...

and then maken sure you use the correct dns server
0
ARPIAuthor Commented:
knwarrior74,

I have installed SP1 in server... didn't work.
0
setasoujiroCommented:
please try my answer.
0
knwarrior74Commented:
I would check the OOF with a new profile first.

The problem your are describing ultimately leads to outlook not knowing how to get to the autodiscover settings of Exchange.

Outlook will try to go to "autodiscover.{domain}.com".
Add an alias in our DNS server "autodiscover.{domain}.com" and pointed it to the EMail server specifically.
Flush the DNS and do a test ping to verify it is resolving to the email server.
Start Outlook
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
eitan84Commented:
hi you need to fix your dns on the sever
if you pot on the local host the record of your-ip-server autodiscover.domain.com

it well work

you can go from
start---> run drivers

C:\Windows\System32\drivers\etc

edit the file hosts
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.