TFS 2008 Timeout Issues

Hi, I have a TFS 2008 installed on a server box.  We have 3 clients which access this box.  It has been very flaky.  It takes forever to open source control window and browse folders.  Most of the time it times out the first time, then the second time you try it works.  Same happens when i check in files.  The box is on the same domain as my pc and I can't see network speeds being an issue.  They are not for any other work that I do.  Just wondering where to begin to debug this issue.  if the server is rebooted it seems to work much better for a day or so then back to the timeout issues.

The TFS2008 server is a Windows 2008 Server (Standard Edition).  It has service pack 2.  It is also a virtual machine.

My client PC is windows 7.  There are two other users with the same issue as well.  At least one has windows 7, not sure of the other.

thanks for your help
Fraser_AdminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mohamed OsamaSenior IT ConsultantCommented:
First place to check would be the event logs for the server , such behaviour will most likely leave a trace there.
Also how is disk space and disk fragmentation level ?
Finally if this took you nowhere, try the tfs best practice analyzer that comes as part of the TFS 2008 Power tools
0
Fraser_AdminAuthor Commented:
I'm consistently getting these event log errors:

Windows Sharepoint Services 3 6772 (Timer) - There was an internal error invoking the timer job.
Windows Sharepoint Services 3 27745 (General) - No additional info
Windows Sharepoing Services 3 3355
Report Server Windows Service 107 (Management) - RSWS cannot connect to the report server database.  Timeout.


These errors are popping up in the log about once an hour.
0
Fraser_AdminAuthor Commented:
found out it was due to a toolbar installed on the machine.  once uninstalled it is working fine.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Fraser_AdminAuthor Commented:
i found the solution on my own.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.