[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 540
  • Last Modified:

I need to run devcon command everytime I logon Win7

I'm having a problem with a peice of hardware and need to run the following two commands at logon to get it running.

c:\devcon\devcon.exe disable "@USB\ROOT_HUB20\4&1D371D5B&0"
c:\devcon\devcon.exe "@USB\ROOT_HUB20\4&1D371D5B&0"

I have tried using task sdcheduler but get error 0x800704DD and nothing happens.  I have configured the tash to run with highest privelages but it makes no difference.  I have tried sticking the command into HKLM\Software\Microsoft\Windows\CurrentVersion\Run but it doesn't run.

Any ideas?
0
bridgegael
Asked:
bridgegael
1 Solution
 
Jim-RCommented:
Add a 30 second or 1 minute delay to the properties of the task.  This worked for me on a task that didn't work until I added the delay.
0
 
Ivano ViolaSystem AdministratorCommented:
Try putting it in your startup folder as a .cmd or .bat file (or All Users startup folder) in All Programs. I think this will work.

IV
0
 
johnb6767Commented:
If this is in a .bat/.cmd file, you can go to the properties of the file/compatibility/and select RunAsAdministrator.....

Is UAC enabled as well?
0
 
bridgegaelAuthor Commented:
I had to disable User Access Control to get this to work
0
 
LeeTutorretiredCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now