Quorum drive failed for 2008 R2 SQL cluster

About an hour ago our Quorum drive on our cluster went into a "failed" state.  There are no errors in the event log leading up to the failure that offer any insight into the cause.  The setup is as follows:

2 X Server 2008 R2 with SQL 2008 in Active/Passive
Quorum drive is on a Xiotech 5000
All other shared resources reside on the same Xiotech and are functioning correctly.

There are no errors on the Xiotech and the volume appears to be fine according to their management software.  We attempted to bring the resource online in Cluster Failover Manager and it failed.  We tried to do the "repair" on the quorum drive and that failed as well.  We've brought down both servers and attempted these tasks with the same failures.  Any advice to bring the quorum drive back online would be greately appreciated.
LVL 8
Acosta Technology ServicesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Paul MacDonaldDirector, Information SystemsCommented:
I wonder how the controller determines the drive is okay...

In any case, can you replace (even temporarily) the affected drive?  Format it, and treat it like it's your quorum drive, but empty?
0
Acosta Technology ServicesAuthor Commented:
The controller (a Xiotech 9000) provides health of the volumes.  I also confirmed with Xiotech that the telemtry logs showed no errors during the most recent upload (20 minutes after initial failure).  Can you provide any details on the process for replacing the Quorum?  Right now it shows "reserved" from both nodes so I'm unable to do anything to it.  I can create and present a new volume, but I'm unsure what the process would be to use it as the quorum at that point.
0
Paul MacDonaldDirector, Information SystemsCommented:
Can you not simply replace the physical drive?  Or is this a virtual drive provisioned in a SAN?  If this is a provisioned drive, are you certain something about the provisioning hasn't changed?  Permissions, etc?

Are there any error messages on either cluster node?

0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Acosta Technology ServicesAuthor Commented:
All shared resources are on the Xiotech 5000 SAN.  Nothing about the provisioning has changed.  The drive shows up in the MPIO software as well as in disk management.  The issue is the failed status in cluster manager.
0
Acosta Technology ServicesAuthor Commented:
I was able to resolve the quorum issue by doing the following:

-Created new volume on Xiotech and presented it to the nodes
-Added new disk into the Cluster Manager
-Ran the Quorum creation tool, selected new disk
-After complete, I ran the same wizard on the original disk (to mantain drive letter) and the process was successful.
-Tested failover using the Failover Manager tools.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Acosta Technology ServicesAuthor Commented:
No solutions were provided relevant to the issue.  I was able to find an outside resource that provided the solution.
0
Paul MacDonaldDirector, Information SystemsCommented:
Replacing the drive is what I was driving at.  I'm glad you were able to solve the problem.  

Still no idea what happened to the old drive?
0
Acosta Technology ServicesAuthor Commented:
Sorry for the confusion; I thought you were referencing a physical disk error and replacing a hard drive.  I still haven't found the underlying issue.  I did find a few initiator errors on the Brocade fiber switch, but the WWN's didn't match up to the hosts that were having the issues.  I'm leaning towards an issue with the Xiotech, it would mark the 3rd failure in our Xiotech array in the past few months.  If I find a cause I'll update this for the knowledgebase.  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.