?
Solved

Unable to access Remote Desktop Web Access Site - HTTP 500 -

Posted on 2011-10-05
4
Medium Priority
?
3,186 Views
Last Modified: 2012-06-21
Remote Dekstop web access is not accessible after installing .net 1.1 which was bundled with a program.
I have uninstalled .net 1.1, but am still having the issue.
I have ran a repair on .net 4.0 - same issue.
This is the error I get when I try to browse to the site from the server.
 Error from browsing to the page from IISHTTP Error 500.0 - Internal Server Error
Calling LoadLibraryEx on ISAPI filter "C:\Windows\Microsoft.NET\Framework\v4.0.30319\\aspnet_filter.dll" failed



Windows Server 2008 R2 SP1



0
Comment
Question by:wcoil
  • 3
4 Comments
 
LVL 30

Expert Comment

by:Brad Howe
ID: 36921134
Hi,

Don't know if you ran a repair on installer or via commandline. Typically, these issues are caused by mismatched tags.

Try the following.

1. Open a command prompt in administrator mode.
2. Browse to C:\Windows\Microsoft.NET\Framework\v4.0.30319\
3. run aspnet_regiis -r

If this doesn't help please provide the OS, (32/64) and your application Pool configuration for further corrections.

Let us know,
Hades666
0
 

Author Comment

by:wcoil
ID: 36923862
The repair on .net 4 was done through add/remove programs.
Ran this command as an administrator without problem. Still having the same issue.

Windows Server 2008 R2 SP1 64bit

Is this what you are looking for for the applicaiton pool configuration?
 Application Pool
0
 

Accepted Solution

by:
wcoil earned 0 total points
ID: 36945015
Well.
Looks like I got it figured out.
I ran the following command.
C:\windows\microsoft.net\framework\v4.0.30319\aspnet_regiis -ua
-this uninstalled all .net versions from iis
-I got errors on this, 0x80004005, but i disregarded them and carried on.
-after that was finish I ran the following command.
C:\windows\microsoft.net\framework64\v4.0.30319\aspnet_regiis -r
-this renistalled .net for iis
-the directories are different from the uninstall and reinstall. I got an error for rdweb after running this on just Framework and not Framework64. So just run it on 64 for both if you can, this is just what worked for me.
Then I totally reinstalled RDWEB, from remove role service in the Server Management console.
Everything is working now.
I can browse to the page without error. Just had to reconfigure my apps.
0
 

Author Closing Comment

by:wcoil
ID: 36972727
Found the answer out myself.
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

What is an ISAPI filter?   •      It's an assembly (.dll file) that can add or change the way IIS works.   •      They can be enabled globally for your web server or on a site-by-site basis.   When the IIS server receives a request, enabling the ISAPI fi…
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
This Micro Tutorial will teach you how to add a cinematic look to any film or video out there. There are very few simple steps that you will follow to do so. This will be demonstrated using Adobe Premiere Pro CS6.
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
Suggested Courses
Course of the Month16 days, 1 hour left to enroll

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question