• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2886
  • Last Modified:

Printer shared on 2008 R2, user gets access is denied on XP

I setup a Windows 2008 R2 (Std) as a print server.  I have setup multiple printers to be shared on it.  One HP is giving me issues.  I have it shared and when the user connects (validated her share permissions) she sees cannot connect, access is denied.  She can connect fine to another printer shared on the same server, no problem.  
0
ehess
Asked:
ehess
  • 5
  • 3
1 Solution
 
The_ChaddCommented:
Have you installed the x86 drivers on the 2008 R2 printserver (under the sharing - additional drivers tab)?

In the printer properties, are the groups and usernames on the security tab the same as the other printers?

If she browses the root of the print server from her workstation (Start, Run, type: \\printservername) can she see the printer she wants to connect to? If she double clicks the printer, does it install?

Kempy
0
 
SandeshdubeyCommented:
Hi, access denied may mean that the user/users do not have enough permissions to print. So do the users that are having problems have something in common e.g. belonging to a certain group. Can an admin log onto one of the XP machines and print? If so then it has to be a group policy from the server side.

On your Print Server,
Select the printer the user can’t access: properties>security settings and add the name of the domain user who can’t access the device and apply.

Go to start, all programs, administrative tools
Select "User Rights Assignment"
Double click on "Access this computer from the network". Click on "Add User or Group". Type "everyone" and then click on "Check Names". Select "everyone" and click ok.

On the XP computer with the problem - Logon using the users credentials who has the “Access Denied” message. Delete only the printer that cannot access the server.

Logoff and Logon as the same user and you should be able add this printer.

Also Turn on DEP for essential Windows programs and services only.
1. Go to Control Panel
2. Maintenance and Performance
3. Click System Icon
4. Advanced
5. Performance under Settings
6. Performance Options---->Data Execution Prevention
7. Choose ----> Turn on DEP for essential Windows programs and services only.
8. Click Apply and OK.

Also check the group policy setting from server if above does not work.


0
 
ehessAuthor Commented:
I have already installed the 32 bit drivers on the 64 bit 2008 server.  I'll try Sandeshdubey suggestions today.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
ehessAuthor Commented:
The Server 2008 R2 doesn't have User Rights Assignment in Administrator Tools.  The server is part of a domain and I don't know if that is the reason or if it's a role or feature that I need to enable.  I checked both the roles and features and didn't see anything regarding User Rights.  I had a Group Policy for the user in place which assigned the printer to her user account and the computer.  I validated the GP applied, but it still failed.  This is what it said.  

User Config\Preferences\Control Panel Settings\Printers\TCP/IP Printer\IP of printer\
The following settings have applied to this object.  Within this category, settings nearest the top of the report are the prevailing settings when resolving conflicts.  
IP of Printer
Winning GPO - GPO with printer assignment
Result: Failure (Error Code: 0x80070706)

I then deleted the GPO and tried to manually add the shared printer for the user.  Still same issue, access is denied.  

I changed the security on the printer share to everyone full control and still the user gets access is denied.  

I tried another user on a different XP computer (non admin user) and connected successfully to the printer.  

Not sure what to try next.  

It's only the HP printer causing issues, the user has a Xerox printer added through another GPO that works successfully.  

I added the GPO back.

I found this and made sure the GPO had "Run in logged-on user's security context" in the "Common" tab checked.  Still no difference, even if the user was targeted.  
0
 
SandeshdubeyCommented:
You will get User rights Assigment setting in control pannel==>administrative tools==>Local Security setting==>Local Policies==>User Rights Assigment.

Also try below setting:
1. Enable the guest account on the server or PC where Printer is connected
2. Add the guest account. Go to start, all programs, administrative tools
3. Select "User Rights Assignment"
4. Double click on "Access this computer from the network". Click on "Add User or Group". Type "guest" and then click on "Check Names". Select "guest" and click ok.
5. Double click on "Deny access to this computer from the network", and remove the guest account from it.
0
 
ehessAuthor Commented:
Everyone and Authenticated Users are already allowed.  I will not add a guest to the Domain Controller, which is hosting the printer.  
0
 
SandeshdubeyCommented:
If it is as DC then don't add guest account.
0
 
ehessAuthor Commented:
I made sure DEP was enabled on the XP machine for essential Windows programs and services, it was.  
There was no unique firewall setting on the XP machine.  
A static IP address was assigned to both the print server and the PC, for other purposes.  

I finally gave in and just added the printer locally on the XP machine using the TCP IP port.  When I added the driver it would fail if I kept the current driver, but worked successfully if I used the new driver I had downloaded from HP.  
FYI...the new print server had the latest HP drivers (both x86 & 64), but the XP machine was still accessing the OLD print server shared printer so it had the old driver loaded.  
0
 
ehessAuthor Commented:
It was a work around, not a complete solution.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now