how to run a program to avoid UAC problems

I use OneSuite's Internet Fax Service.  They use their "printer driver" as a means for me to "print" a document using their driver, which opens up their fax client so I can create a cover page and fill in recipient info like fax#.  I click on "send" and the fax is sent via internet through OneSuite's server.

The printer driver doesn't work if UAC is set to default.  So I have to set it to "Never notify me" and reboot every time I want to send a fax.

Is there something I can do to fix this problem so I don't have to disable UAC -- maybe give the SendMng.exe file special permissions?

Running W7 64
SAbboushiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bz43Commented:
I don't have that program but this might work for you.

Right click the program you use and select Properties.  
Then, click the tab name Compatibility.
Under Privilege Level put a check mark in "Run this program as an administrator" and click Apply.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
marsiliesCommented:
On their site, Onesuite explains this is because it tries to create a temp file at C:\, which it doesn't have access to with UAC on.

Their recommended solution is to create a new phonebook within your Documents folder. Instructions here:
http://www.onesuite.com/faqs_OSFax.asp#M60
nobusCommented:
in Windows  7  you can enable the hidden admin account, and use that : net user administrator /active:yes
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

SAbboushiAuthor Commented:
bz43 - great idea!  Unfortunately, that did not work...  but this is the type of solution I had in mind!

marsilies - thanks.  I tried that a few months ago in desperation, even though the link you reference is for a problem I don't experience ("Why do I get a "Error #80004005" pop-up message when I start OSFX?")

OneSuite support has been unhelpful.

nobus - I am an admin.  Does the admin account gives me any different privileges than an admin user?

Although I would still like to figure out a workaround, I signed up for GreenFax last night for outbound internet fax service.  
marsiliesCommented:
Do you have the most recent version of their software? A lot of vendors had to update their programs when Vista introduced UAC.

What's the error that appears when you try to use the program with UAC on?

The hidden/deactivated "Administrator" account does not give any additional privileges over any other account with admin privileges.
SAbboushiAuthor Commented:
>> Do you have the most recent version of their software?

Yes

>> What's the error that appears when you try to use the program with UAC on?

No error received - the fax client window just doesn't appear.  Nothing in the W7 event log.
marsiliesCommented:
I'd try completely uninstalling the program, then reinstalling it. Make sure UAC is on, and run the installer as administrator.

From:
http://www.edbott.com/weblog/2007/02/what-happens-when-those-tips-dont-work/
User settings for some programs go in different places, depending on whether UAC is on or off. If you install with UAC off and then turn it back on, some of your programs might get confused.
If you had originally installed it with UAC off, this could explain why it only works now when UAC is off.

In any case, an uninstall/reinstall of a program is sometimes effective in clearing up some problems with it.
SAbboushiAuthor Commented:
Thanks - I really appreciate your effort.  I have tried this approach several times but still no joy.  As best as I can tell, I believe the problem is that OneSuite is using a client program (SendMgr.exe) from XMediusFAX that is from 2008...

marsiliesCommented:
2008 is after Vista introduced UAC, and they already identified one UAC issue in their FAQ, so it may not be that.

From their FAQ, it seems like they may not support Windows 7:
http://www.onesuite.com/faqs_OSFax.asp#M48
What platforms are supported by OSFX?

OSFX supports the following programs: Windows XP, Windows 2000 SP4, Windows 2003, Windows 2008, and Windows Vista.

Perhaps try running the executable in Compatibility Mode. Set the compatibility for XP or Vista.
jcimarronCommented:
SAbboushi--You could avoid UAC specitically for the One Suite fax program
http://www.sevenforums.com/tutorials/11949-elevated-program-shortcut-without-uac-prompt-create.html
SAbboushiAuthor Commented:
>> Perhaps try running the executable in Compatibility Mode.
marsilies - thanks again - you are a trooper (that's a compliment)!  Already tried that (XP SP2 and SP3)... no go
SAbboushiAuthor Commented:
jcimarron - tried your approach, but no difference.

I suspect that UAC is preventing SendMgr.exe from getting access to something.  But I think I'm done with OneSuite Fax... just ran into another unrelated problem!

Thanks to all for your help.

With Regards-
Sam
SAbboushiAuthor Commented:
Thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.