Dell Optiplex 990 Wake On Lan issues

So we have bought 34 of these Dell Optiplex 990 Desktop PCs. About 50% of them I can get the WOL option to work. They are all the same configuration and they are all the same OEM image from dell. Other than windows updates these are pretty plain machines. To enable I went into the bios and turn on "WAKE ON LAN" to "LAN only" as that's the only option. I then go into the network interface and under power management I check the box "Wake on Magic Packet and Wake on Pattern Match" These are Intel 82579LM Gig Adapters on the board. Again about 50% seem to work just fine. I can put them into sleep mode and send WOL and it wakes up. In digging into the ones that don't work I found out that if I run from cmd elevated "powercfg -devicequery wake_armed" The ones that do work have the "Intel(R) 82579LM Gigabit Network Connection" Listed, but the ones that don't, don't have it listed. So i tried "powercfg -deviceenablewake "Intel(R) 82579LM Gigabit Network Connection" which adds just fine, but on a reboot it's not there. So it's like the setting does not take. Also with the intel driver there isn't a check box to "allow this device to wake the pc" option. Any help would be great, Dell's tech support blows so their no help. I guess I could call MS, but they may just point to intel. BTW running windows 7 pro.

Thanks

matrixnetworksAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

marsiliesCommented:
It sounds like it could be a BIOS option. Try updating the BIOS on the ones that aren't working. The most recent version BIOS for the Optiplex 990, A06, was just released last month:
http://support.euro.dell.com/support/downloads/download.aspx?c=is&cs=isbsdt1&l=en&s=bsd&releaseid=R309592&SystemID=PLX_990&fileid=467593

Note, if the BIOS isn't currently version A05, upgrade to that before upgrading to A06. File for A05 here:
http://support.dell.com/support/downloads/download.aspx?c=us&cs=RC956904&l=en&s=hied&releaseid=R305398&SystemID=PLX_990&fileid=460412
marsiliesCommented:
Note, I meant it could be a BIOS problem.
teomcamCommented:
They fixed a lot of problem with the A06 BIOS update. BUT first you must update to A05 then A06!
matrixnetworksAuthor Commented:
It wasn't a BIOS issue, but I did it get working.
What didn't work
powercfg -deviceenablewake "Intel(R) 82579LM Gigabit Network Connection"
This would show as set, using powercfg -devicequery wake_armed, but on a reboot it didn't take

Looking into powershell, this seemed to work.

****
$namespace = "root\WMI"
Write-Host "Enable `"Allow the computer to turn off this device to save power`""
Get-WmiObject  Win32_NetworkAdapter -filter "AdapterTypeId=0" | % {
  $strNetworkAdapterID=$_.PNPDeviceID.ToUpper()
  Get-WmiObject -class MSPower_DeviceEnable -Namespace $namespace | % {
    if($_.InstanceName.ToUpper().startsWith($strNetworkAdapterID)){
      $_.Enable = $true
      $_.Put() | Out-Null
    }
  }
}
   
   
Write-Host "Enable `"Allow this device to wake the computer`""
Get-WmiObject Win32_NetworkAdapter -filter "AdapterTypeId=0" | % {
  $strNetworkAdapterID=$_.PNPDeviceID.ToUpper()
  Get-WmiObject -class MSPower_DeviceWakeEnable  -Namespace $namespace | % {
    if($_.InstanceName.ToUpper().startsWith($strNetworkAdapterID)){
      $_.Enable = $true
      $_.Put() | Out-Null
    }
  }
}
****

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
matrixnetworksAuthor Commented:
We fixed our selfs
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.