Email not sent when Task is complete

I have a tasked scheduled with an actin to email me an message when the task is done. However, no email is sent. History does not show any errors. The task completes successfully, but no email. Could there be a port that is blocked? Port 25? If so, how do I unblock this port on Windows Server 2008 R2?

Thanks.
gtrappAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
do you have smtp enabled?
0
gtrappAuthor Commented:
The smtp service/server that I am using is on a different server. SMTP is not running on the server where the task is running.
0
David Johnson, CD, MVPOwnerCommented:
That could explain it right there
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

gtrappAuthor Commented:
So, I need to have SMTP running on the same server? I can't use another service running on another server?
0
David Johnson, CD, MVPOwnerCommented:
taskmanager has no idea of where the smtp server is.. or which one to use if there are many servers that have the service enabled. did you configure the server ??
and in the taskmanager did you put the server name?
0
David Johnson, CD, MVPOwnerCommented:
by server name *I mean the server that has the smtp service running*
I don't mean an email server that requires authorization i.e. smtp.google.com
0
gtrappAuthor Commented:
The server name is SERVER345 where the task is running. In the task, I have specified thoth.pbtf.com as the SMTP server in the Edit Action dialog, a SMTP server that I have used for other programs. With these other programs, I just specify thoth.pbtf.com and email is sent.

Does SMTP need to be on SERVER345?
0
David Johnson, CD, MVPOwnerCommented:
do they work with this server .. they might have their own built in smtp library
0
gtrappAuthor Commented:
Not sure what you mean. On the server with the smtp service that I have used, its on a Windows Server 2003. SERVER345 is a Windows Server 2008. Would there be ports that are blocked on the 2008 server?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gtrappAuthor Commented:
I installed the SMTP service on the server, but that did not work. I will look into opening the port 25.
0
gtrappAuthor Commented:
I needed to look else where for assistance with this.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.