setup python

hello there,
I need to setup python v2.4 on centos v6 like I have on my other box running centos v5.7.
when I download the rpm is get issue with required libraries.. how can I set it up?

centos v6
[(01:02 AM)][(root@alpha)] [(~)] $ rpm -q python
python-2.6.5-3.el6_0.2.x86_64  

centos v5.7
[(12:42 AM)][(root@critical)] [(~)] $ rpm -q python
python-2.4.3-44.el5_7.1.x86_64  
LVL 1
XK8ERAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PapertripCommented:
You said you need to setup 2.4 on CentOS 6, but rpm -q says it's 2.6.

If you are fine with 2.6, then you should be using yum to manage your packages.
yum install python

Open in new window

0
XK8ERAuthor Commented:
its already installed.. I need python v2.4
[(01:12 AM)][(root@alpha)] [(/etc/yum.repos.d)] $ yum install python
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * base: mirror.ash.fastserv.com
 * extras: yum.singlehop.com
 * updates: mirror.7x24web.net
base                                                                                                                                                                                                                     | 3.7 kB     00:00
extras                                                                                                                                                                                                                   | 3.0 kB     00:00
updates                                                                                                                                                                                                                  | 3.5 kB     00:00
Setting up Install Process
Package python-2.6.5-3.el6_0.2.x86_64 already installed and latest version
Nothing to do

Open in new window

0
PapertripCommented:
I'm not sure of the consequences of having 2 versions of python on the system at the same time, but I can definitely help you do it anyways :p

How are you trying to install 2.4 and what are the errors you are getting.  The more info you give us, the faster you will get your solution.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

XK8ERAuthor Commented:
im trying to install by download the rpmbut its not working

[(01:24 AM)][(root@alpha)] [(~)] $ rpm -Uhv python-2.4.3-44.el5_7.1.x86_64.rpm
warning: python-2.4.3-44.el5_7.1.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID e8562897: NOKEY
error: Failed dependencies:
        libpython2.4.so.1.0()(64bit) is needed by python-2.4.3-44.el5_7.1.x86_64
        python-libs-x86_64 = 2.4.3-44.el5_7.1 is needed by python-2.4.3-44.el5_7.1.x86_64
        python(abi) = 2.6 is needed by (installed) dbus-python-0.83.0-6.1.el6.x86_64
        python(abi) = 2.6 is needed by (installed) report-plugin-ftp-0.18-7.el6.centos.x86_64
        python(abi) = 2.6 is needed by (installed) report-plugin-localsave-0.18-7.el6.centos.x86_64
        python(abi) = 2.6 is needed by (installed) report-0.18-7.el6.centos.x86_64
        python(abi) = 2.6 is needed by (installed) report-plugin-scp-0.18-7.el6.centos.x86_64
        python(abi) = 2.6 is needed by (installed) newt-python-0.52.11-2.el6.x86_64
        python(abi) = 2.6 is needed by (installed) pygobject2-2.20.0-5.el6.x86_64
        python(abi) = 2.6 is needed by (installed) rpm-python-4.8.0-12.el6.x86_64
        python(abi) = 2.6 is needed by (installed) authconfig-6.1.4-6.el6.x86_64
        python(abi) = 2.6 is needed by (installed) abrt-addon-python-1.1.13-4.el6.x86_64
        python(abi) = 2.6 is needed by (installed) python-ethtool-0.3-5.1.el6.x86_64
        python(abi) = 2.6 is needed by (installed) libxml2-python-2.7.6-1.el6.x86_64
        python(abi) = 2.6 is needed by (installed) system-config-printer-libs-1.1.16-17.el6.x86_64
        python(abi) = 2.6 is needed by (installed) pyorbit-2.24.0-5.el6.x86_64
        python(abi) = 2.6 is needed by (installed) python-ldap-0:2.3.10-1.el6.x86_64
        python(abi) = 2.6 is needed by (installed) pyxf86config-0.3.37-7.1.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gamin-python-0.1.10-9.el6.x86_64
        python(abi) = 2.6 is needed by (installed) yum-metadata-parser-1.1.2-14.1.el6.x86_64
        python(abi) = 2.6 is needed by (installed) pygpgme-0.1-18.20090824bzr68.el6.x86_64
        python(abi) = 2.6 is needed by (installed) python-markupsafe-0.9.2-4.el6.x86_64
        python(abi) = 2.6 is needed by (installed) python-crypto-2.0.1-22.el6.x86_64
        python(abi) = 2.6 is needed by (installed) libselinux-python-2.0.94-2.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gnome-menus-2.28.0-4.el6.x86_64
        python(abi) = 2.6 is needed by (installed) python-slip-0.2.11-1.el6.noarch
        python(abi) = 2.6 is needed by (installed) python-urlgrabber-3.9.1-7.el6.noarch
        python(abi) = 2.6 is needed by (installed) python-paramiko-1.7.5-2.1.el6.noarch
        python(abi) = 2.6 is needed by (installed) sos-2.2-2.el6.noarch
        python(abi) = 2.6 is needed by (installed) report-newt-0.18-7.el6.centos.x86_64
        python(abi) = 2.6 is needed by (installed) python-iniparse-0.3.1-2.1.el6.noarch
        python(abi) = 2.6 is needed by (installed) yum-3.2.27-14.el6.centos.noarch
        python(abi) = 2.6 is needed by (installed) pyxdg-0.18-1.el6.noarch
        python(abi) = 2.6 is needed by (installed) python-beaker-1.3.1-6.el6.noarch
        python(abi) = 2.6 is needed by (installed) python-mako-0.3.4-1.el6.noarch
        python(abi) = 2.6 is needed by (installed) python-decorator-3.0.1-3.1.el6.noarch
        python(abi) = 2.6 is needed by (installed) python-slip-dbus-0.2.11-1.el6.noarch
        python(abi) = 2.6 is needed by (installed) libproxy-python-0.3.0-2.el6.x86_64
        python(abi) = 2.6 is needed by (installed) PackageKit-0.5.8-13.el6.x86_64    
        python(abi) = 2.6 is needed by (installed) pycairo-1.8.6-2.1.el6.x86_64
        python(abi) = 2.6 is needed by (installed) pygtk2-2.16.0-3.el6.x86_64
        python(abi) = 2.6 is needed by (installed) pygtk2-libglade-2.16.0-3.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gstreamer-python-0.10.16-1.1.el6.x86_64
        python(abi) = 2.6 is needed by (installed) pygtksourceview-2.8.0-1.el6.x86_64
        python(abi) = 2.6 is needed by (installed) pywebkitgtk-1.1.6-3.el6.x86_64
        python(abi) = 2.6 is needed by (installed) notify-python-0.1.1-10.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gnome-python2-libwnck-2.28.0-4.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gnome-python2-2.28.0-3.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gnome-python2-gconf-2.28.0-3.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gnome-python2-canvas-2.28.0-3.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gnome-python2-gnomekeyring-2.28.0-4.el6.x86_64
        python(abi) = 2.6 is needed by (installed) report-gtk-0.18-7.el6.centos.x86_64
        python(abi) = 2.6 is needed by (installed) python-slip-gtk-0.2.11-1.el6.noarch
        python(abi) = 2.6 is needed by (installed) python-iwlib-0.1-1.2.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gnome-python2-bonobo-2.28.0-3.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gnome-python2-gnomevfs-2.28.0-3.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gnome-python2-gnome-2.28.0-3.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gnome-python2-libegg-2.25.3-20.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gnome-python2-applet-2.28.0-4.el6.x86_64
        python(abi) = 2.6 is needed by (installed) ibus-1.3.4-3.el6.x86_64
        python(abi) = 2.6 is needed by (installed) at-spi-python-1.28.1-2.el6.x86_64
        python(abi) = 2.6 is needed by (installed) python-meh-0.9-1.el6.noarch
        python(abi) = 2.6 is needed by (installed) system-config-services-0.99.45-1.el6.3.noarch
        python(abi) = 2.6 is needed by (installed) system-config-date-1.9.60-1.el6.noarch
        python(abi) = 2.6 is needed by (installed) system-config-keyboard-1.3.1-3.el6.x86_64
        python(abi) = 2.6 is needed by (installed) firstboot-1.110.8-1.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gnome-applets-1:2.28.0-7.el6.x86_64
        python(abi) = 2.6 is needed by (installed) ipa-client-2.0-9.el6.x86_64
        python(abi) = 2.6 is needed by (installed) ibus-anthy-1.2.1-1.el6.x86_64
        python(abi) = 2.6 is needed by (installed) gnome-packagekit-2.28.3-3.el6.x86_64
        python(abi) = 2.6 is needed by (installed) orca-2.28.2-1.el6.x86_64
        python(abi) = 2.6 is needed by (installed) cas-0.15-1.el6.1.noarch
        python(abi) = 2.6 is needed by (installed) cracklib-python-2.8.16-4.el6.x86_64
        python(abi) = 2.6 is needed by (installed) libuser-python-0.56.13-4.el6_0.1.x86_64
        python(abi) = 2.6 is needed by (installed) hplip-libs-3.9.8-33.el6_0.1.x86_64
        python(abi) = 2.6 is needed by (installed) sssd-1.2.1-28.el6_0.4.x86_64
        python(abi) = 2.6 is needed by (installed) vte-0.25.1-6.el6.x86_64
        python(abi) = 2.6 is needed by (installed) python-pycurl-7.19.0-8.el6.x86_64
        python-sqlite is needed by (installed) yum-3.2.27-14.el6.centos.noarch
        python-sqlite is needed by (installed) cas-0.15-1.el6.1.noarch
        python = 2.6.5-3.el6_0.2 is needed by (installed) python-libs-2.6.5-3.el6_0.2.x86_64    

Open in new window


[(01:26 AM)][(root@alpha)] [(~)] $ rpm -Uhv python-libs-2.4.3-44.el5_7.1.x86_64.rpm
warning: python-libs-2.4.3-44.el5_7.1.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID e8562897: NOKEY
error: Failed dependencies:
        libcrypto.so.6()(64bit) is needed by python-libs-2.4.3-44.el5_7.1.x86_64
        libdb-4.3.so()(64bit) is needed by python-libs-2.4.3-44.el5_7.1.x86_64
        libexpat.so.0()(64bit) is needed by python-libs-2.4.3-44.el5_7.1.x86_64
        libreadline.so.5()(64bit) is needed by python-libs-2.4.3-44.el5_7.1.x86_64
        libssl.so.6()(64bit) is needed by python-libs-2.4.3-44.el5_7.1.x86_64
        libtermcap.so.2()(64bit) is needed by python-libs-2.4.3-44.el5_7.1.x86_64
        python(abi) = 2.4 is needed by python-libs-2.4.3-44.el5_7.1.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) rpm-python-4.8.0-12.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) python-ethtool-0.3-5.1.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) libxml2-python-2.7.6-1.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) system-config-printer-libs-1.1.16-17.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) python-ldap-0:2.3.10-1.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) yum-metadata-parser-1.1.2-14.1.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) pygpgme-0.1-18.20090824bzr68.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) python-markupsafe-0.9.2-4.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) python-crypto-2.0.1-22.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) gstreamer-python-0.10.16-1.1.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) gnome-python2-gconf-2.28.0-3.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) gnome-python2-canvas-2.28.0-3.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) python-iwlib-0.1-1.2.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) gnome-python2-bonobo-2.28.0-3.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) gnome-python2-gnomevfs-2.28.0-3.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) gnome-python2-gnome-2.28.0-3.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) totem-2.28.6-2.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) rhythmbox-0.12.8-1.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) ibus-anthy-1.2.1-1.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) gedit-1:2.28.4-3.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) python-2.6.5-3.el6_0.2.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) sssd-1.2.1-28.el6_0.4.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) vim-enhanced-2:7.2.411-1.6.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) python-pycurl-7.19.0-8.el6.x86_64
        libpython2.6.so.1.0()(64bit) is needed by (installed) gdb-7.1-29.el6_0.1.x86_64
        python-libs(x86-64) is needed by (installed) gdb-7.1-29.el6_0.1.x86_64      

Open in new window

0
PapertripCommented:
Trying to install an RPM for an earlier version of Python than is already installed is going to throw all the errors you pasted.  You will need to compile from source.

Following these instructions should not interfere with the 2.6 version already installed.
wget http://www.python.org/ftp/python/2.4.3/Python-2.4.3.tgz
tar -zxvf Python-2.4.3.tgz
cd Python-2.4.3
./configure && make altinstall

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
XK8ERAuthor Commented:
I have done the following.. how can I run a script using that version of python?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.