[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 872
  • Last Modified:

Cisco 2600 routing

I have a layer 2 HP switch set up with Vlans, I can ping between them all but as it does not have RIP or PIM it will not allow my CCTV network to see all the units connected into the different VLans.
My question is can I connect a Cisco 2600 router to the switch to rout between all the vlans, if so how would I set it to do that?

I have attached the config of the HP switch and also the version of the Cisco 2600. 2600-Version.txt J4904A-Configuration.txt
0
koop1koop
Asked:
koop1koop
  • 49
  • 43
  • 4
  • +1
1 Solution
 
SouljaCommented:
What you would do is remove the vlan interfaces from the HP switch. Leave the actual vlan on the switch. Then create a dot1q trunk on the switch to connect to the router.

On the router you would for example use the fa0/1 interface for your vlan routing "router on a stick" setup:

interface fa0/1.1
encapsulation dot1q 1
ip address 192.168.5.1 255.255.255.0

interface fa0/1.2
encapsulation dot1q 2
ip address 192.168.6.1 255.255.255.0

interface fa0/1.3
encapsulation dot1q 3
ip address 102.168.7.1 255.255.255.0

interface fa0/1.4
encapsulation dot1q 4
ip address 102.168.8.1 255.255.255.0

interface fa0/1.5
encapsulation dot1q 5
ip address 102.168.9.1 255.255.255.0

interface fa0/1
no shut


Connect the trunk on the switch to the fa0/1 interface on the router. If you are using nat, you will need to add ip nat inside to all the subinterfaces, and ip nat outside on the fa0/0 interface.  

Add you default route to your next hop to the isp also on the router

ip route 0.0.0.0 0.0.0.0 x.x.x.x (isp next hop)
0
 
jmeggersCommented:
You can.  You will trunk a port from the HP switch (can't tell you how to do that) and set up sub interfaces on the 2600, one for each VLAN

interface FA0/0
no ip address

interface FA0/0.10
encapsulation dot1q 10              <= VLAN number
ip address x.x.x.x 255.255.255.0

interface FA0/0.20
encapsulation dot1q 20 <native>  <= if this is the native (untagged) VLAN
ip address y.y.y.y 255.255.255.0

The 2600 will route between the connected subnets.
0
 
koop1koopAuthor Commented:
so on the HP switch I would remove
ip address 192.168.x.1 255.255.255.0 from each vlan, would I need to remove the ip helper too?
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
SouljaCommented:
Yes, you will need to add the helpers to the subinterfaces on the router.
0
 
SouljaCommented:
The switch will be doing no routing for you now.
0
 
jmeggersCommented:
Yes, I would remove the addresses from the switch, although they won't hurt anything if they stay.
0
 
koop1koopAuthor Commented:
can you explain ho I do this part please?
Then create a dot1q trunk on the switch to connect to the router.

is the trunk one port per Vlan I'm not to sure about it
0
 
SouljaCommented:
The trunk will carry all of your vlans.
0
 
koop1koopAuthor Commented:
sorry, its the crating of the trunk I dont quite understand.

This is what i have so far

Running configuration:

 
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.1
 encapsulation dot1Q 1 native
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 102.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 102.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 102.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Open in new window

!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.1
 encapsulation dot1Q 1 native
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 102.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 102.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 102.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Open in new window

0
 
koop1koopAuthor Commented:
0
 
koop1koopAuthor Commented:
Can anyone help on how to create the trunks needed please?
0
 
ArneLoviusCommented:
You have a L3 switch, I do not understand what you are trying to acheive.

If you need to run RIP to advertise routes to other networks, use your router to run RIP on the external conections.

If you move your internal routing from the L3 switch to the router, all internal routing trffic will go over the trunk between the switch and the router and it _will_ become a bottleneck.

a diagram of what you have and where you perceive the problem to be might be useful
0
 
koop1koopAuthor Commented:
I have been told that the switch is not a full layer 3 switch, it is being used in a CCTV system (pelco Endura) that uses multicast.
as far as I know the switch wont work on its own as it does not have RIP or PIM.

What I was wanting to do was add the router so that I can route between the Vlans hopefully!

What I dont understand is how to create the trunk on the HP switch to get the data to the Cisco 2600 enabling the routing.

0
 
ArneLoviusCommented:
It is a L3 switch. It can route between VLANS.

http://ftp.hp.com/pub/networking/software/AdvTraff-Oct2005-59908853-Chap07-IProuting.pdf

What do you need to use RIP for ? are other routers involved ?

For simple VLAN trunk configuration, use the menu interface on the console rather than the plain command line.
0
 
koop1koopAuthor Commented:
when I had the switch set up as in the attached I could ping all and I got DHCP in each vlan from the DHCP server. All seemed to be ok.

The problem I was having was that the CCTV system would not see the equipment connected in each Vlan even though the system manager 192.168.5.10 was dishing out ip addresses to each unit connected in each Vlan.
Speaking to the manufacturer they told me that as the switch did not have RIP and PIM it would not see the different Vlans. apparently it is because the system uses multicast
 
Running configuration:

; J4904A Configuration Editor; Created on release #I.08.98

hostname "ProCurve Switch 2848" 
snmp-server contact "Mark" 
snmp-server location "Endura" 
ip default-gateway 192.168.5.10 
ip routing 
snmp-server community "public" Unrestricted 
vlan 1 
   name "VLAN1" 
   untagged 1,19-43,46-48 
   ip address 192.168.5.1 255.255.255.0 
   ip helper-address 192.168.5.10 
   no untagged 2-18,44-45 
   ip igmp 
   ip irdp 
   exit 
vlan 2 
   name "VLAN2" 
   untagged 2-9 
   ip address 192.168.6.1 255.255.255.0 
   ip helper-address 192.168.5.10 
   ip igmp 
   ip irdp 
   exit 
vlan 3 
   name "VLAN3" 
   untagged 10,44-45 
   ip address 192.168.7.1 255.255.255.0 
   ip helper-address 192.168.5.10 
   ip igmp 
   ip irdp 
   exit 
vlan 4 
   name "VLAN4" 
   untagged 11-14,18 
   ip address 192.168.8.1 255.255.255.0 
   ip helper-address 192.168.5.10 
   ip igmp 
   ip irdp 
   exit 
vlan 5 
   name "VLAN5" 
   untagged 15-17 
   ip address 192.168.9.1 255.255.255.0 
   ip helper-address 192.168.5.10 
   ip igmp 
   ip irdp 
   exit 
ip route 0.0.0.0 0.0.0.0 192.168.5.10

Open in new window

0
 
ArneLoviusCommented:
multicast does not require RIP

you have a helper address configured on each port, so I presume that you are managing DHCP on a single DHCP server. each DHCP scope should have the "router' configured to be the interface addres for that VLAN/subnet on the HP

unless you are doing multicast filtering on the HP, then it should "just work"

you are also on a very old release of software, I would suggest updating to current

https://h10145.www1.hp.com/downloads/SoftwareReleases.aspx?ProductNumber=J4904A

for more on the capabilities of the switch
http://ftp.hp.com/pub/networking/software/2600-2800-4100-6108-MgmtConfig-Oct2005-59906023.pdf
http://ftp.hp.com/pub/networking/software/2600-2800-4100-6108-AdvTraff-Oct2005-59908853.pdf
0
 
koop1koopAuthor Commented:
I agree, I was under the impression that it should work. I have upgraded the software but I still have the same issue.
I was told that "The HP switch looks like it’s blocking some Multicast"

is there anything else you can suggest?
0
 
ArneLoviusCommented:
can you post the output from

show ip igmp config

Open in new window

0
 
koop1koopAuthor Commented:
VLAN ID VLAN NAME    IGMP Enabled Forward with High Priority Querier Allowed
  ------- ------------ ------------ -------------------------- ---------------
  1       vlan1        Yes          No                         Yes
  2       vlan2        Yes          No                         Yes
  3       vlan3        Yes          No                         Yes
  4       vlan4        Yes          No                         Yes
  5       vlan5        Yes          No                         Yes
0
 
koop1koopAuthor Commented:
VLAN ID VLAN NAME    IGMP Enabled   Forward with High Priority   Querier Allowed
  -------    ------------       ------------         --------------------------           ---------------
  1       vlan1                    Yes                   No                                        Yes
  2       vlan2                    Yes                   No                                        Yes
  3       vlan3                    Yes                   No                                        Yes
  4       vlan4                    Yes                   No                                        Yes
  5       vlan5                    Yes                   No                                        Yes
0
 
ArneLoviusCommented:
can you now post the output from each of these commands

show ip igmp 1 config
show ip igmp 2 config
show ip igmp 3 config
show ip igmp 4 config
show ip igmp 5 config

Open in new window

0
 
koop1koopAuthor Commented:
IGMP Service

  VLAN ID : 1
  VLAN NAME    : vlan1
  IGMP Enabled [No] : Yes
  Forward with High Priority [No] : No
  Querier Allowed [Yes] : Yes

  Port Type      | IP Mcast
  ---- --------- + --------
  1              | Auto
  19             | Auto
  20             | Auto
  21             | Auto
  22             | Auto
  23             | Auto
  24             | Auto
  25             | Auto
  26             | Auto
  27             | Auto
  28             | Auto
  29             | Auto
  30             | Auto
  31             | Auto
  32             | Auto
  33             | Auto
  34             | Auto
  35             | Auto
  36             | Auto
  37             | Auto
  38             | Auto
  39             | Auto
  40             | Auto
  41             | Auto
  42             | Auto
  43             | Auto
  44             | Auto
  45             | Auto
  46             | Auto
  47             | Auto
  48             | Auto

Open in new window

IGMP Service

  VLAN ID : 2
  VLAN NAME    : vlan2
  IGMP Enabled [No] : Yes
  Forward with High Priority [No] : No
  Querier Allowed [Yes] : Yes

  Port Type      | IP Mcast
  ---- --------- + --------
  2              | Auto
  3              | Auto
  4              | Auto
  5              | Auto
  6              | Auto
  7              | Auto
  8              | Auto
  9              | Auto

Open in new window


IGMP Service

  VLAN ID : 3
  VLAN NAME    : vlan3
  IGMP Enabled [No] : Yes
  Forward with High Priority [No] : No
  Querier Allowed [Yes] : Yes

  Port Type      | IP Mcast
  ---- --------- + --------
  10             | Auto

Open in new window

IGMP Service

  VLAN ID : 4
  VLAN NAME    : vlan4
  IGMP Enabled [No] : Yes
  Forward with High Priority [No] : No
  Querier Allowed [Yes] : Yes

  Port Type      | IP Mcast
  ---- --------- + --------
  11             | Auto
  12             | Auto
  13             | Auto
  14             | Auto
  18             | Auto

Open in new window

IGMP Service

  VLAN ID : 5
  VLAN NAME    : vlan5
  IGMP Enabled [No] : Yes
  Forward with High Priority [No] : No
  Querier Allowed [Yes] : Yes

  Port Type      | IP Mcast
  ---- --------- + --------
  15             | Auto
  16             | Auto
  17             | Auto

Open in new window

0
 
ArneLoviusCommented:
You have now shown that the HP switch is configured correctly

I would go back to the person that said "The HP switch looks like it’s blocking some Multicast" and ask them to confirm exactly what Multicast they think it is blocking.

From the above, I think it is more likely that the CCTV system is not configured correctly.




0
 
koop1koopAuthor Commented:
So the way the switch is set up no if I connect a PC into Vlan1 and one into Vlan2 should I be able to see them both?
0
 
ArneLoviusCommented:
I went to http://www.pelco.com/sites/global/en/products/video-management-solutions/downloads.page

I selected Endura IP Video Management | NSM5200 | Manuals

I then downloaded the attached
c4609m-a.pdf
0
 
ArneLoviusCommented:
as long as they each have the VLAN interfacxe address as their default gteway you should be able to ping between them or send any IP traffic between them
0
 
koop1koopAuthor Commented:
The following is what the CCTV manufacturer asked me to show them
ProCurve Switch 2848(config)# Show ip igmp

 Status and Counters - IP Multicast (IGMP) Status

 VLAN ID : 1
 VLAN Name : vlan1
 Querier Address : This switch is Querier

  Active Group Addresses Reports Queries Querier Access Port
  ---------------------- ------- ------- -------------------
  239.255.255.250        181     0

 VLAN ID : 2
 VLAN Name : vlan2
 Querier Address : This switch is Querier

  Active Group Addresses Reports Queries Querier Access Port
  ---------------------- ------- ------- -------------------
  239.255.255.250        256     0

 VLAN ID : 3
 VLAN Name : vlan3
 Querier Address : This switch is Querier

  Active Group Addresses Reports Queries Querier Access Port
  ---------------------- ------- ------- -------------------

 VLAN ID : 4
 VLAN Name : vlan4
 Querier Address : This switch is Querier

  Active Group Addresses Reports Queries Querier Access Port
  ---------------------- ------- ------- -------------------
  239.255.255.250        170     0

 VLAN ID : 5
 VLAN Name : vlan5
 Querier Address : This switch is Querier

  Active Group Addresses Reports Queries Querier Access Port
  ---------------------- ------- ------- -------------------
  239.168.9.199          42      0
  239.168.9.200          42      0
  239.255.255.250        86      0

Open in new window

0
 
koop1koopAuthor Commented:
ProCurve Switch 2848(config)# show ip igmp group 239.255.255.250

 IGMP ports for group 239.255.255.250

  Port  Type      Access      Age Timer Leave Timer
  ----- --------- ----------- --------- -----------
  1               host        0         0
  21              host        0         0
  43              host        0         0
  44              host        0         0
  2               host        0         0
  5               host        0         0
  6               host        0         0
  7               host        0         0
  8               host        0         0
  9               host        0         0
  12              host        0         0
  13              host        0         0
  14              host        0         0
  18              host        0         0
  16              host        0         0
  17              host        0         0

Open in new window

0
 
koop1koopAuthor Commented:
The manual is for Endura 2 which can be used on a layer 2 switch with no problems, I need to use it on the earlier version 1.3.

Multicast Routing Protocols
In a Layer 3 Endura network, multicast routing is used for critical intra-system communications such as device discovery and health check. It is also the preferred approach for transmitting digital video to viewing stations because multicast transmission uses network bandwidth more efficiently. If one or more subnets or VLANs exist, one of the following protocols can be used to meet this requirement.
DVMRP:
Protocol Independent Multicast (PIM):
0
 
koop1koopAuthor Commented:
LAYER 3 DESIGN APPROACH
When an Endura system is using a Layer 3 approach in its design, there is an inherent need to route Endura traffic between multiple VLANs or
subnets. If the Endura traffic will traverse multiple subnets or VLANs, appropriate multicast routing protocols must be used to facilitate the
multicast traffic throughout the network infrastructure. The following considerations need to be addressed when implementing a Layer 3 solution
with Endura.
• All Layer 3 devices do not have the ability to process data at line speed. Traditional routers that are used to route traffic across WAN
connections are typically implemented on devices that use software routing. Layer 3 switches typically implement a hardware solution to
handle all Layer 2 switching and Layer 3 routing. Routing for Endura should be performed by Layer 3 switches that have the capacity to
transfer the data at line speed. Software-based routers should only be used when the expectation is that a low volume of traffic will
traverse the link. This traffic volume should remain within the capabilities of the WAN router.
• A Layer 3 solution can be implemented using a centralized routing topology or a distributed routing topology. Based upon the routing load
that will be handled by a centralized Layer 3 switch, the decision to push the Layer 3 routing to the edge devices can help alleviate the
strain of a single core switch handling all routing decisions.
• At least one multicast routing protocol must be used to allow multicast routing between VLANs. Protocol Independent Multicast (PIM),
Distance Vector Routing Multicast Protocol (DVRMP), or Multicast Open Shortest Path First (MOSPF) can all be used to route multicast
traffic throughout the network. Careful planning must be performed to ensure that the multicast limits of the switch and protocol selected
are not exceeded.
• Careful consideration must be given to the number of Layer 3 hops that the Endura traffic is traversing. As the number of hops increases,
there will be an expected latency associated with the response of the Endura system. The default transistor-transistor logic (TTL) limits are
as follows:
– SMLocator service TTL = 4
– Video streams have a TTL = 3
– Local discover has a TTL = 1
These limits can be modified to accommodate different network topologies; staying within the default TTL limits will yield optimum performance.
0
 
ArneLoviusCommented:
If you used your Cisco 2600 series router to route between the VLANS, then all inter VLAN traffic will be going through a single 100mb  link.

On reading the manual, this might well not be enough bandwidth.

How many devices do you have in your network ?

How about having all of the Endura devices in a single VLAN ?

0
 
ArneLoviusCommented:
I just love the "The default transistor-transistor logic (TTL) "

TTL is Transistor Transistor Logic, but in the case it actually should be Time To Live

can you post the output from

show default values

Open in new window

0
 
koop1koopAuthor Commented:
There is not much traffic on the network as it is used for testing only, the reason 1 Vlan does not work is that:

the older Endura units search for cameras connected in the same Vlan as itself, so if we had more than one of the units connected to the same vlan then we are unable to tell the unit what video to record.
The 2nd unit connected will take the cameras from the 1st unit and so on. The Vlans are to segregate the different units and cameras to stop this.

the command you mentioned gives this error

Invalid input: default
0
 
ArneLoviusCommented:
so I'm guessing that you are trying to setup one camera and endura unit per VLAN, but then need the multicast support for a management application ?
0
 
koop1koopAuthor Commented:
yes.

What I have is
Vlan1 System Manager / DHCP Server 192.168.5.10
Vlan2 workstation / camera viewer
Vlan3 recorder / Camera
Vlan4 recorder / Camera / Poe switch with cameras
Vlan5 recorder / Camera
0
 
ArneLoviusCommented:
In which case you will need to use the Cisco

Apologies for taking you down the wrong route

If you can post the current config of the 2600 and the 2824 and let me know which port you want to use on the 2824 to connect to the Cisco I'll do both configs for you
0
 
koop1koopAuthor Commented:
I think it would be better to go down the route of the 2600 being at factory default and the 2848 is attached.

The 2600 has ports 0/0 & 0/1, I actually have x2 2600 units

on the 2848 to connect to the 2600 can be port 48

Thanks for your help on this

J4904A-Configuration.txt 2600-Version.txt
0
 
ArneLoviusCommented:
you can post these directly into a console connection

you should do the 2824 first, otherwise you will get an IP address conflict
2600-Version.txt
J4904A-Configuration.txt
0
 
ArneLoviusCommented:
after you have updated them, can you post the new configs so I can be sure that they are correct
0
 
koop1koopAuthor Commented:
HP2848
J4904A Configuration Editor; Created on release #I.10.77

hostname "ProCurve Switch 2848"
ip default-gateway 192.168.5.10
sntp server 192.168.5.10
ip routing
timesync sntp
sntp unicast
snmp-server community "public" Unrestricted
vlan 1
   name "vlan1"
   untagged 1,19-48
   ip address 192.168.5.1 255.255.255.0
   no untagged 2-18
   exit
vlan 2
   name "vlan2"
   untagged 2-9
   no ip address
   tagged 48
   exit
vlan 3
   name "vlan3"
   untagged 10
   no ip address
   tagged 48
   exit
vlan 4
   name "vlan4"
   untagged 11-14,18
   no ip address
   tagged 48
   exit
vlan 5
   name "vlan5"
   untagged 15-17
   no ip address
   tagged 48
   exit
gvrp
ip route 0.0.0.0 0.0.0.0 192.168.5.10

0
 
ArneLoviusCommented:
the address needs to be changed on VLAN1

vlan 1 
   name "vlan1" 
   untagged 1,19-48 
   ip address 192.168.5.1 255.255.255.0 

Open in new window


should be

vlan 1 
   name "vlan1" 
   untagged 1,19-48 
   ip address 192.168.5.2 255.255.255.0 

Open in new window

0
 
koop1koopAuthor Commented:
You may wish to use your browser to print the following report or to save it into a file.
--------------------------------------------------------------------------------
 

Running configuration:

; J4904A Configuration Editor; Created on release #I.10.77

hostname "ProCurve Switch 2848"
ip default-gateway 192.168.5.10
sntp server 192.168.5.10
ip routing
timesync sntp
sntp unicast
snmp-server community "public" Unrestricted
vlan 1
   name "vlan1"
   untagged 1,19-48
   ip address 192.168.5.2 255.255.255.0
   no untagged 2-18
   exit
vlan 2
   name "vlan2"
   untagged 2-9
   no ip address
   tagged 48
   exit
vlan 3
   name "vlan3"
   untagged 10
   no ip address
   tagged 48
   exit
vlan 4
   name "vlan4"
   untagged 11-14,18
   no ip address
   tagged 48
   exit
vlan 5
   name "vlan5"
   untagged 15-17
   no ip address
   tagged 48
   exit
gvrp
ip route 0.0.0.0 0.0.0.0 192.168.5.10
0
 
ArneLoviusCommented:
and the 2600
0
 
koop1koopAuthor Commented:
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.1
 encapsulation dot1Q 1 native
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 102.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 102.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 102.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
0
 
ArneLoviusCommented:
the interface is shut down

interface Ethernet0/0
 no ip address
 shutdown
 half-duplex

Open in new window


should be

interface Ethernet0/0
 no ip address
 no shutdown
 duplex auto
 speed auto

Open in new window

0
 
koop1koopAuthor Commented:
Router(config-if)# duplex auto
                          ^
% Invalid input detected at '^' marker.

Router(config-if)# speed auto
                    ^
% Invalid input detected at '^' marker.
0
 
ArneLoviusCommented:
sorry, my mistake, wrong interface...

interface Ethernet0/1
 no ip address
 half-duplex

Open in new window


should be

interface Ethernet0/1
 no ip address
 duplex auto
 speed auto

Open in new window



0
 
koop1koopAuthor Commented:
Router(config)#interface Ethernet0/1
Router(config-if)# no ip address
Router(config-if)# duplex auto
                          ^
% Invalid input detected at '^' marker.

Router(config-if)# speed auto
                    ^
% Invalid input detected at '^' marker.
embed=snippet 8225230]
Using 1404 out of 29688 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.1
 encapsulation dot1Q 1 native
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 102.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 102.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 102.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Open in new window

0
 
ArneLoviusCommented:
oh, in which case you only have 100mb half duplex on those ports

what is the output from

sh int fa 0/1

Open in new window

0
 
koop1koopAuthor Commented:
Router(config)#sh int ethernet 0/1
                 ^
% Invalid input detected at '^' marker.
Router#show interface ethernet 0/0
Ethernet0/0 is up, line protocol is down
  Hardware is AmdP2, address is 0002.b918.3160 (bia 0002.b918.3160)
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 140/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:06, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     86 packets output, 6815 bytes, 0 underruns
     86 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     86 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Open in new window

0
 
ArneLoviusCommented:
oops, my error

sh int eth 0/1

Open in new window


if it shows line protocol down

on the 2824

int 48
speed-duplex 100-half

Open in new window


then do

sh int eth 0/1

Open in new window


again and post the result
0
 
koop1koopAuthor Commented:
should I have them both connected at this point?
0
 
ArneLoviusCommented:
yes :-)
0
 
koop1koopAuthor Commented:
Ok connected we have the following:

 
HP2848

; J4904A Configuration Editor; Created on release #I.10.77

hostname "ProCurve Switch 2848" 
ip default-gateway 192.168.5.10 
sntp server 192.168.5.10 
ip routing 
timesync sntp 
sntp unicast 
snmp-server community "public" Unrestricted 
vlan 1 
   name "vlan1" 
   untagged 1,19-48 
   ip address 192.168.5.2 255.255.255.0 
   no untagged 2-18 
   exit 
vlan 2 
   name "vlan2" 
   untagged 2-9 
   no ip address 
   tagged 48 
   exit 
vlan 3 
   name "vlan3" 
   untagged 10 
   no ip address 
   tagged 48 
   exit 
vlan 4 
   name "vlan4" 
   untagged 11-14,18 
   no ip address 
   tagged 48 
   exit 
vlan 5 
   name "vlan5" 
   untagged 15-17 
   no ip address 
   tagged 48 
   exit 
gvrp 
ip route 0.0.0.0 0.0.0.0 192.168.5.10

Open in new window

Cisco 2600

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.1
 encapsulation dot1Q 1 native
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 102.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 102.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 102.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Open in new window

0
 
ArneLoviusCommented:
on the 2600, can you post the output from

show port capabilities eth0/0

and

show port capabilities eth1/0
0
 
ArneLoviusCommented:
IP routing also needs to be enabled on the 2600

conf t
ip routing

Open in new window


0
 
koop1koopAuthor Commented:

show port capabilities eth0/0, show port capabilities eth1/0
neither work the show
Router(config)#show port capabilities eth0/0
                 ^
% Invalid input detected at '^' marker.

Router(config)#show port capabilities eth1/0
                 ^
% Invalid input detected at '^' marker.
Using 1404 out of 29688 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.1
 encapsulation dot1Q 1 native
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 102.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 102.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 102.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Open in new window

0
 
ArneLoviusCommented:
okay, how about

sh int eth 0/1

Open in new window


IP routing still needs to be enabled on the 2600
0
 
koop1koopAuthor Commented:
Router(config)#sh int eth 0/1
                 ^
% Invalid input detected at '^' marker.
Using 1404 out of 29688 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.1
 encapsulation dot1Q 1 native
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 102.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 102.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 102.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Open in new window

0
 
koop1koopAuthor Commented:
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#ip routing
Router(config)#

on the last config above I had done this, does it show?
0
 
ArneLoviusCommented:
no, the line "ip routing" is not shown in the config

you need to come out of conf mode before doing the "sh int eth 0/1"
0
 
koop1koopAuthor Commented:
Router#show interface eth 0/1
% Ambiguous command:  "show interface eth 0/1"

Is there another way to do the ip routing, it does not give an error when issuing the command
0
 
koop1koopAuthor Commented:
It will show if I type the following

Router#show interface Ethernet 0/1
Ethernet0/1 is up, line protocol is up
  Hardware is AmdP2, address is 0002.b918.3161 (bia 0002.b918.3161)
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:05, output 00:00:06, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     710 packets input, 48916 bytes, 0 no buffer
     Received 661 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     120 packets output, 10974 bytes, 0 underruns
     0 output errors, 0 collisions, 7 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
0
 
ArneLoviusCommented:
okay, the interface is up :-)

try doing a "wri mem" and then posting the output from "sh run" again
0
 
koop1koopAuthor Commented:
Building configuration...

Current configuration : 1411 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.1
 encapsulation dot1Q 1 native
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 102.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 102.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 102.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
0
 
ArneLoviusCommented:
can you ping between devices in different VLANS ?
0
 
koop1koopAuthor Commented:
No, I tried
192.168.5.1
192.168.6.1
192.168.7.1
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.1
 encapsulation dot1Q 1 native
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 192.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 192.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 192.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Open in new window

0
 
ArneLoviusCommented:
from the management station on 192.168.5.10 can you ping

192.168.5.2

and

192.168.5.1
0
 
koop1koopAuthor Commented:
I can ping 192.168.5.2 but not 192.168.5.1 destination unreachable
0
 
ArneLoviusCommented:
if port 0/1 on the 2600 is connected to port 48 on the 2824 this should work

can you post copies of both configs as they are now and confirm the ports connecting the two devices

0
 
koop1koopAuthor Commented:
Does it need to be a crossed lead?  
; J4904A Configuration Editor; Created on release #I.10.77

hostname "ProCurve Switch 2848" 
ip default-gateway 192.168.5.10 
sntp server 192.168.5.10 
ip routing 
timesync sntp 
sntp unicast 
snmp-server community "public" Unrestricted 
vlan 1 
   name "vlan1" 
   untagged 1,19-48 
   ip address 192.168.5.2 255.255.255.0 
   no untagged 2-18 
   exit 
vlan 2 
   name "vlan2" 
   untagged 2-9 
   no ip address 
   tagged 48 
   exit 
vlan 3 
   name "vlan3" 
   untagged 10 
   no ip address 
   tagged 48 
   exit 
vlan 4 
   name "vlan4" 
   untagged 11-14,18 
   no ip address 
   tagged 48 
   exit 
vlan 5 
   name "vlan5" 
   untagged 15-17 
   no ip address 
   tagged 48 
   exit 
gvrp 
ip route 0.0.0.0 0.0.0.0 192.168.5.10

Open in new window

Router#sh run
Building configuration...

Current configuration : 1411 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.1
 encapsulation dot1Q 1 native
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 192.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 192.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 192.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Open in new window

0
 
ArneLoviusCommented:
no, it doesn't need to be a crossover as the 2824 is auto MDI/MDIX

lets try changing VLAN 1 to be tagged on the 2824 and the 2600

on the 2824

conf t
vlan 1 
   name "vlan1" 
   untagged 1,19-47
   ip address 192.168.5.2 255.255.255.0 
   no untagged 2-18
   tagged 48
   exit 

Open in new window


on the 2600

conf t
no interface Ethernet0/1.1
interface Ethernet0/1.1
 encapsulation dot1Q 1
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
 exit

Open in new window




0
 
ArneLoviusCommented:
please post configs again after you have done this, and test from the management station if you can ping

192.168.5.2
192.168.5.1

if both of these work, then try to ping

192.168.6.1
0
 
koop1koopAuthor Commented:
It is still the same

[root@PELCO root]# ping 192.168.5.2
PING 192.168.5.2 (192.168.5.2) 56(84) bytes of data.
64 bytes from 192.168.5.2: icmp_seq=1 ttl=64 time=5.36 ms
64 bytes from 192.168.5.2: icmp_seq=2 ttl=64 time=0.537 ms
64 bytes from 192.168.5.2: icmp_seq=3 ttl=64 time=0.546 ms

[root@PELCO root]# ping 192.168.5.1
PING 192.168.5.1 (192.168.5.1) 56(84) bytes of data.
From 192.168.5.10 icmp_seq=2 Destination Host Unreachable

; J4904A Configuration Editor; Created on release #I.10.77

hostname "ProCurve Switch 2848" 
ip default-gateway 192.168.5.10 
sntp server 192.168.5.10 
ip routing 
timesync sntp 
sntp unicast 
snmp-server community "public" Unrestricted 
vlan 1 
   name "vlan1" 
   untagged 1,19-47 
   ip address 192.168.5.2 255.255.255.0 
   tagged 48 
   no untagged 2-18 
   exit 
vlan 2 
   name "vlan2" 
   untagged 2-9 
   no ip address 
   tagged 48 
   exit 
vlan 3 
   name "vlan3" 
   untagged 10 
   no ip address 
   tagged 48 
   exit 
vlan 4 
   name "vlan4" 
   untagged 11-14,18 
   no ip address 
   tagged 48 
   exit 
vlan 5 
   name "vlan5" 
   untagged 15-17 
   no ip address 
   tagged 48 
   exit 
gvrp 
ip route 0.0.0.0 0.0.0.0 192.168.5.10

Open in new window

Building configuration...

Current configuration : 1411 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.1
 encapsulation dot1Q 1 native
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 192.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 192.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 192.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Open in new window

0
 
ArneLoviusCommented:
the 2600 config doesn't show the change
0
 
koop1koopAuthor Commented:
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no interface Ethernet0/1.1
Not all config may be removed and may reappear after reactivating the sub-interf
ace
Router(config)#interface Ethernet0/1.1
Router(config-subif)# encapsulation dot1Q 1
Router(config-subif)# ip address 192.168.5.1 255.255.255.0
Router(config-subif)# ip helper-address 192.168.5.10
Router(config-subif)# no snmp trap link-status
Router(config-subif)# exit

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.1
 encapsulation dot1Q 1 native
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 192.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 192.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 192.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Open in new window

0
 
ArneLoviusCommented:
hmmm

conf t
int eth 0/1.1
no encap dot1q 1 native
encap dot1q 1
exit
wri mem

Open in new window


then post the config again




0
 
koop1koopAuthor Commented:
Building configuration...

Current configuration : 1373 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.1
 encapsulation dot1Q 1 native
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 192.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 192.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 192.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
0
 
ArneLoviusCommented:
still not right


interface Ethernet0/1.1
 encapsulation dot1Q 1 native
 ip helper-address 192.168.5.10
 no snmp trap link-status

Open in new window


needs to be

interface Ethernet0/1.1
 encapsulation dot1Q 1 
 ip helper-address 192.168.5.10
 no snmp trap link-status

Open in new window


notice teh lack of "native" on the second one
0
 
koop1koopAuthor Commented:
every time I remove the line and add the one you suggest it keeps coming back as native
0
 
ArneLoviusCommented:
okay, in which case , lets use a new VLAN and move the configs around

on the 2600

conf t
no int eth 0/1.1
int eth 0/1.50
 encapsulation dot1Q 50
  ip address 192.168.5.1 255.255.255.0
  no snmp trap link-status
exit

Open in new window


on the 2848

conf t
vlan 1 
   name "vlan1" 
   no untagged 1-47
   untagged 48
   exit 

vlan 50 
   name "vlan50" 
   untagged 1,19-47 
   ip address 192.168.5.2 255.255.255.0 
   tagged 48 
   no untagged 2-18 
   exit 

Open in new window


then post updated configs from both the 2600 and the 2824 and try and ping 192.168.5.1 from the management station again
0
 
koop1koopAuthor Commented:
This is what we have now, I can also ping

[root@PELCO root]# ping 192.168.5.2
PING 192.168.5.2 (192.168.5.2) 56(84) bytes of data.
64 bytes from 192.168.5.2: icmp_seq=1 ttl=64 time=5.43 ms
64 bytes from 192.168.5.2: icmp_seq=2 ttl=64 time=0.548 ms
[root@PELCO root]# ping 192.168.6.1
PING 192.168.6.1 (192.168.6.1) 56(84) bytes of data.
64 bytes from 192.168.6.1: icmp_seq=1 ttl=255 time=1.98 ms
64 bytes from 192.168.6.1: icmp_seq=2 ttl=255 time=1.89 ms


 
; J4904A Configuration Editor; Created on release #I.10.77

hostname "ProCurve Switch 2848" 
ip default-gateway 192.168.5.10 
sntp server 192.168.5.10 
ip routing 
timesync sntp 
sntp unicast 
snmp-server community "public" Unrestricted 
vlan 1 
   name "vlan1" 
   untagged 48 
   no ip address 
   no untagged 1-47 
   exit 
vlan 2 
   name "vlan2" 
   untagged 2-9 
   no ip address 
   tagged 48 
   exit 
vlan 3 
   name "vlan3" 
   untagged 10 
   no ip address 
   tagged 48 
   exit 
vlan 4 
   name "vlan4" 
   untagged 11-14,18 
   no ip address 
   tagged 48 
   exit 
vlan 5 
   name "vlan5" 
   untagged 15-17 
   no ip address 
   tagged 48 
   exit 
vlan 50 
   name "vlan50" 
   untagged 1,19-47 
   ip address 192.168.5.2 255.255.255.0 
   tagged 48 
   exit 
gvrp 
ip route 0.0.0.0 0.0.0.0 192.168.5.10

Open in new window

Building configuration...

Current configuration : 1374 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 192.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 192.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 192.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.50
 encapsulation dot1Q 50
 ip address 192.168.5.1 255.255.255.0
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Open in new window


0
 
ArneLoviusCommented:
okay you now have routing going via the 2600 :-)

I would next test DHCP on each VLAN

I'd be interested in the output from the below on the 2600

show ip dvmrp route

Open in new window




0
 
koop1koopAuthor Commented:
that line does not do anything, the same as ip routing

Router#show ip dvmrp route
Router#

DHCP
Works in
192.168.6.1
192.168.7.1
192.168.8.1
192.168.9.1
but not in 192.168.5.1
0
 
ArneLoviusCommented:
as VLAN 50 is directly connected to the DHCP server, there should not be a helper-address required, but you can try adding it

conf t
interface Ethernet0/1.50
 ip helper-address 192.168.5.10
exit

Open in new window


to enable multicast routing

conf t
ip multicast-routing
exit

Open in new window


can you also post the output from

show ip route

Open in new window


and also post the output from

show ip dvmrp route

Open in new window

0
 
koop1koopAuthor Commented:
Router#show ip dvmrp route
Router#
The above does not show an output

DHCP does not work with 192.168.5.1

Router#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.5.10 to network 0.0.0.0

C    192.168.8.0/24 is directly connected, Ethernet0/1.4
C    192.168.9.0/24 is directly connected, Ethernet0/1.5
C    192.168.5.0/24 is directly connected, Ethernet0/1.50
C    192.168.6.0/24 is directly connected, Ethernet0/1.2
C    192.168.7.0/24 is directly connected, Ethernet0/1.3
S*   0.0.0.0/0 [1/0] via 192.168.5.10

Open in new window

Current configuration : 1428 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
ip multicast-routing
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.6.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.3
 encapsulation dot1Q 3
 ip address 192.168.7.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.4
 encapsulation dot1Q 4
 ip address 192.168.8.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.5
 encapsulation dot1Q 5
 ip address 192.168.9.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
interface Ethernet0/1.50
 encapsulation dot1Q 50
 ip address 192.168.5.1 255.255.255.0
 ip helper-address 192.168.5.10
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.10
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Open in new window

0
 
ArneLoviusCommented:
in which case I would suggest checking the configuration of your DHCP server, the rest should now work
0
 
koop1koopAuthor Commented:
I have fixed that, it gets DHCP now 192.168.5.0 at the top of the Vlan.jpg had replaicated itself?!?!
which showed a missing default route in Vlan3.jpg
Vlan.jpg
Vlan2.jpg
Vlan3.jpg
0
 
ArneLoviusCommented:
in which case you should now be able to start connecting the Endura equipment :-)
0
 
koop1koopAuthor Commented:
Yeh, i started to do that, but I still cannot see the units in the other Vlans apart from the one my computer is connected to.
DHCP.jpg
units.jpg
0
 
ArneLoviusCommented:
you could try this on the 2600

conf t
int eth 0/1.2
ip pim state-refresh origination-interval 60
ip pim dense-mode
int eth 0/1.3
ip pim state-refresh origination-interval 60
ip pim dense-mode
int eth 0/1.4
ip pim state-refresh origination-interval 60
ip pim dense-mode
int eth 0/1.5
ip pim state-refresh origination-interval 60
ip pim dense-mode
int eth 0/1.50
ip pim state-refresh origination-interval 60
ip pim dense-mode
exit
wri mem

Open in new window


then post the output of

show ip pim interface

Open in new window

0
 
koop1koopAuthor Commented:
That works!!!
but as you said "the router and it _will_ become a bottleneck" it is very slow and the video breaks up!

Last question..

Can you suggest a router that would work that is not heave on the pocket or even a switch?
Router#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
192.168.6.1      Ethernet0/1.2            v2/D   0      30     1      192.168.6.
1
192.168.7.1      Ethernet0/1.3            v2/D   0      30     1      192.168.7.
1
192.168.8.1      Ethernet0/1.4            v2/D   0      30     1      192.168.8.
1
192.168.9.1      Ethernet0/1.5            v2/D   0      30     1      192.168.9.
1
192.168.5.1      Ethernet0/1.50           v2/D   0      30     1      192.168.5.
1
Router#

Open in new window

0
 
ArneLoviusCommented:
I  have a feeling that if you had a 2600 that would do full duplex you might be able to get away with it

Where geographically are you ?







0
 
koop1koopAuthor Commented:
Multicare Electronics, Leeds, west Yorkshire
http://www.multicare.org.uk


0
 
ArneLoviusCommented:
I did wonder if you were on this side of the Atlantic even though your timezone shows as GMT -7 :-)

If you can get one, a Cisco 3750 with a recent image would suit you well, however this will probably be in the thousands.

A MikroTik 750GL might do you http://routerboard.com/RB750GL

Available in the UK http://linitx.com/product/13148 

have a look at their wiki http://wiki.mikrotik.com/wiki/Manual:Routing/Multicast 

I have no experience of configuring them, but I am available for hire :-)
0
 
koop1koopAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for koop1koop's comment http:/Q_27383434.html#36931230

for the following reason:

Thank you for all your help
0
 
ArneLoviusCommented:
I think the points should actually be awarded to me...
0
 
koop1koopAuthor Commented:
sorry I clicked the wrong button!

Thanks again for your help
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 49
  • 43
  • 4
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now