Cisco SRP527W & Sierra Compass 888 dongle not connecting

I am trying to get a connection through a Cisco SRP527W router using a Sierra Compass 888 dongle, but getting the mobile network status of "Card Not Matched" (from the router interface).

I have tried the dongle directly in a laptop and connect without any problem proving the card and dongle work ok, but I need to go through the router.

I have tried various ways of connecting (auto, manual - entering the APN etc.) but it always says "card not matched" and the connect button is unavailable.
fred2k3Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

fred2k3Author Commented:
ok, sorted it now by upgradng to firmware 1.1.24
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.