Ex2010 Resource Booking Attendant

Hello all -

We are in the process of moving Exchange 2010 (SP1 rollup 5) from an older server to a new beefier box.  The process we are using is simply installing Ex2010 on he new server and moving everything to it and then we'll remove the old server.

Up to now, all has been fine.  What we noticed today is that when we move a room resource mailbox to the new server, the auto-accept stops working.  In looking at it further, we noticed that we cannot enable the Resource Booking Attendant on the new server - the checkbox for that is grayed out in the EMC when we open properties on a room resource mailbox.

The attchment is a screenshot of what the properties look like and you will notice the 'locked' chekbox as well as several mising tabs.

I think I am just missing something simlpe here, but I was unable to find any good info on the web in regards to this.  I found a lot about how to create room resources and all, but not much about the Resource Booking Attendant or its workings.

Any help would be appreciated.

Thanks!

PS - the Mailbox Assistant service is started (even restarted) on the new server.

screenshot.jpg
LVL 1
dasmail2000Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gravy-xCommented:
The screenshot looks like it's a user mailbox and not a resource mailbox. Can you run the command below to verify?
get-mailbox -identity "Blue Conference Area" | format-list resourcetype
0
dasmail2000Author Commented:
Here is the output from that:

ResourceType : Room


(And thanks for taking the time to look at this.)
0
dasmail2000Author Commented:
Any thoughts anyone?
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

gravy-xCommented:
I can't help but think that looks just like a user mailbox. As a last resort, I'd export the calendar data, delete and recreate the mailbox, and reimport.
0
dasmail2000Author Commented:
I tried to create a new room mailbox and it fails stating that there is "no provisioning handler is installed".

I can find next to nothing on this error.

Anyone have any ideas?

Thanks in advance.
0
gravy-xCommented:
Could either be a permissions error or a failed install of the Mailbox role. Is the new beefier server running 2008R2? Did it meet all the prerequisites?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dasmail2000Author Commented:
It is running 2008R2 and as far as I know all the prerequisities are good.

Since you specifically asked about R2, is there something about R2 that I have missed?

We do have user mailboxes on that server and hey seem fine.

I did run the BPA and I got an error stating "The System Attendant homeMDB attribute is missing".  I went thorugh http://technet.microsoft.com/en-us/library/dd535374(EXCHG.80).aspx to address it - or tried to anyway.  The steps they list are:

1.Start the ADSI Edit tool. To do this, click Start, click Run, type adsiedit.msc, and then click OK.

2.Connect to the Configuration container if ADSI Edit is not already connected. To do this, follow these steps:

a.On the Action menu, click Connect to.
b.In the Select a well known Naming Context list, click Configuration, and then click OK.

3.Expand the following path:

Configuration [<domainController>.contoso.com]
CN=Configuration,DC=contoso,DC=com
CN=Services
CN=Microsoft Exchange
CN=<OrganizationName>
CN=Administrative Groups
CN=Exchange Administrative Group (<ID>)
CN=Servers
CN=<MailboxServerName>
CN=Information Store
CN=<StorageGroupName>

4.In the details pane, right-click the CN=<DataBaseName> entry that has a Class value of msExchPrivateMDB, and then click Properties.

5.On the Attribute Editor tab, click distinguishedName, and then click View.

6.Copy the path that appears in the Value box, and then click Cancel.

7.Click Cancel, and then exit the ADSI Edit tool.

The problem I found is that there is nothing in under CN=Information Store on either server as seen here:


Thoughts?
adsi.jpg
0
dasmail2000Author Commented:
As a side note, prioir to installing Exchange I did do the following:

Open PowerShell and run: Import-Module ServerManager
With PowerShell still open run: Add-WindowsFeature NET-Framework,RSAT-ADDS,Web-Server,Web-Basic-Auth,Web-Windows-Auth,Web-Metabase,Web-Net-Ext,Web-Lgcy-Mgmt-Console,WAS-Process-Model,RSAT-Web-Server,Web-ISAPI-Ext,Web-Digest-Auth,Web-Dyn-Compression,NET-HTTP-Activation,RPC-Over-HTTP-Proxy -Restart

0
dasmail2000Author Commented:
Scratch the previous part about adsiedit - I was experiencing a severe brain cramp.  I think I might have it taken care of....I'll let you know.

0
dasmail2000Author Commented:
The actual answer was the SP1 was somehow messed up.  As soon as I reapplied it for the second time, everytyhing worked just fine.

I am awarding points not for the solution but rather for the effort - so thanks.

Sorry I did not do this sooner.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.