Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

HP-UX nfs problem

Posted on 2011-10-06
5
Medium Priority
?
1,068 Views
Last Modified: 2013-12-06
Hii all,
I have 2 HP-UX servers. Server1 is HP-UX 11.11.  Server2 is new HP-UX 11.31.
On Server2, I enter SAM and share a local filesystem /d01.
On Server1, I enter SAM and mount Server2 remote filesystem as /rd01
However, on server1 I only can read the /rd01. When I try to create directory, it shows Read-only file system.
May I know how to configure it correctly so that /rd01 can be full access?

Regards,
Vince
0
Comment
Question by:generait
  • 2
  • 2
5 Comments
 
LVL 38

Expert Comment

by:yuzh
ID: 36928985
Check your HP box you make your you have setup the export permissions correctly
(check /etc/exports file), to make sure you allow root access from the NFS client.

man exports
to learn more details.

or have a look at
http://ods.com.ua/win/eng/unix/usail/man/hpux/exports.4.html

also have a look at:
http://hp-ux-11i.blogspot.com/2010/12/nfs-in-hp-ux.html
0
 
LVL 9

Expert Comment

by:parparov
ID: 36933754
if only root has this problem, add 'no_root_squash' to the options of the export. If any user has problem, then you're likely to be either exporting or mounting the system read-only, so you need to check both export and mount options.
0
 

Accepted Solution

by:
generait earned 0 total points
ID: 36965844
Finally I found the problem was due to missing /etc/nsswitch.conf in the nfs server
After manually create this file, the access problem is solved.
0
 

Author Closing Comment

by:generait
ID: 36984689
Problem solved after manually add /etc/nsswitch.conf file
0
 
LVL 38

Expert Comment

by:yuzh
ID: 36968054
Hi generait,

     Good to know you have found the solution fot the problem, please PAQ/ refund and close the question.

     Have a nice weekend to all of you!
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Attention: This article will no longer be maintained. If you have any questions, please feel free to mail me. jgh@FreeBSD.org Please see http://www.freebsd.org/doc/en_US.ISO8859-1/articles/freebsd-update-server/ for the updated article. It is avail…
When you do backups in the Solaris Operating System, the file system must be inactive. Otherwise, the output may be inconsistent. A file system is inactive when it's unmounted or it's write-locked by the operating system. Although the fssnap utility…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses
Course of the Month11 days, 13 hours left to enroll

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question