• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 307
  • Last Modified:

IE 9 error on specific web page: "Could not initialize the browser's security component."...

Every time a specific file is opend internally with IE 9 the following message pops up.
Could not initialize the browser's security component.  The most likely cuase is problems with files in your browser's profile directory.  Please check that this directory has no read/write restrictions and your hard disk is not full or close to full. It is recommended that you exit the browser and fix teh problem.  If you continue to use this browser session, you might see incorrect broswer behavior when accessing security features.

Most of the resolutions are related to Mozilla/Firefox.  This computer is fairly fresh out of the box and has no other browser installed except for IE9.  And... the hard drive has plety of space.  I was referred to 1 source that stated go to the APPDATA folder of the user and make the cert8.db file read/write but there was no such file there.

Any ideas would be greatly appreciated.
0
toadman
Asked:
toadman
  • 4
  • 2
4 Solutions
 
jcimarronCommented:
toadman--Yes, most references are for Firefox, but the same fixes might apply to IE 9
http://www.sevenforums.com/browsers-mail/143223-internet-explorer-wether-32-64-bit.html

You could also try a repair of IE9
http://support.microsoft.com/kb/318378

Are you saying this happens with only one file?

P.S. cert8.db is indeed a Firefox file and not part of IE.
0
 
jcimarronCommented:
toadman--It is possible to uninstall/reinstall IE9, but it is a little complicated, so post back if the above has not helped.
It might be interesting to install Firefox, see if you have the same problem and apply the fixes for FF that you have found.  That may also clear IE.
Have you tried starting IE9 with no add-ons?
Start|All Programs|Accessories|System Tools|Internet Explorer (No add-ons)
0
 
jcimarronCommented:
toadman--In view of the message that there is a problem with the browser's security component, you may want to try IE Tools|Internet Options|Security tab|click Internet (or are you talking about an Intranet file?)|and click Default Level if that option is available.
And something else to try is to Reset IE9.  
http://support.microsoft.com/kb/923737
Note you will be losing any customizations you have made.  That is explained in the link.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
toadmanAuthor Commented:
Thank you all for your quick response.  In the end it was a lot of tweaking in the IE Options / Advanced tab.  A little too much to describe in detail but non the less it is working now.
0
 
toadmanAuthor Commented:
Thank you all for ideas and suggestions.  This made me really dig deep into the Advanced Options Tab and tweak the settings until I came up with the right a solution.
0
 
jcimarronCommented:
toadman--You are most welcome!
0

Featured Post

2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now