?
Solved

Automounting Home folder on login OS X

Posted on 2011-10-06
11
Medium Priority
?
454 Views
Last Modified: 2012-05-12
hi all -

odd question. I have a group of users (staff) that have their network shares on my domain controller (windows server 2003: file server, mail server, dc, dns, dhcp, wins) and a group of users (students) that have their network shares on another server (windows server 2008 r2: application server, file services, iis, wds, wsus).

When a staff member logs into a mac running os x 10.6 with their network credentials (all macs have been joined to the domain), their user share mounts automatically and an icon is placed in the doc. When a student logs into the same machine (or any machine) running os x 10.6 with their network credentials, a '?' appears in the doc with the label "USERNAME's Network Home". No folder is actually mounted and clicking on the '?' does nothing. I AM able to manually mount the share (finder > connect to server > path) and it connects without prompting for the users credentials.

I'm assuming that this has something to do with the configuration of my Server 2008 R2 box, since it's working fine for users connected to the server 2003 box, but I cannot find any differences in the file services configuration that would lead to this. I can't have users (especially students) mounting their own network shares whenever they login.

Help! Thanks in advance
0
Comment
Question by:SJATechsupport
  • 7
  • 4
11 Comments
 
LVL 12

Accepted Solution

by:
nxnw earned 2000 total points
ID: 36932205
HAve you tried setting up a student account on the 2003 server and a staff account on the 2008 server to confirm that it is a config issue (rather than, for instance, a privileges issue)?

What mechanism is being used to automount the home directories?
0
 

Author Comment

by:SJATechsupport
ID: 36932914
I haven't but will try that. and I'm using the 'home folder' option in the AD account properties
0
 
LVL 12

Expert Comment

by:nxnw
ID: 36933126
I do not know windows server, but the equivalent mechanism in OS X Server will not work unless the share point containing the home directories is configured to enable automount. Does this mean anything in Windowese?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 

Author Comment

by:SJATechsupport
ID: 36933133
Each user in active directory has a share that maps (the windows equivalent of automouting) when the user logs in.
0
 

Author Comment

by:SJATechsupport
ID: 36933159
It IS a permissions thing. I created a test staff account with it's share on the 2008 box and a test student account with it's share on the 2003 box and the staff worked and student didn't. Completely opposite as before.
I wonder if it's because staff are administrators and students are not.. any way I can get around this?
0
 
LVL 12

Expert Comment

by:nxnw
ID: 36933222
"Each user in active directory has a share that maps (the windows equivalent of automouting) when the user logs in"
This is the same with OS X Server — you set a Home URL and path for each user in Open Directory —  BUT setting the sharepoint as "automount enabled" is a separate thing.

Have you looked at the group settings for staff and students to see how they are different?
0
 

Author Comment

by:SJATechsupport
ID: 36933237
Like i said in my last post - the staff are administrators and the students are not. I might try making the students administrators on the macs through ad uc, but i don't know if that will work.
0
 
LVL 12

Expert Comment

by:nxnw
ID: 36933334
I am assuming that there are other characteristics of the groups, aside from the fact that staff are administrators.

I think you should also look at the permissions and settings for the sharepoints.

0
 

Assisted Solution

by:SJATechsupport
SJATechsupport earned 0 total points
ID: 36933412
Making the original student account an administrator fixed the problem..
0
 

Author Closing Comment

by:SJATechsupport
ID: 36954309
Changing user permissions fixed the problem
0
 

Author Comment

by:SJATechsupport
ID: 36933997
I gave the students 'List Directory Contents' rights on the root of their network share and everything is working A OK now
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…
Suggested Courses

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question