ODBC connection failing

We are running ACT 2010; MS ACCESS 2007 on Win 7 PC's.  ACCESS has been programed using ACCESS and Visual Basic to link to data from ACT.  ACT is resident database; ACCESS is the reporting tool for Data.

ACT/ACCESS marriage worked perfectly on a Win 2003 server environment.  We recently upgraded PDC to Win 2008.  All converted perfectly but ACT/ACCESS.  Took some time to get SQL happy.  ACT is now working OK (although much slower than previously).  ACCESS is issue.  We cannot get ACCESS to stay connected to the ODBC.  Connection is inconsistent from user to user / desktop to desktop.  Error msg:  cannot connect to ODBC.  Sometimes you get error - other times you don't.  If you click OK (once or numerous time) you may evenutally connect.  Sometimes you can connect to the application ok, but when you navigate to a different section of the application, the connection fails.

IT have given up and say it is NOT server related.  The ACCESS programmer cannot find anyting correct or wrong with the coding.

All are frustrated and at a loss.  Help
max-a-millionAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Netman66Commented:
Try recreating the ODBC connection using the 32-bit tool found here:  C:\Windows\SysWOW64\odbcad32.exe


I suspect it's a 64-bit to 32-bit app issue.

0
max-a-millionAuthor Commented:
Thank you for responding.  I'll try this this morning and get back to you. This issue has some very GOOD IT pros totally stumped.
0
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
If that didn't help:
1. What full version of server OS - SP1, R2, x32 or x64?
2. What version of SQL - 2005Ex (as shipped) or x64 or 2008?
3. What ver/build of ACT! (from Help About)? If not 12.1, apply SP1. If 12.1, but not hotfix 5, apply hotfix5... note ALL systems sharing database (LAN or Sync) must be on same build

Also, is that the full error?
Any error in event log (client or server)?

Any reason you're using ODBC? OLEDB is usually easier
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

max-a-millionAuthor Commented:
Thank you for your comments.  As it turns out, the problem was identified and resolved as follows.
IT had already considered the 32/64 bit conflict.  Appreciate your response.

                This problem occurs because the TCP Chimney Offload feature is enabled on the server. The TCP Chimney Offload feature is enabled by the Windows Server 2003 Scalable Networking Pack.
Typically, this problem occurs when the network adapter uses the Broadcom 5708 chipset. For example, the following network adapters use the Broadcom 5708 chipset:
•      Broadcom NetXtreme II
•      Hewlett-Packard NC373i Multifunction Gigabit Server Adapter
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
max-a-millionAuthor Commented:
I was the one who solved the issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Applications

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.