• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 405
  • Last Modified:

Remote Desktop Into My Windows 7 PC at home

Hi

I've got virgin broadband and a netgear router, with a Windows 7 machine.  On the Windows 7 I've enabled Remote Desktop.  The router has remote management enabled.  How do I connect to my machine using remote desktop from the internet?  

Philip
0
philanderson888
Asked:
philanderson888
  • 5
  • 5
  • 2
  • +1
1 Solution
 
Brian GeeCommented:
Register an account on DynDNS, then use your DynDNS account info to populate the necessary fields in the DDNS section of your Netgear router's interface.

Port forward port 3389 and ensure the IP address of the computer you want to connect to remotely is set as well.
0
 
David Johnson, CD, MVPOwnerCommented:
If you are using home premium at home you can't remote in using rdp.. suggest logmeinfree
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
As stated, you need Pro or Ultimate (or Enterprise) to enable remote access... since you stated "I've enabled Remote Desktop" I'll assume you have Pro or Ultimate.  In which case, you do as yobri stated and that way, you and everyone else on the internet can connect to your computer.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
David Johnson, CD, MVPOwnerCommented:
in your router you need to forward the port 3389 tcp to the internal ip address of your machine.. if you know your public ip address you can from a remote location
bring up the remote desktop client http://www.portforward.com will help you here

DO NOT enable remote managment of your router as it allows others from the internet to attempt to gain control of your router.. if you need it I suggest at minimum a 10 character password
0
 
philanderson888Author Commented:
I still need a little help.

I've checked the Windows 7 firewall for 3389 to be opened both inbound and outbound.

I've fixed the IP address of my windows 7 machine to be static.

I've implemented port forwarding on tcp/udp port 3389 to this fixed IP address

I've launched the Remote Desktop client from a remote location and typed in the public IP address of my router (also tried the Dynamic DNS name which I have set up with www.dyndns.org and implemented on my router) and the connection is still failing.  

I'm not sure where to begin troubleshooting the issue.

I've even installed LogMeIn on the computer in question just so I can troubleshoot it from two locations at once.

Thanks for your help.

Phil
0
 
Brian GeeCommented:
Ensure the port forwarding you've setup on the router is under the Port Range Forwarding section. Which model of router are you using, by the way?

Afterward, simply typing in something like philanderson888.dyndns.org from an RDP client should connect without issue...
0
 
philanderson888Author Commented:
Port Forwarding Set Up On My Router To Port 3389
I think I've set it up right - screenshot included.

Router model is Netgear WGR614-9VGUKS by the way.

 Showing router public IP address
Screenshot also included of router showing public IP address so we can bypass Dynamic DNS for the purposes of troubleshooting surely?

0
 
Brian GeeCommented:
There looks to be a radio button near the number 1 in the Port Forwarding screenshot that looks like it ought to be set/clicked....
0
 
Brian GeeCommented:
Go to whatismyip.com and see what your public IP address displays there.
0
 
philanderson888Author Commented:
Hi Yobri

Re the radio button, it's there for selection only if the item is to be edited or deleted and it cannot be selected otherwise - on screen refresh it 'unselects'.

Phil
whatismyip.png
0
 
philanderson888Author Commented:
Public Router IP
0
 
Brian GeeCommented:
I just tried an RDP connection to the IP address of the first screenshot and I got a login prompt successfully... looks like you're all configured correctly at this point.
0
 
philanderson888Author Commented:
Hi Yobri

You've solved the whole issue for me - the reason it did not work was nothing to do with my router settings but port 3389 outbound is blocked at my work so your test this morning which worked revealed all!

Thanks Yobri for your help!

Phil
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 5
  • 5
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now