• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 276
  • Last Modified:

How do I get a SharePoint WCF to find it's type?

I am trying to set up a WCF service in SharePoint. My project builds and deploys without error. I am able to navigate to the control on the server.When I actually try to view the control, I get an error telling me that they type could not be found.
In the attached PDF, you can see the files I am working with. Any insight you can give as to why this is happening would be greatly appreciated. O06U1.vsd
0
Rahsaan-Pringle
Asked:
Rahsaan-Pringle
1 Solution
 
Rahsaan-PringleAuthor Commented:
Chris Beckett over at SharePointBits.com has been helping me out with this. I downloaded one of his projects from the following page
[http://blog.sharepointbits.com/2010/04/custom-wcf-services-in-sharepoint-2010_17.html]
 I was able to get HIS project working, but when I tried to duplicate it on another project, I got the same results. Attached is the second screenshot I sent to him, which shows how I was able to get his project up, but my duplicate is still missing something.
O06T2.pdf
0
 
GeorgeGerguesCommented:
Did you deploy that dll on the GAC and Add it as a safe control ?
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now