?
Solved

Problems creating a lInked server

Posted on 2011-10-06
3
Medium Priority
?
179 Views
Last Modified: 2012-05-12
I am having trouble creating a linked server from a win 2003 32bit SQL 2000 to a Win 2008 64 Bit SQL 2008 server.  I am able to create the linked server via the wizard with no errors, but when I try to test the connection I get the attached error. error message
0
Comment
Question by:red_75116
3 Comments
 
LVL 21

Accepted Solution

by:
JestersGrind earned 2000 total points
ID: 36928513
It looks like it's failing authentication.  Open the properties of the linked server.  Under the security tab, select "Be made using the login's security context" if you are using Windows authentication.  If you are using SQL authentication or your Windows account doesn't have access to the remote server, select "Be made using this security context" and use a SQL security username and password for the remote server.

Greg

0
 
LVL 5

Expert Comment

by:AlokJain0412
ID: 36928994
This error will occur if the correct provider was not selected in the New Linked Server dialog.

Try This
Resolution/Workaround:
To resolve this issue, do the following:
1.  If you still have the error message up, select ‘No’ to prevent the creation of the linked server.  This will take you back to the New Linked Server dialog and will give you the opportunity to select the correct provider from the Provider drop down list.  The correct provider is the Microsoft OLE DB for ODBC Drivers.

2. If you have already closed the error message, you will need to delete the linked server and recreate it.  To delete the linked server, right-click on the linked server and click on ‘Delete’.  When recreating the linked server, be sure to choose the Microsoft OLE DB for ODBC Drivers provider from the Provider drop down list.

If the provided Resolution/Workaround does not resolve your issues, please contact BizNet Software Support for further assistance.

Or



1)Ping that server to make sure basic level configuration is set up right like allow Remote connections, TCP/IP etc.

Open Linked server properties and check for these things
2) on Security Tab correct security option is checked
3) On Server Options Tab make sure Data Access, RPC, RPC Out is true
4) Select providers under Linked server and make sure "ALLOW IN Process" is enabled and your linked server can be seen at the bottom of the provider options window

Cheers
0
 

Author Comment

by:red_75116
ID: 36937671
Just to confirm- the correct provide for 2008 to 2000 sql is Microsoft OLE DB for ODBC Drivers...
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

     When we have to pass multiple rows of data to SQL Server, the developers either have to send one row at a time or come up with other workarounds to meet requirements like using XML to pass data, which is complex and tedious to use. There is a …
Long way back, we had to take help from third party tools in order to encrypt and decrypt data.  Gradually Microsoft understood the need for this feature and started to implement it by building functionality into SQL Server. Finally, with SQL 2008, …
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
With just a little bit of  SQL and VBA, many doors open to cool things like synchronize a list box to display data relevant to other information on a form.  If you have never written code or looked at an SQL statement before, no problem! ...  give i…

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question