• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4051
  • Last Modified:

Supervisor won't boot on Cisco 4500

I specified an IOS image that is not in bootflash using the boot system command.

Now the switch tries to load that image and goes into rommon.

I have tried changing the confreg to 0x2101, 0x2102 and 0x2142 but no luck.

How can I make the switch stop looking for the image that is not there and use the old image that is in bootflash?

Or am I going to have to use xmodem to copy the image to bootflash?
0
Dragon0x40
Asked:
Dragon0x40
  • 2
  • 2
2 Solutions
 
jabman11Commented:
It would depend on the rommon version the supervisor engine has. Normally when the switch doesn't find the image that is specified with the boot system command, it automatically gives you the option to specify a path for the image (Before going to Rommon mode), so if you know the exact name of the image that is in bootflash, you just need to write "bootflash:image.bin", or "sup-bootflash:image.bin"
Or being in Rommon mode, you should be able to use the command boot, and write "boot bootflash:image.bin" or "boot sup-bootflash:image.bin"
A complementary option for both ways, is that you use a compact flash that has a valid image file, insert it in the slot disk0 or disk1 of the supervisor engine, and specify the path disk0:image.bin (or disk1:image.bin), as above.
Advice after you solve the issue.
If you don't specify the booting image with the boot system command, the switch automatically looks for a valid image file in the bootflash (sup-bootflash), you just have to make sure you have stored a valid .bin file, you can check the MD5 with verify command, adding the path of the image after "verify" with space tab.
Or if you have enough memory to have two image files, you can use two boot system commands with different images, the first one listed in the show running config is the first file for booting process, if it fails, then it continues with the secodn boot command.
0
 
jabman11Commented:
PD: Changing configuration register is useful for password recovery.
0
 
pgstephanCommented:
do you know the name of the old image? If yes, then when on ROMMON try:
boot flash:c4500-x.x.x.x.x

easiest will be to delete the new IOS image from the bootflash, and try the confreg 0x2101 again.
0
 
pgstephanCommented:
altenative could also be that you setup a TFTP server with the IOS images, then when on ROMMON, use:
boot tftp://172.18.125.3/cat4000-is-mz.121-11b.EW

refer to this link for more info:
http://www.cisco.com/en/US/products/hw/switches/ps663/products_configuration_example09186a0080094ecf.shtml
0
 
Dragon0x40Author Commented:
I copied the new IOS to bootflash: but not slavebootflash:

Set the "boot system flash bootflash:cat4500-xxxxxx1.bin"
Both supervisors tried to boot cat4500-xxxxxx1.bin

One supervisor had both IOS images but one only had the original IOS image.

The sup with one IOS tried to boot from the non-existent IOS and ignored the other IOS image and went into rommon>

I used the "set" command showed all boot variables

"clear boot" did not help and started giving me the following message:
Autobooting using BOOT variable specified file..... Could not find a valid file in BOOT environment variable. BOOT variable can be set from IOS. To find
set command showed no boot file

booted into the IOS using the command rommon 2 >boot bootflash:cat4500-xxxxx2.bin

switch successfully booted up so I could tftp ios file to the bootflash

entered "boot system flash bootflash:cat4500-xxxxxx1.bin" into running-config

"show bootvar" still showed no valid boot file

"wr mem" and then "show bootvar" showed a valid boot file

Switch#sh bootvar
BOOT variable = bootflash:cat4500-xxxxxx1.bin,1;
CONFIG_FILE variable does not exist
BOOTLDR variable does not exist
Configuration register is 0x2102

Standby not ready to show bootvar

rebooted and both supervisors booted correctly.

rommon is not very helpful at telling you what commands are available and what they do.

rommon 2 >boot bootflash:cat4500-xxxxx2.bin should have been the first command that I ran after the supervisor had problems booting.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now