?
Solved

Exchange 2010 Activesync with DROID

Posted on 2011-10-06
9
Medium Priority
?
543 Views
Last Modified: 2012-05-12
Hello.  I have been trying to find a solution to this for the last few days and cannot find it.

We have moved from Exchange 2003 to Exchange 2010.  The problem we are having is with activesync.  On our HTC Droid phones I can setup the activesync with the server and it seems to work fine.  I see it bring down the mail, contacts, and calendar just fine.  Then after that is done it seems to stop updating the calendar.  

I have checked the security of the accounts having the issue and that is correct.
I have removed and reset the sync on the phone and it does the same thing.
We have a SSL cert from GoDaddy that points to mail.domain.com
When I look at the logs i see Android-EAS/2.0 & Android-EAS/0.1
Does this matter?
Could this be a Droid version problem?
0
Comment
Question by:Matt Horning
  • 3
  • 3
  • 2
  • +1
9 Comments
 
LVL 6

Expert Comment

by:sumit_arora
ID: 36929225
1) if other phone like Windows mobile and Iphone etc are working fine and you dont see any errors in it. Then its Android issue.

0
 
LVL 10

Expert Comment

by:gaurav05
ID: 36929543
Hi,

have you update exchange 2010 with sp 1 ?

plz provide android version ?

if your android version is 2.2 then check this policies

http://www.sysadminlab.net/activesync/android-2-2-and-activesync-policies-a-complete-guide-what-works
0
 

Expert Comment

by:Prabhajee
ID: 36929627
1) Did you recheck the settings under "Settings->Account & sync->Exchange ActiveSync->Calender" is checked to get updates?
2) Have you set the ActiveSync to Push updates?

With regard
Prabhajee
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Expert Comment

by:Prabhajee
ID: 36929640
If you had a SSL cert  error most probably the ActiveSync wont work at all. I guess it should be somewhere under Droid settings.
0
 

Author Comment

by:Matt Horning
ID: 36933990
OK FOLLOW UP:

gaurav05:
I am pretty sure we put SP1 on.  We are at v14.1 (Build 218.15) Enterprise
The Android Versions we are at are both 2.2 and 2.3.3 both do NOT work
Thankyou for the link.  The only change I made was unchecked "Allow non-provisionable devices"

Prabhajee:
Yes the calendar is checked
and what do you mean "Have you set the ActiveSync to Push update"?  Do I have to turn this on on the server?

I have tested this with an iPhone and it works fine.

Thanks for the help really!
0
 
LVL 6

Expert Comment

by:sumit_arora
ID: 36934859
so its clear,issue is with android  
0
 

Expert Comment

by:Prabhajee
ID: 36936643
Ok.. its clear then. If it works fine with iOS, the server configuration should be fine too.
Try changing update schedule of the ActiveSync settings on DROID to "PUSH"
If you use "htc sense" on your work station and plug the HTC on that WS meanwhile you sync you HTC with Exchange it'll get confused. try not to use "htc sense" at all, and then configure Exchange ActiveSync once again on the HTC.
Did you try accepting an event invitation on the HTC, and then check whether it would sync with the respective Exchange mailbox (in Outlook)?
0
 

Accepted Solution

by:
Matt Horning earned 0 total points
ID: 36965573
OK after 2 hours on the phone with HTC and a couple weeks Googling this here is what they said.

Click Menu | Settings | Applications | Manage Applications | All Applications | Calendar Storage
Clear Data
Remove Active Sync Account
Pull Battery | Wait 1 min
Replace and boot phone
Setup Active Sync Account again

It now seems to be syncing calendar events back up to exchange.

It was nice of the guy to tell me they are aware of this issue with Exchange 2010 and he said there would be a update to address this.  He did not know if it would be from Microsoft or from Android
0
 

Author Closing Comment

by:Matt Horning
ID: 37010547
HTC phone call has solved this.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
How to effectively resolve the number one email related issue received by helpdesks.
how to add IIS SMTP to handle application/Scanner relays into office 365.
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question