User keeps being routed to wrong server

I have a user who has his homepage in his browser set to a DNS entry. This DNS entry changed about 3 months ago to be resolved to a new server. Unfortunately he is still being routed to the old on. I have checked his hosts file in the default location and there is nothing in there.

How can this be? The only thing I can think of is his system is using a different hosts file, how would I know this though?
Lico_wAsked:
Who is Participating?
 
ChiefITConnect With a Mentor Commented:
DNS troubleshooting made Easy:

Follow the path your DNS query takes you:
http://www.experts-exchange.com/Networking/Protocols/DNS/A_323-DNS-Troubleshooting-made-easy.html

Check your DNS server's Host A records and also make sure you don't have the wrong HOST file location. There are two of these HOST files.
0
 
setasoujiroConnect With a Mentor Commented:
first of all issue the command : ipconfig /flushdns
then try and ping the hostname and see if it resolves correct
0
 
Martin_J_ParkerCommented:
Also use nslookup to see which default DNS server Windoze thinks is in use and what the name resolves to within DNS.
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
Lico_wAuthor Commented:
Thanks but the server's been changed 3 months, I don't think the DNS server cache would last that long. Also other people in the same location don't have the issue
0
 
Martin_J_ParkerCommented:
I seem to remember that there was a rootkit which redirected some DNS addresses , so could be worth trying a malware scan.

I would do the "ipconfig /flushdns" command anyway in case the DNS TTL (Time To Live) setting has been screwed up somehow.  I believe the TTL is usually in the region of a day or two, but if set wrong could last a long time.

You can turn off the client side dns cache if you want to test if that's giving problems. Use the command:
net stop dnscache
0
 
Martin_J_ParkerCommented:
Take a look at this:
http://support.microsoft.com/kb/318803

About 1/4 of the way down is a section called "Using the Registry to Control the Caching Time"
It would be worth checking that the TTL settings haven't been created/modified by some program.
Check that the settings on that machine are the same as the others that do work correctly.
0
 
Martin_J_ParkerCommented:
Sorry - it's closer to 1/2 way down the page.  :-)
0
 
JammyPakCommented:
ok, simple but I assume they've cleared their browser cache?
0
 
mkuehngoeCommented:
do you have an entry in the HOST file on that machine?
0
 
Lico_wAuthor Commented:
Hi Chief, great article thanks, can you elaborate on where the 2nd hosts file location is, as none of the above worked so I can only assume this is the problem (I couldn't see this detailed in the article).

Thanks in advance
0
 
ChiefITCommented:
In windows:

This is the host file that effects DNS resolution:  
C:\Windows\system32\drivers\ect\Host

The second (fake) host file is located:
(don't remember and it's really irrelevant)

For 64 Bit OS on, it's located in a slightly different location:
http://support.microsoft.com/kb/972034

So, it not only depends on the operating system, it also depends upon location if you are editing the correct host file.
0
 
JammyPakConnect With a Mentor Commented:
not to be picky, but the file must be called 'hosts' not 'host' in order to work. I would empty that file and just use DNS to remove future problems

maybe you're thinking of the lmhosts file in the same folder...leave that one with a .sam extension so it doesn't get used. otherwise there's only 1 real 'hosts' file...

cheers
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.