Force PST Path Change In Outlook 2003,2007 and 2010

I am trying to change the PST path in Outlook 2003, 2007 and 2010 clients via Group Policy Management Console on windows Server 2008 dmoain controller.  I've installed the ADM for Outlook 2003, Outlook 2007 and 2010 and have entered the path in the policy and enabled the policy (only on Outlook 2007 & -2010 as Oulook 2003 is handled via registry hack).

---The old path is \\servername\shared_folder\username.pst  
---I want the new path to be a file cluster name:  \\filecluster\pst\username\%username%.pst  

I've made the policy change for both Outlook 2007 and Outlook 2010 (since their same policy object, it's easy to do).  I've forced the policy update on a test machine, but when I look in Outlook 2010 and Outlook 2007, they both show the autoarchive path is still local.  I don't understand why the path won't change.

--I am already aware of Microsoft's stance on PST files on a network share, so no need to elaborate on that.
--Also, I have a test OU and a group with test users to apply the GPO to.

I discovered the GPO deal DOES work, but only with NEW profiles.  This doesn't help me with existing outlook profiles - I cannot delete those, so it's not even an option.  I need to know how to make the PST redirection work...step-by-step on exisiting profiles.

Can anyone tell me what the problem is with getting the path to change on 2007 and 2010 and show me step-by-step how to correct this?  Also how can I do this for my Outlook 2003 too?  This is a production problem for me, so your assistance is GREATLY needed.

Thanks!
LVL 1
MonterioAsked:
Who is Participating?
 
e_aravindConnect With a Mentor Commented:
The reson for my .prf files is that
- AutoArchiveFileName values can be best controlled by creating\modifying the Outlook profiles than a mere registry keys

Options
1. if needed we can create new profile along with the AutoArchiveFileName value
2. modify the options...so the existing profiles could be modified?
0
 
apache09Commented:
Not sure if it can be done via GPO.

If you use an Admin Install on Office 2007/2010
There is an option in OUtlook\Misc to change the default location of PSTs and OSTs

However, I believe these options, just as in the GPO, only work if they are local Locations

Microsoft doesn not support PSTs on a network location.
Which is why all PSTs are defaulted to be saved in My Documents

0
 
e_aravindCommented:
ForcePST
-> this will determine the PST location for the user created PST Files and not for the auto-archive settings

Individual AutoArchive settings not stored in registry
http://support.microsoft.com/kb/198479

How to set the location of an archive .pst file in Outlook
http://support.microsoft.com/kb/836755

note: in the above article, you need to concentrate @ AutoArchiveFileName

0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

 
alwayzexchangeCommented:
If we want to do it from client itself.
Here is a registry hack to force the PST Path. This can either be done before you add the account to Outlook or if you need to move existing PST files. In the later case you need to move the PST files from the default location to the new location as well.

Close Outlook and Locate Outlook in the registry (regedit.exe).

Outlook 2003: HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\

Outlook 2007: HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\

Outlook 2010: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\

Then create a new Expandable String Value named ForcePSTPath and as value enter the path where you want the PST files to be.

Now start Outlook and the new path should be used.

I'm not sure but this artcile might have some info (there are 3 parts):
http://www.msexchange.org/articles_tutorials/exchange-server-2007/management-administration/managing-outlook-2007-through-group-policies-part1.html

0
 
MonterioAuthor Commented:
Thanks for the response, gentlemen!  i do appreciate your assistance.  However, here's where I am with those suggestions:

Apache09 - I'm aware of Microsoft's stance on this (as I noted in my question).  I know the GPO option is "do-able" because I've got it to work via GPO.  The problem is that it only works on new profiles, not existing.  Please refer to the 4th paragraph of my question.

Alwayzexchange - I tried these settings and they only work on new profiles, not exisiting ones.

e_aravind - I will try this, but I think it only works, again, with new profiles...I'll check and get back to you on this.  
0
 
MonterioAuthor Commented:
Again, thanks to you all for your assitance.  I'll check back in shortly with the results.
0
 
samiam41Commented:
Brilliant work experts (and thanks to Monterio for asking a question that has been nagging at me!)

As time permits, if anyone can solve my riddle, I would appreciate it greatly!

http://www.experts-exchange.com/Software/Office_Productivity/Groupware/Outlook/Q_27492174.html
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.